aboutsummaryrefslogtreecommitdiff
path: root/audio/taglib-extras
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-08-07 17:04:34 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-08-07 17:04:34 +0000
commitadd7e9f258087ed73bc223023eac8fda3aaeb9ce (patch)
tree67f47825441581a4b3008c69ac8c64565453b9d1 /audio/taglib-extras
parent00567a5048c91872c3a64ac16d8d34bc224f4dc4 (diff)
downloadports-add7e9f258087ed73bc223023eac8fda3aaeb9ce.tar.gz
ports-add7e9f258087ed73bc223023eac8fda3aaeb9ce.zip
This splits the taglib plugins that used to be in Amarok into a separate
package, for use by amarok-utils as well as Amarok itself (plus anyone else that wants to use it). WWW: http://websvn.kde.org/trunk/kdesupport/taglib-extras/ (it required for upcoming amarok 2.1.1 update) Submitted by: Matt Tosto <datahead4 at gmail.com>
Notes
Notes: svn path=/head/; revision=239091
Diffstat (limited to 'audio/taglib-extras')
-rw-r--r--audio/taglib-extras/Makefile37
-rw-r--r--audio/taglib-extras/distinfo3
-rw-r--r--audio/taglib-extras/pkg-descr5
-rw-r--r--audio/taglib-extras/pkg-plist31
4 files changed, 76 insertions, 0 deletions
diff --git a/audio/taglib-extras/Makefile b/audio/taglib-extras/Makefile
new file mode 100644
index 000000000000..7a2e8740aeeb
--- /dev/null
+++ b/audio/taglib-extras/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: taglib-extras
+# Date created: Thu Aug 14 12:50:02 EDT 2008
+# Whom: Matt Tosto <datahead4@gmail.com>
+#
+# $FreeBSD$
+
+PORTNAME= taglib-extras
+PORTVERSION= 0.1.6
+CATEGORIES= audio
+MASTER_SITES= http://www.kollide.net/~jefferai/
+
+MAINTAINER= datahead4@gmail.com
+COMMENT= Extra taglib features for Amarok 2.1
+
+LIB_DEPENDS= tag.6:${PORTSDIR}/audio/taglib
+
+USE_KDE4= automoc4 kdehier
+USE_QT_VER= 4
+QT_COMPONENTS= corelib qmake_build moc_build rcc_build uic_build phonon
+USE_CMAKE= yes
+
+OPTIONS= KDE4_MIME "Resolve file types with KMimeTypeResolve" ON
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITHOUT_KDE4_MIME)
+CMAKE_ARGS+= -DWITH_KDE:BOOL=Off
+.else
+USE_KDE4+= kdelibs
+CMAKE_ARGS+= -DWITH_KDE:BOOL=On
+.endif
+
+post-extract:
+ ${REINPLACE_CMD} -e 's|$${LIB_INSTALL_DIR}/pkgconfig|libdata/pkgconfig|' \
+ ${WRKSRC}/CMakeLists.txt
+
+.include <bsd.port.post.mk>
diff --git a/audio/taglib-extras/distinfo b/audio/taglib-extras/distinfo
new file mode 100644
index 000000000000..614e885d7d47
--- /dev/null
+++ b/audio/taglib-extras/distinfo
@@ -0,0 +1,3 @@
+MD5 (taglib-extras-0.1.6.tar.gz) = 706a82fe4c25606f731faf4c14b5edb0
+SHA256 (taglib-extras-0.1.6.tar.gz) = bfa4ef62ae69168545993dd3472d5a35db7fa2960d64bc8c9e8cff4a1e65081b
+SIZE (taglib-extras-0.1.6.tar.gz) = 49280
diff --git a/audio/taglib-extras/pkg-descr b/audio/taglib-extras/pkg-descr
new file mode 100644
index 000000000000..d166d7b19fd2
--- /dev/null
+++ b/audio/taglib-extras/pkg-descr
@@ -0,0 +1,5 @@
+This splits the taglib plugins that used to be in Amarok into a separate
+package, for use by amarok-utils as well as Amarok itself (plus anyone
+else that wants to use it).
+
+WWW: http://websvn.kde.org/trunk/kdesupport/taglib-extras/
diff --git a/audio/taglib-extras/pkg-plist b/audio/taglib-extras/pkg-plist
new file mode 100644
index 000000000000..a6e2d654c236
--- /dev/null
+++ b/audio/taglib-extras/pkg-plist
@@ -0,0 +1,31 @@
+bin/taglib-extras-config
+include/taglib-extras/asfattribute.h
+include/taglib-extras/asffile.h
+include/taglib-extras/asffiletyperesolver.h
+include/taglib-extras/asfproperties.h
+include/taglib-extras/asftag.h
+include/taglib-extras/audiblefile.h
+include/taglib-extras/audiblefiletyperesolver.h
+include/taglib-extras/audibleproperties.h
+include/taglib-extras/audibletag.h
+include/taglib-extras/mp4atom.h
+include/taglib-extras/mp4file.h
+include/taglib-extras/mp4filetyperesolver.h
+include/taglib-extras/mp4item.h
+include/taglib-extras/mp4properties.h
+include/taglib-extras/mp4tag.h
+include/taglib-extras/realmediafile.h
+include/taglib-extras/realmediafiletyperesolver.h
+include/taglib-extras/taglib-extras_export.h
+include/taglib-extras/tdebug.h
+include/taglib-extras/tfile_helper.h
+include/taglib-extras/tplugins.h
+include/taglib-extras/wavfile.h
+include/taglib-extras/wavfiletyperesolver.h
+include/taglib-extras/wavproperties.h
+lib/libtag-extras.so
+lib/libtag-extras.so.0
+lib/libtag-extras.so.0.1.0
+libdata/pkgconfig/taglib-extras.pc
+@dirrmtry lib/pkgconfig
+@dirrm include/taglib-extras