aboutsummaryrefslogtreecommitdiff
path: root/audio/taglib
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2013-10-09 09:24:24 +0000
committerJason E. Hale <jhale@FreeBSD.org>2013-10-09 09:24:24 +0000
commiteac4e56163d5104c0aeed15cc08dea935e978066 (patch)
tree1f69703e9e23076f0b6c8d41a61a836e2da40f46 /audio/taglib
parent34232c71a3dfd4058fad27eb7e1d84f117436a53 (diff)
downloadports-eac4e56163d5104c0aeed15cc08dea935e978066.tar.gz
ports-eac4e56163d5104c0aeed15cc08dea935e978066.zip
- Support staging
- Use options helpers - Use new LIB_DEPENDS syntax
Notes
Notes: svn path=/head/; revision=329876
Diffstat (limited to 'audio/taglib')
-rw-r--r--audio/taglib/Makefile20
1 files changed, 7 insertions, 13 deletions
diff --git a/audio/taglib/Makefile b/audio/taglib/Makefile
index 8a5ea82fca3b..236f63e373af 100644
--- a/audio/taglib/Makefile
+++ b/audio/taglib/Makefile
@@ -14,25 +14,19 @@ LICENSE= LGPL21 MPL
LICENSE_COMB= dual
LICENSE_FILE_MPL= ${WRKSRC}/COPYING.MPL
-OPTIONS_DEFINE= RCC
-
-RCC_DESC= Build with RusXMMS librcc patches (experimental)
-
USES= cmake
-NO_STAGE= yes
CMAKE_ARGS= -DWITH_ASF:BOOL=ON \
-DWITH_MP4:BOOL=ON
USE_LDCONFIG= yes
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= RCC
+OPTIONS_SUB= yes
-.if ${PORT_OPTIONS:MRCC}
-EXTRA_PATCHES+= ${FILESDIR}/extrapatch-rcc
-LIB_DEPENDS+= rcc:${PORTSDIR}/devel/librcc
-PLIST_SUB+= RCC=""
-.else
-PLIST_SUB+= RCC="@comment "
-.endif
+RCC_DESC= Build with RusXMMS librcc patches (experimental)
+RCC_EXTRA_PATCHES= ${FILESDIR}/extrapatch-rcc
+RCC_LIB_DEPENDS= librcc.so:${PORTSDIR}/devel/librcc
+
+.include <bsd.port.options.mk>
post-patch:
.if ${PORT_OPTIONS:MRCC}