aboutsummaryrefslogtreecommitdiff
path: root/audio/taglookup
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-02-19 09:04:48 +0000
committerJohn Marino <marino@FreeBSD.org>2015-02-19 09:04:48 +0000
commit336e01bba79b398e2d0dfb1f5698b6053b36dc7f (patch)
treeeb4ded65dcd716ee10e98211e2969808f1bbc854 /audio/taglookup
parentdadadc8ced4e198c58830fd7c6fa99ef9f7d55dd (diff)
downloadports-336e01bba79b398e2d0dfb1f5698b6053b36dc7f.tar.gz
ports-336e01bba79b398e2d0dfb1f5698b6053b36dc7f.zip
audio/taglookup: Respect CXXFLAGS (PHB 12.9)
While here, fix LDFLAGS and use the BSD_INSTALL_* macros instead of hardcoding modes. Approved by: blanket
Notes
Notes: svn path=/head/; revision=379334
Diffstat (limited to 'audio/taglookup')
-rw-r--r--audio/taglookup/files/patch-Makefile21
1 files changed, 13 insertions, 8 deletions
diff --git a/audio/taglookup/files/patch-Makefile b/audio/taglookup/files/patch-Makefile
index ddf6cc62aa28..5773cd88b7bb 100644
--- a/audio/taglookup/files/patch-Makefile
+++ b/audio/taglookup/files/patch-Makefile
@@ -1,22 +1,27 @@
---- ./Makefile.orig 2007-10-29 13:02:54.000000000 +0100
-+++ ./Makefile 2014-04-07 10:15:45.329720325 +0200
-@@ -4,7 +4,7 @@
+--- Makefile.orig 2007-10-29 12:02:54 UTC
++++ Makefile
+@@ -4,10 +4,10 @@ LIBCDDB_LIBRARY = `pkg-config --libs lib
TAGLIB_INCLUDE = `taglib-config --cflags`
TAGLIB_LIBRARY = `taglib-config --libs`
-CPP = g++
+CPP = $(CXX)
- CPPFLAGS = -Wall $(TAGLIB_INCLUDE) $(LIBCDDB_INCLUDE) -c
- LDFLAGS = $(TAGLIB_LIBRARY) $(LIBCDDB_LIBRARY)
-@@ -18,8 +18,8 @@
+-CPPFLAGS = -Wall $(TAGLIB_INCLUDE) $(LIBCDDB_INCLUDE) -c
+-LDFLAGS = $(TAGLIB_LIBRARY) $(LIBCDDB_LIBRARY)
++CPPFLAGS = ${CXXFLAGS} -Wall $(TAGLIB_INCLUDE) $(LIBCDDB_INCLUDE) -c
++LDFLAGS+= $(TAGLIB_LIBRARY) $(LIBCDDB_LIBRARY)
+
+ OBJ = cddb_query.o cddb_query_impl.o command_line.o main.o tag.o tracks.o
+ EXE = taglookup
+@@ -18,8 +18,8 @@ EXE = taglookup
all: $(EXE)
install: $(EXE)
- $(INSTALL) -c -o root -g wheel -m 644 taglookup.1 $(PREFIX)/man/man1/taglookup.1
- $(INSTALL) -c -o root -g wheel -m 755 $(EXE) $(PREFIX)/bin/taglookup
-+ $(INSTALL) -c -m 644 taglookup.1 $(DESTDIR)$(PREFIX)/man/man1/taglookup.1
-+ $(INSTALL) -c -m 755 $(EXE) $(DESTDIR)$(PREFIX)/bin/taglookup
++ $(BSD_INSTALL_MAN) taglookup.1 $(DESTDIR)$(PREFIX)/man/man1/taglookup.1
++ $(BSD_INSTALL_PROGRAM) $(EXE) $(DESTDIR)$(PREFIX)/bin/taglookup
$(EXE): $(OBJ)
$(CPP) $(LDFLAGS) $(OBJ) -o $(EXE)