aboutsummaryrefslogtreecommitdiff
path: root/audio/tagtool
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-11-11 17:57:46 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-11-11 17:57:46 +0000
commitc0a473ac403eb6ab7ec3741c5a2f2f25cdb11e86 (patch)
tree605a39eae9f2bcb0b8684d4d3743292788b38bba /audio/tagtool
parente2302ad137692aadbd7fc67047a9a779893f5b1d (diff)
downloadports-c0a473ac403eb6ab7ec3741c5a2f2f25cdb11e86.tar.gz
ports-c0a473ac403eb6ab7ec3741c5a2f2f25cdb11e86.zip
Add tagtool, a GNOME 2 application for tagging MP3/OGG files, similar to
Easytag but more lightweight PR: ports/73812 Submitted by: Anthony Ginepro <anthony.ginepro@laposte.net>
Notes
Notes: svn path=/head/; revision=121398
Diffstat (limited to 'audio/tagtool')
-rw-r--r--audio/tagtool/Makefile30
-rw-r--r--audio/tagtool/distinfo2
-rw-r--r--audio/tagtool/pkg-descr22
-rw-r--r--audio/tagtool/pkg-plist21
4 files changed, 75 insertions, 0 deletions
diff --git a/audio/tagtool/Makefile b/audio/tagtool/Makefile
new file mode 100644
index 000000000000..e8a70a5bdb8a
--- /dev/null
+++ b/audio/tagtool/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: tagtool
+# Date created: 1st November 2004
+# Whom: Anthony Ginepro <anthony.ginepro@laposte.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tagtool
+PORTVERSION= 0.11.1
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A GNOME application that tag mp3/ogg files
+
+LIB_DEPENDS= id3-3.8.3:${PORTSDIR}/audio/id3lib \
+ vorbis.3:${PORTSDIR}/audio/libvorbis
+
+USE_X_PREFIX= yes
+USE_LIBTOOL_VER=15
+USE_GMAKE= yes
+
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+USE_GNOME= libglade2
+
+DATADIR= share/tagtool
+
+.include <bsd.port.mk>
diff --git a/audio/tagtool/distinfo b/audio/tagtool/distinfo
new file mode 100644
index 000000000000..78f0e89af37a
--- /dev/null
+++ b/audio/tagtool/distinfo
@@ -0,0 +1,2 @@
+MD5 (tagtool-0.11.1.tar.gz) = df99222a660659e73c30a8946ea7034a
+SIZE (tagtool-0.11.1.tar.gz) = 215470
diff --git a/audio/tagtool/pkg-descr b/audio/tagtool/pkg-descr
new file mode 100644
index 000000000000..822b571a81c8
--- /dev/null
+++ b/audio/tagtool/pkg-descr
@@ -0,0 +1,22 @@
+Audio Tag Tool is a program to manage the information fields in MP3 and
+Ogg Vorbis files, commonly called tags. Tag Tool can be used to edit tags
+one by one, but the most useful features are the ability to easily tag or
+rename hundreds of files at once, in any desired format.
+
+The interface is arranged into two sections, with the list of available
+files on the left and a set of tabs on the right. Each tab corresponds
+to one of the main operations Audio Tag Tool can do:
+
+ * Tag Editor
+ * Tag Multiple Files
+ * Clear Tags
+ * Move/Rename Multiple Files
+ * Create Playlists
+
+The mass tag and mass rename features can handle filenames in any format
+thanks to an easily configurable format template.
+
+WWW: http://pwp.netcabo.pt/paol/tagtool/
+
+- Anthony Ginepro
+anthony.ginepro@laposte.net
diff --git a/audio/tagtool/pkg-plist b/audio/tagtool/pkg-plist
new file mode 100644
index 000000000000..6bc406c85cab
--- /dev/null
+++ b/audio/tagtool/pkg-plist
@@ -0,0 +1,21 @@
+bin/tagtool
+share/gnome/apps/Multimedia/tagtool.desktop
+share/pixmaps/TagTool.png
+%%DATADIR%%/TagTool.png
+%%DATADIR%%/edit.png
+%%DATADIR%%/fail.png
+%%DATADIR%%/file.png
+%%DATADIR%%/folder.png
+%%DATADIR%%/graydot.png
+%%DATADIR%%/greendot.png
+%%DATADIR%%/info.png
+%%DATADIR%%/ok.png
+%%DATADIR%%/preferences.dtd
+%%DATADIR%%/tab_clear.png
+%%DATADIR%%/tab_edit.png
+%%DATADIR%%/tab_playlist.png
+%%DATADIR%%/tab_rename.png
+%%DATADIR%%/tab_tag.png
+%%DATADIR%%/tagtool.glade
+%%DATADIR%%/warn.png
+@dirrm %%DATADIR%%