aboutsummaryrefslogtreecommitdiff
path: root/audio/teamspeak3-server/Makefile
diff options
context:
space:
mode:
authorMichael Scheidell <scheidell@FreeBSD.org>2012-05-04 18:26:13 +0000
committerMichael Scheidell <scheidell@FreeBSD.org>2012-05-04 18:26:13 +0000
commit83a2497645768cdb0c1177728bcf66ad95adf307 (patch)
tree254718478dd3cb3b2b87bcf6890a272680f729e2 /audio/teamspeak3-server/Makefile
parent118b30124d12e7d2e91d8ad9a5afade239b9009c (diff)
downloadports-83a2497645768cdb0c1177728bcf66ad95adf307.tar.gz
ports-83a2497645768cdb0c1177728bcf66ad95adf307.zip
Notes
Diffstat (limited to 'audio/teamspeak3-server/Makefile')
-rw-r--r--audio/teamspeak3-server/Makefile26
1 files changed, 18 insertions, 8 deletions
diff --git a/audio/teamspeak3-server/Makefile b/audio/teamspeak3-server/Makefile
index 3f904fa3ee23..d154ea1d8e84 100644
--- a/audio/teamspeak3-server/Makefile
+++ b/audio/teamspeak3-server/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= teamspeak3-server
-PORTVERSION= 3.0.1
+PORTVERSION= 3.0.3
PORTEPOCH= 1
CATEGORIES= audio net
MASTER_SITES= http://teamspeak.gameserver.gamed.de/ts3/releases/${PORTVERSION}/ \
@@ -16,6 +16,15 @@ DISTNAME= ${PORTNAME}_freebsd-${TEAMSPEAK_ARCH}-${PORTVERSION}
MAINTAINER= hirner@bitfire.at
COMMENT= Server side of the TeamSpeak group voice chat system
+LICENSE= teamspeak
+LICENSE_NAME= TeamSpeak 3.x End User License Agreement
+LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_PERMS= no-dist-mirror no-dist-sell no-pkg-mirror no-pkg-sell
+
+.ifdef (BATCH)
+IGNORE= license ${LICENSE} needs confirmation, but BATCH is defined
+.endif
+
USE_ICONV= yes
USE_LDCONFIG= ${PREFIX}/lib/teamspeak/server
USE_RC_SUBR= teamspeak
@@ -29,13 +38,14 @@ NO_BUILD= yes
USERS= teamspeak
GROUPS= teamspeak
-LICENSE= teamspeak
-LICENSE_NAME= TeamSpeak 3.x End User License Agreement
-LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
-LICENSE_FILE= ${WRKSRC}/LICENSE
-
CONFLICTS= teamspeak_server-[0-9]*
+PLIST_SUB+= DBDIR=${DBDIR} \
+ LOGDIR=${LOGDIR} \
+ USERS=${USERS} \
+ GROUPS=${GROUPS} \
+ BINGRP=${BINGRP}
+
.include <bsd.port.options.mk>
.if ${ARCH} == "i386"
@@ -74,9 +84,9 @@ do-install:
.endif
post-install:
- @${MKDIR} ${DBDIR} && ${CHOWN} -R ${USERS}:${GROUPS} ${DBDIR}
+ @${INSTALL} -d -o ${USERS} -g ${GROUPS} ${DBDIR}
+ @${INSTALL} -d -o ${USERS} -g ${BINGRP} ${LOGDIR}
@${MKDIR} ${ETCDIR}
- @${MKDIR} ${LOGDIR} && ${CHOWN} -R ${USERS}:${BINGRP} ${LOGDIR}
@${CAT} ${WRKDIR}/pkg-message
.include <bsd.port.mk>