aboutsummaryrefslogtreecommitdiff
path: root/audio/timidity++-xaw
diff options
context:
space:
mode:
authorSeiichirou Hiraoka <flathill@FreeBSD.org>1999-10-12 17:07:06 +0000
committerSeiichirou Hiraoka <flathill@FreeBSD.org>1999-10-12 17:07:06 +0000
commitb25b5f13fb40d34929629f4f5395603193c0d0a3 (patch)
treed58affa5efc09e94dadf168ed927104ece93bf44 /audio/timidity++-xaw
parentaa92d4cea4da41cab4b077f5424bb9c79f9be139 (diff)
downloadports-b25b5f13fb40d34929629f4f5395603193c0d0a3.tar.gz
ports-b25b5f13fb40d34929629f4f5395603193c0d0a3.zip
PR: ports/12157
Submitted by: yatt@msc.biglobe.ne.jp Xaw interface for TiMidity++.
Notes
Notes: svn path=/head/; revision=22385
Diffstat (limited to 'audio/timidity++-xaw')
-rw-r--r--audio/timidity++-xaw/Makefile70
-rw-r--r--audio/timidity++-xaw/pkg-comment1
-rw-r--r--audio/timidity++-xaw/pkg-descr9
-rw-r--r--audio/timidity++-xaw/pkg-plist7
4 files changed, 87 insertions, 0 deletions
diff --git a/audio/timidity++-xaw/Makefile b/audio/timidity++-xaw/Makefile
new file mode 100644
index 000000000000..269475e1d636
--- /dev/null
+++ b/audio/timidity++-xaw/Makefile
@@ -0,0 +1,70 @@
+# New ports collection makefile for: TiMidity++
+# Version required: 1.3.10
+# Date created: 27 Feb 1999
+# Whom: Yoichi Asai <yatt@msc.biglobe.ne.jp>
+#
+# $FreeBSD$
+#
+
+DISTNAME= TiMidity++-1.3.10
+PKGNAME= timidity++-xaw-1.3.10
+CATEGORIES= audio
+MASTER_SITES= http://www.goice.co.jp/member/mo/timidity/dist/
+
+MAINTAINER= yatt@msc.biglobe.ne.jp
+
+RUN_DEPENDS= ${PREFIX}/bin/timidity:${PORTSDIR}/audio/timidity++
+LIB_DEPENDS= Xaw3d.6:${PORTSDIR}/x11-toolkits/Xaw3d
+
+# If you don't require Japanese docs, uncomment this.
+#NO_USE_JAPANESE= yes
+
+USE_XLIB= yes
+USE_AUTOCONF= yes
+
+FILESDIR= ${.CURDIR}/../../audio/timidity++/files
+
+DIST_SUBDIR= timidity
+
+.include <bsd.port.pre.mk>
+
+CONFIGURE_ARGS= --prefix=${PREFIX} --with-x \
+ --disable-ncurses --disable-vt100 --disable-tcltk \
+ --disable-emacs --enable-xaw=dynamic --disable-xskin \
+ --disable-motif --disable-slang --disable-gtk \
+ --enable-network --enable-spectrogram --enable-wrd
+.if ${PORTOBJFORMAT} == "elf"
+CONFIGURE_ENV= LDFLAGS=-export-dynamic
+.endif
+
+TIMID_DIR= ${PREFIX}/lib/timidity
+LINK= xawmidi
+DOCFILES= README.xaw
+DOCLANG= C
+.if !defined(NO_USE_JAPANESE)
+DOCLANG+= ja_JP.ujis
+.endif
+
+do-build:
+ cd ${WRKSRC}/interface; ${MAKE}
+
+do-install:
+ cd ${WRKSRC}/interface; ${MAKE} ${INSTALL_TARGET}
+ ${LN} -sf ${PREFIX}/bin/timidity ${PREFIX}/bin/${LINK}
+ @${MKDIR} ${X11BASE}/lib/X11/ja_JP.EUC/app-defaults
+ ${INSTALL_DATA} ${WRKSRC}/TiMidity.ad \
+ ${X11BASE}/lib/X11/app-defaults/TiMidity
+ ${INSTALL_DATA} ${WRKSRC}/TiMidity-uj.ad \
+ ${X11BASE}/lib/X11/ja_JP.EUC/app-defaults/TiMidity
+
+post-install:
+.if !defined(NOPORTDOCS)
+.for lang in ${DOCLANG}
+ @${MKDIR} \
+ ${PREFIX}/share/doc/timidity/`echo ${lang} | ${SED} 's/_JP.ujis//'`
+ ${INSTALL_DATA} ${WRKSRC}/doc/${lang}/${DOCFILES} \
+ ${PREFIX}/share/doc/timidity/`echo ${lang} | ${SED} 's/_JP.ujis//'`
+.endfor
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/audio/timidity++-xaw/pkg-comment b/audio/timidity++-xaw/pkg-comment
new file mode 100644
index 000000000000..a0198f78bfc1
--- /dev/null
+++ b/audio/timidity++-xaw/pkg-comment
@@ -0,0 +1 @@
+Xaw interface for TiMidity++.
diff --git a/audio/timidity++-xaw/pkg-descr b/audio/timidity++-xaw/pkg-descr
new file mode 100644
index 000000000000..35febe7fe1a9
--- /dev/null
+++ b/audio/timidity++-xaw/pkg-descr
@@ -0,0 +1,9 @@
+This port allows you to operate TiMidity++ with Xaw interface.
+
+Formerly, the original version of this program was written by Tuuka
+Toivonen(until version 0.2i).
+Now, Masanao Izumo and many hackers are developing "TiMidity++".
+Official site is
+http://www.goice.co.jp/member/mo/timidity/
+
+Yoichi Asai <yatt@msc.biglobe.ne.jp>
diff --git a/audio/timidity++-xaw/pkg-plist b/audio/timidity++-xaw/pkg-plist
new file mode 100644
index 000000000000..1755333f2503
--- /dev/null
+++ b/audio/timidity++-xaw/pkg-plist
@@ -0,0 +1,7 @@
+bin/xawmidi
+lib/timidity/interface_a.so
+share/doc/timidity/C/README.xaw
+share/doc/timidity/ja/README.xaw
+@cwd /usr/X11R6
+lib/X11/app-defaults/TiMidity
+lib/X11/ja_JP.EUC/app-defaults/TiMidity