aboutsummaryrefslogtreecommitdiff
path: root/audio/timidity++-xskin
diff options
context:
space:
mode:
authorSeiichirou Hiraoka <flathill@FreeBSD.org>1999-10-12 16:40:01 +0000
committerSeiichirou Hiraoka <flathill@FreeBSD.org>1999-10-12 16:40:01 +0000
commitaa92d4cea4da41cab4b077f5424bb9c79f9be139 (patch)
tree17942f0c3e29fca8920d9cbd0cb91373df2c5b86 /audio/timidity++-xskin
parentf9c626bf066d37f906fa07a03386d75d0ac0055b (diff)
downloadports-aa92d4cea4da41cab4b077f5424bb9c79f9be139.tar.gz
ports-aa92d4cea4da41cab4b077f5424bb9c79f9be139.zip
PR: ports/12158
Submitted by: yatt@msc.biglobe.ne.jp X11AMP skin interface for TiMidity++.
Notes
Notes: svn path=/head/; revision=22384
Diffstat (limited to 'audio/timidity++-xskin')
-rw-r--r--audio/timidity++-xskin/Makefile65
-rw-r--r--audio/timidity++-xskin/pkg-comment1
-rw-r--r--audio/timidity++-xskin/pkg-descr13
-rw-r--r--audio/timidity++-xskin/pkg-message11
-rw-r--r--audio/timidity++-xskin/pkg-plist4
5 files changed, 94 insertions, 0 deletions
diff --git a/audio/timidity++-xskin/Makefile b/audio/timidity++-xskin/Makefile
new file mode 100644
index 000000000000..ca6f8f7846c1
--- /dev/null
+++ b/audio/timidity++-xskin/Makefile
@@ -0,0 +1,65 @@
+# New ports collection makefile for: TiMidity++
+# Version required: 1.3.10
+# Date created: 27 Feb 1999
+# Whom: Yoichi Asai <yatt@msc.biglobe.ne.jp>
+#
+# $FreeBSD$
+#
+
+DISTNAME= TiMidity++-1.3.10
+PKGNAME= timidity++-xskin-1.3.10
+CATEGORIES= audio
+MASTER_SITES= http://www.goice.co.jp/member/mo/timidity/dist/
+
+MAINTAINER= yatt@msc.biglobe.ne.jp
+
+RUN_DEPENDS= ${PREFIX}/bin/timidity:${PORTSDIR}/audio/timidity++
+
+# If you don't require Japanese docs, uncomment this.
+#NO_USE_JAPANESE= yes
+
+USE_XLIB= yes
+USE_AUTOCONF= yes
+
+FILESDIR= ${.CURDIR}/../../audio/timidity++/files
+
+DIST_SUBDIR= timidity
+
+.include <bsd.port.pre.mk>
+
+CONFIGURE_ARGS= --prefix=${PREFIX} --with-x \
+ --disable-ncurses --disable-vt100 --disable-tcltk \
+ --disable-emacs --disable-xaw --enable-xskin=dynamic \
+ --disable-motif --disable-slang --disable-gtk \
+ --enable-network --enable-spectrogram --enable-wrd
+.if ${PORTOBJFORMAT} == "elf"
+CONFIGURE_ENV= LDFLAGS=-export-dynamic
+.endif
+
+TIMID_DIR= ${PREFIX}/lib/timidity
+LINK= xskinmidi
+DOCFILES= README.xskin
+DOCLANG= C
+.if !defined(NO_USE_JAPANESE)
+DOCLANG+= ja_JP.ujis
+.endif
+
+do-build:
+ cd ${WRKSRC}/interface; ${MAKE}
+
+do-install:
+ cd ${WRKSRC}/interface; ${MAKE} ${INSTALL_TARGET}
+ ${LN} -sf ${PREFIX}/bin/timidity ${PREFIX}/bin/${LINK}
+
+post-install:
+.if !defined(NOPORTDOCS)
+.for lang in ${DOCLANG}
+ @${MKDIR} \
+ ${PREFIX}/share/doc/timidity/`echo ${lang} | ${SED} 's/_JP.ujis//'`
+ ${INSTALL_DATA} ${WRKSRC}/doc/${lang}/${DOCFILES} \
+ ${PREFIX}/share/doc/timidity/`echo ${lang} | ${SED} 's/_JP.ujis//'`
+.endfor
+.endif
+ @cat ${PKGDIR}/MESSAGE
+
+.include <bsd.port.post.mk>
diff --git a/audio/timidity++-xskin/pkg-comment b/audio/timidity++-xskin/pkg-comment
new file mode 100644
index 000000000000..3a4b814eec75
--- /dev/null
+++ b/audio/timidity++-xskin/pkg-comment
@@ -0,0 +1 @@
+X11AMP skin interface for TiMidity++.
diff --git a/audio/timidity++-xskin/pkg-descr b/audio/timidity++-xskin/pkg-descr
new file mode 100644
index 000000000000..3237896d4770
--- /dev/null
+++ b/audio/timidity++-xskin/pkg-descr
@@ -0,0 +1,13 @@
+This port allows you to operate TiMidity++ with X11AMP skins.
+Please prepare skins and set environment variable.
+
+Ex.
+% setenv timidity_skin ~/.x11amp/Skins/timidity/
+
+Formerly, the original version of this program was written by Tuuka
+Toivonen(until version 0.2i).
+Now, Masanao Izumo and many hackers are developing "TiMidity++".
+Official site is
+http://www.goice.co.jp/member/mo/timidity/
+
+Yoichi Asai <yatt@msc.biglobe.ne.jp>
diff --git a/audio/timidity++-xskin/pkg-message b/audio/timidity++-xskin/pkg-message
new file mode 100644
index 000000000000..fce4d932698e
--- /dev/null
+++ b/audio/timidity++-xskin/pkg-message
@@ -0,0 +1,11 @@
+
+========================================================================
+Please set environment variable to choose skin you like.
+
+Ex.
+% setenv timidity_skin ~/.x11amp/Skins/timidity/
+or
+% setenv timidity_skin /dos/programs/winamp/skins/winamp.zip
+
+========================================================================
+
diff --git a/audio/timidity++-xskin/pkg-plist b/audio/timidity++-xskin/pkg-plist
new file mode 100644
index 000000000000..496be43ec7bd
--- /dev/null
+++ b/audio/timidity++-xskin/pkg-plist
@@ -0,0 +1,4 @@
+bin/xskinmidi
+lib/timidity/interface_i.so
+share/doc/timidity/C/README.xskin
+share/doc/timidity/ja/README.xskin