aboutsummaryrefslogtreecommitdiff
path: root/audio/timidity++/Makefile
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>1996-11-17 11:10:09 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>1996-11-17 11:10:09 +0000
commit09b534a2e190f229847c0ddbda19dbf26b1b44c5 (patch)
tree37feba55bb4754733b16d3b26eefe2a1a1275ac8 /audio/timidity++/Makefile
parent8be09d854e3fba5023ba3efa61d4e7b1865f198f (diff)
downloadports-09b534a2e190f229847c0ddbda19dbf26b1b44c5.tar.gz
ports-09b534a2e190f229847c0ddbda19dbf26b1b44c5.zip
MIDI-to-WAV rendered/player, sounds much better than playmidi
Notes
Notes: svn path=/head/; revision=4543
Diffstat (limited to 'audio/timidity++/Makefile')
-rw-r--r--audio/timidity++/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/audio/timidity++/Makefile b/audio/timidity++/Makefile
new file mode 100644
index 000000000000..a2844fbe46c1
--- /dev/null
+++ b/audio/timidity++/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: timidity
+# Homepage: http://www.clinet.fi/~toivonen/timidity/
+# Version required: 0.2i
+# Date created: 17 Nov 1996
+# Whom: ache
+#
+# $Id: Makefile,v 1.6 1996/11/15 10:52:00 asami Exp $
+#
+
+DISTNAME= timidity-0.2i
+CATEGORIES= audio
+MASTER_SITES= ftp://ftp.cdrom.com/pub/demos/music/samples/ \
+ http://www.clinet.fi/~toivonen/timidity/
+TIINS= dgguspat.zip
+DISTFILES= ${TIINS} ${DISTNAME}.tar.gz
+EXTRACT_ONLY= ${DISTNAME}.tar.gz
+BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
+
+MAINTAINER= ache@FreeBSD.ORG
+
+
+INSTALL_TARGET= install.all
+
+do-configure:
+ @cd ${WRKSRC} && \
+ sed "s=%PREFIX%=${PREFIX}=" < gravis.cfg > gravis.cfg.new && \
+ mv gravis.cfg.new gravis.cfg
+
+post-install:
+ cd ${PREFIX}/lib/timidity/patch && \
+ unzip -q -L ${DISTDIR}${TIINS}
+
+MAN1= timidity.1
+
+.include <bsd.port.mk>