aboutsummaryrefslogtreecommitdiff
path: root/audio/timidity++
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /audio/timidity++
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
downloadports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.tar.gz
ports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.zip
- update png to 1.5.10
Notes
Notes: svn path=/head/; revision=297915
Diffstat (limited to 'audio/timidity++')
-rw-r--r--audio/timidity++/Makefile5
-rw-r--r--audio/timidity++/files/patch-x_sherry.c28
2 files changed, 31 insertions, 2 deletions
diff --git a/audio/timidity++/Makefile b/audio/timidity++/Makefile
index 7214088b3bb0..7d77fc9326a8 100644
--- a/audio/timidity++/Makefile
+++ b/audio/timidity++/Makefile
@@ -7,7 +7,7 @@
PORTNAME= timidity++
PORTVERSION= 2.13.2
-PORTREVISION?= 9
+PORTREVISION?= 10
CATEGORIES+= audio
MASTER_SITES= SF/timidity/TiMidity%2B%2B/TiMidity%2B%2B-${PORTVERSION}
DISTNAME= TiMidity++-${PORTVERSION}
@@ -56,7 +56,8 @@ CONFIGURE_ARGS+=--without-x --disable-spectrogram --disable-wrd --disable-dynami
.else
CONFIGURE_ARGS+=--with-x --enable-spectrogram --enable-wrd --enable-dynamic
USE_XORG= x11 xext
-LIB_DEPENDS+= png:${PORTSDIR}/graphics/png
+LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png
+CPPFLAGS+= -I${LOCALBASE}/include/libpng15
.endif
.if ${HAVE_GNOME:Mesound}!=""
diff --git a/audio/timidity++/files/patch-x_sherry.c b/audio/timidity++/files/patch-x_sherry.c
new file mode 100644
index 000000000000..c33a60cf7ce0
--- /dev/null
+++ b/audio/timidity++/files/patch-x_sherry.c
@@ -0,0 +1,28 @@
+--- interface/x_sherry.c.orig 2002-07-14 23:19:32.000000000 +0200
++++ interface/x_sherry.c 2012-04-27 13:12:58.000000000 +0200
+@@ -34,6 +34,7 @@
+ #endif
+ #include <stdlib.h>
+ #include <png.h>
++#include <pngpriv.h>
+
+ #include "timidity.h"
+ #include "common.h"
+@@ -909,7 +910,7 @@
+ {
+ if(png_get_valid(pngPtr, infoPtr, PNG_INFO_hIST))
+ png_get_hIST(pngPtr, infoPtr, &hist);
+- png_set_dither(pngPtr, palette,
++ png_set_quantize(pngPtr, palette,
+ numPalette, MAX_SCREEN_COLORS, hist, 1);
+ }
+ }
+@@ -934,7 +935,7 @@
+ }
+ }
+ }
+- png_set_dither(pngPtr, stdColorCube,
++ png_set_quantize(pngPtr, stdColorCube,
+ 6*7*6, MAX_SCREEN_COLORS,
+ NULL, 1);
+ /*???*/