aboutsummaryrefslogtreecommitdiff
path: root/audio/timidity
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-01-30 14:54:44 +0000
committerJohn Marino <marino@FreeBSD.org>2016-01-30 14:54:44 +0000
commit2373204770d359edbd852b058f6652008fe95f90 (patch)
tree8edf3e7174631e16d437214726e0e8e905e6c003 /audio/timidity
parent05ff349f831c80858580ad2c4509f37651245cf7 (diff)
downloadports-2373204770d359edbd852b058f6652008fe95f90.tar.gz
ports-2373204770d359edbd852b058f6652008fe95f90.zip
audio/timidy: Respect LDFLAGS, document ncurses requirement
Notes
Notes: svn path=/head/; revision=407528
Diffstat (limited to 'audio/timidity')
-rw-r--r--audio/timidity/Makefile2
-rw-r--r--audio/timidity/files/patch-Makefile21
2 files changed, 16 insertions, 7 deletions
diff --git a/audio/timidity/Makefile b/audio/timidity/Makefile
index 090ebf49fcd2..cfe7d394a903 100644
--- a/audio/timidity/Makefile
+++ b/audio/timidity/Makefile
@@ -16,7 +16,7 @@ CONFLICTS= timidity++-2.*
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= alias
+USES= alias ncurses
TIINS= goemon.tgz
INSTALL_TARGET= install.all
diff --git a/audio/timidity/files/patch-Makefile b/audio/timidity/files/patch-Makefile
index d1c7db256a70..445aafad7d08 100644
--- a/audio/timidity/files/patch-Makefile
+++ b/audio/timidity/files/patch-Makefile
@@ -1,5 +1,5 @@
---- ./Makefile.orig 1996-05-26 09:26:46.000000000 +0000
-+++ ./Makefile 2014-02-06 21:14:36.000000000 +0000
+--- Makefile.orig 1996-05-26 09:26:46 UTC
++++ Makefile
@@ -24,22 +24,22 @@
# But where to change without revealing my secret identity?
@@ -29,7 +29,7 @@
# Where to install the Tcl code, if you use the Tcl code that is.
TCL_DIR = $(TIMID_DIR)
-@@ -112,9 +112,9 @@
+@@ -112,9 +112,9 @@ EXTRALIBS += -lncurses
#EXTRALIBS += -lgen
# Select the Tcl/Tk interface
@@ -42,7 +42,7 @@
#EXTRAINCS +=
#EXTRALIBS +=
-@@ -136,7 +136,7 @@
+@@ -136,7 +136,7 @@ DISTZIP = timid$(FNVERSION).zip
SDIST = timidity-lib-$(SUPPVERSION).tar.gz
SDISTZIP = tilib$(FNSUPPVERSION).zip
@@ -51,7 +51,16 @@
-DTIMID_VERSION=\"$(VERSION)\" $(SYSTEM) $(EXTRAINCS)
########### All relevant files.. Anybody know autoconf?
-@@ -228,10 +228,10 @@
+@@ -220,7 +220,7 @@ spotless: clean
+ $(CC) $(CFLAGS) -c $<
+
+ $(PROJ): $(COBJS)
+- $(CC) $(CFLAGS) -o $(PROJ) $(COBJS) $(EXTRALIBS) -lm
++ $(CC) $(CFLAGS) -o $(PROJ) $(COBJS) $(LDFLAGS) $(EXTRALIBS) -lm
+
+ bag: bag.c
+ $(CC) $(CFLAGS) -o bag bag.c
+@@ -228,10 +228,10 @@ bag: bag.c
wav2pat: wav2pat.c
$(CC) $(CFLAGS) -o wav2pat wav2pat.c
@@ -66,7 +75,7 @@
########### Installation targets
-@@ -249,22 +249,22 @@
+@@ -249,22 +249,22 @@ install.all: install.bin install.man ins
# install.bin: $(PROJ) Dumb make thinks it has to have $(COBJS) to install...
install.bin: