aboutsummaryrefslogtreecommitdiff
path: root/audio/tta
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2005-10-06 07:09:04 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2005-10-06 07:09:04 +0000
commit9112e12f4d58ebb60028e2309d4e07f36a26ab1c (patch)
tree2bcb6d5df8658d34694141b5efbe1f59edf87711 /audio/tta
parent8766c0c5a9c66d0a53cbeab7064d504b0ef9fd36 (diff)
downloadports-9112e12f4d58ebb60028e2309d4e07f36a26ab1c.tar.gz
ports-9112e12f4d58ebb60028e2309d4e07f36a26ab1c.zip
Update audio/tta to 3.3
PR: 86939 Submitted by: dieringe@zedat.fu-berlin.de (maintainer) Approved by: novel (mentor)
Notes
Notes: svn path=/head/; revision=144366
Diffstat (limited to 'audio/tta')
-rw-r--r--audio/tta/Makefile39
-rw-r--r--audio/tta/distinfo4
-rw-r--r--audio/tta/pkg-descr3
-rw-r--r--audio/tta/pkg-plist1
4 files changed, 31 insertions, 16 deletions
diff --git a/audio/tta/Makefile b/audio/tta/Makefile
index 08be4d9f33a6..cc2fb9a47049 100644
--- a/audio/tta/Makefile
+++ b/audio/tta/Makefile
@@ -5,19 +5,24 @@
# $FreeBSD$
#
-PORTNAME= tta
-PORTVERSION= 3.2
-CATEGORIES= audio
-MASTER_SITES= http://www.true-audio.com/ftp/
-DISTNAME= ${PORTNAME}enc-${PORTVERSION}-src
+PORTNAME= tta
+PORTVERSION= 3.3
+CATEGORIES= audio
+MASTER_SITES= http://www.true-audio.com/ftp/
+DISTNAME= ${PORTNAME}enc-${PORTVERSION}-src
-MAINTAINER= dieringe@zedat.fu-berlin.de
-COMMENT= "The True Audio Encoder", lossless (de)compressor
+MAINTAINER= dieringe@zedat.fu-berlin.de
+COMMENT= "The True Audio Encoder", lossless (de)compressor
-USE_ZIP= yes
-USE_GMAKE= yes
-WRKSRC= ${WRKDIR}
-ALL_TARGET=
+USE_ZIP= yes
+
+WRKSRC= ${WRKDIR}
+LDFLAGS+= -lm
+
+PROGRAM= ttaenc
+
+PORTDOCS= Readme
+PLIST_FILES= bin/ttaenc
.include <bsd.port.pre.mk>
@@ -25,4 +30,16 @@ ALL_TARGET=
IGNORE= Requires FreeBSD 5.x or higher for wide character support
.endif
+do-build:
+ ${CC} ${CFLAGS} -c ${WRKSRC}/${PROGRAM}.c -o ${WRKSRC}/${PROGRAM}.o
+ ${CC} ${LDFLAGS} -o ${WRKSRC}/${PROGRAM} ${WRKSRC}/${PROGRAM}.o
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PROGRAM} ${PREFIX}/bin
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
+.endif
+
.include <bsd.port.post.mk>
diff --git a/audio/tta/distinfo b/audio/tta/distinfo
index 277768887766..d33233d74ec4 100644
--- a/audio/tta/distinfo
+++ b/audio/tta/distinfo
@@ -1,2 +1,2 @@
-MD5 (ttaenc-3.2-src.zip) = 317b046027d00972b261d582bc7ef547
-SIZE (ttaenc-3.2-src.zip) = 23552
+MD5 (ttaenc-3.3-src.zip) = 03dbdab2ada063042e01afbb73c75011
+SIZE (ttaenc-3.3-src.zip) = 24092
diff --git a/audio/tta/pkg-descr b/audio/tta/pkg-descr
index f377f11fb828..60a8a9171b7d 100644
--- a/audio/tta/pkg-descr
+++ b/audio/tta/pkg-descr
@@ -1,4 +1,3 @@
-
TTA is a simple lossless audio compressor.
TTA performs lossless compression on multichannel 8,16,24 bit's
@@ -9,7 +8,7 @@ The compression size will generally range between 30% - 70% of the
original. TTA format supports both of ID3v1 and ID3v2 information
tags.
-WWW: http://tta.iszf.irk.ru/
+WWW: http://www.true-audio.com/
- dieringe
dieringe@zedat.fu-berlin.de
diff --git a/audio/tta/pkg-plist b/audio/tta/pkg-plist
deleted file mode 100644
index acd899a6a8fd..000000000000
--- a/audio/tta/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/ttaenc