aboutsummaryrefslogtreecommitdiff
path: root/audio/umodplayer/Makefile
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-09-14 16:25:13 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-09-14 16:25:13 +0000
commit5b3ed27552f7c761a4be4a031123cb9d693ad2d4 (patch)
tree833a9b1a2a254af81b97960677060d6f7d38116d /audio/umodplayer/Makefile
parent30a2ddae5bc580f028e9e3bf9158090dca8e9969 (diff)
downloadports-5b3ed27552f7c761a4be4a031123cb9d693ad2d4.tar.gz
ports-5b3ed27552f7c761a4be4a031123cb9d693ad2d4.zip
Notes
Diffstat (limited to 'audio/umodplayer/Makefile')
-rw-r--r--audio/umodplayer/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/audio/umodplayer/Makefile b/audio/umodplayer/Makefile
new file mode 100644
index 000000000000..31aa3595ff66
--- /dev/null
+++ b/audio/umodplayer/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: umodplayer
+# Date created: 14 September 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= umodplayer
+PORTVERSION= 0.b4
+DISTVERSION= B4
+CATEGORIES= audio
+MASTER_SITES= SF
+DISTNAME= ${PORTNAME}_${DISTVERSION}
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Console module player
+
+LIB_DEPENDS= modplug.0:${PORTSDIR}/audio/libmodplug \
+ ao.3:${PORTSDIR}/audio/libao
+BUILD_DEPENDS= ${LOCALBASE}/lib/libaiff.a:${PORTSDIR}/audio/libaiff
+
+GNU_CONFIGURE= yes
+PLIST_FILES= bin/${PORTNAME}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/CFLAGS =/CFLAGS +=/' ${WRKSRC}/${MAKEFILE}.in
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+
+.include <bsd.port.mk>