aboutsummaryrefslogtreecommitdiff
path: root/audio/umurmur/Makefile
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2014-08-16 21:14:54 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2014-08-16 21:14:54 +0000
commitc48c1b5658a2cb33130987a3f3278929441b4a8a (patch)
treeeb8b161581d4d53d3d04d86b4a91fa1aef49bf9f /audio/umurmur/Makefile
parentf3ff426b004b302d930ff0e8a9f5e703dac04f96 (diff)
downloadports-c48c1b5658a2cb33130987a3f3278929441b4a8a.tar.gz
ports-c48c1b5658a2cb33130987a3f3278929441b4a8a.zip
audio/umurmur: update to 0.2.15
PR: 192177 Submitted by: truckman Approved by: maintainer (timeout)
Notes
Notes: svn path=/head/; revision=365135
Diffstat (limited to 'audio/umurmur/Makefile')
-rw-r--r--audio/umurmur/Makefile16
1 files changed, 11 insertions, 5 deletions
diff --git a/audio/umurmur/Makefile b/audio/umurmur/Makefile
index 244390158eb5..8d4c2a8ac60c 100644
--- a/audio/umurmur/Makefile
+++ b/audio/umurmur/Makefile
@@ -2,18 +2,24 @@
# $FreeBSD$
PORTNAME= umurmur
-PORTVERSION= 0.2.13
-PORTREVISION= 1
+PORTVERSION= 0.2.15
CATEGORIES= audio net
-MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
MAINTAINER= ayu@commun.jp
COMMENT= Minimalistic Murmur (Mumble server)
+LICENSE= BSD2CLAUSE
+
LIB_DEPENDS= libconfig.so:${PORTSDIR}/devel/libconfig \
libprotobuf-c.so:${PORTSDIR}/devel/protobuf-c
-USES= gmake
+USE_GITHUB= yes
+GH_ACCOUNT= fatbob313
+GH_COMMIT= 17daa7e
+
+USES= gmake libtool
+USE_AUTOTOOLS= aclocal autoconf autoheader automake
+AUTOMAKE_ARGS= --add-missing
GNU_CONFIGURE= yes
USE_OPENSSL= yes
CONFIGURE_ARGS= --with-ssl=openssl
@@ -24,7 +30,7 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
post-patch:
- @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/src/conf.h
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/configure.ac
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/src/conf.c
@${REINPLACE_CMD} \
-e 's|/etc/|${PREFIX}/etc/|g' ${WRKSRC}/umurmur.conf.example