aboutsummaryrefslogtreecommitdiff
path: root/audio/vgmplay
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2019-04-06 18:31:14 +0000
committerMark Linimon <linimon@FreeBSD.org>2019-04-06 18:31:14 +0000
commit2de3c9178038a8997b8d3e8196103faefd0c6f0a (patch)
treefb559371b708060e1a8b1b18eb4289b78b43c66b /audio/vgmplay
parente06b9e343d2686399712a22b006373d8abd66fff (diff)
downloadports-2de3c9178038a8997b8d3e8196103faefd0c6f0a.tar.gz
ports-2de3c9178038a8997b8d3e8196103faefd0c6f0a.zip
Modify compiler flags if !clang to prevent the following:
cc1: error: unrecognized command line option "-Wno-unused-but-set-variable" Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=498163
Diffstat (limited to 'audio/vgmplay')
-rw-r--r--audio/vgmplay/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/audio/vgmplay/Makefile b/audio/vgmplay/Makefile
index d5813e1c4473..7dc0df8bf54b 100644
--- a/audio/vgmplay/Makefile
+++ b/audio/vgmplay/Makefile
@@ -12,7 +12,7 @@ COMMENT= Command-line player for VGM (video game music) files
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/licenses/GPL.txt
-USES= 7z dos2unix gmake
+USES= 7z compiler dos2unix gmake
NO_WRKSUBDIR= yes
@@ -33,8 +33,13 @@ MAKE_ENV+= PREFIX=${LOCALBASE}
PLIST_FILES= bin/vgmplay bin/vgm2pcm bin/vgm2wav man/man1/vgmplay.1.gz ${EXAMPLESDIR}/vgmplay.ini
+.include <bsd.port.pre.mk>
+
post-patch:
${REINPLACE_CMD} -e 's/@//' ${WRKSRC}/Makefile
+.if ${CHOSEN_COMPILER_TYPE} != clang
+ ${REINPLACE_CMD} -e 's/-Wno-unused-but-set-variable//' ${WRKSRC}/Makefile
+.endif
${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|; s|/usr/share/vgmplay|${EXAMPLESDIR}|; s|VGMPlay|vgmplay|g;' ${WRKSRC}/vgmplay.1
do-install:
@@ -45,4 +50,4 @@ do-install:
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/VGMPlay.ini ${STAGEDIR}${EXAMPLESDIR}/vgmplay.ini
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>