aboutsummaryrefslogtreecommitdiff
path: root/audio/vgmplay
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-05-04 22:14:02 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-05-04 22:14:02 +0000
commitd61f31c137ff2328b1471c1fa2c179c3b994e464 (patch)
tree87c083150457d8705bc9b86d33a138e7b981d228 /audio/vgmplay
parent92be8e1db3064629ad7668711d9728be3d01d0d7 (diff)
downloadports-d61f31c137ff2328b1471c1fa2c179c3b994e464.tar.gz
ports-d61f31c137ff2328b1471c1fa2c179c3b994e464.zip
audio/vgmplay: correct endianness on big-endian architectures
By default little-endian is specified, which may result in runtime issues. Set it to big-endian where needed. Also add USES=localbase:ldflags. PR: 237173 Approved by: tagattie@yandex.com (maintainer), linimon (mentor) Differential Revision: https://reviews.freebsd.org/D19994
Notes
Notes: svn path=/head/; revision=500834
Diffstat (limited to 'audio/vgmplay')
-rw-r--r--audio/vgmplay/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/audio/vgmplay/Makefile b/audio/vgmplay/Makefile
index 7dc0df8bf54b..e99d1e738805 100644
--- a/audio/vgmplay/Makefile
+++ b/audio/vgmplay/Makefile
@@ -2,6 +2,7 @@
PORTNAME= vgmplay
PORTVERSION= 0.40.9
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= https://github.com/vgmrips/${PORTNAME}/releases/download/${PORTVERSION}/
DISTNAME= ${PORTNAME:S/vgmp/VGMP/}_${PORTVERSION:S/.//:S/./-/}_src
@@ -26,10 +27,12 @@ LIBAO_DESC= Use libao
OSS_MAKE_ENV+= USE_LIBAO=0
LIBAO_MAKE_ENV+= USE_LIBAO=1
LIBAO_LIB_DEPENDS= libao.so:audio/libao
-LIBAO_CFLAGS+= -I${LOCALBASE}/include
-LIBAO_LDFLAGS+= -L${LOCALBASE}/lib
+LIBAO_USES= localbase:ldflags
-MAKE_ENV+= PREFIX=${LOCALBASE}
+MAKE_ENV+= PREFIX=${LOCALBASE} ${MAKE_ENV_${ARCH}}
+MAKE_ENV_powerpc64= BYTE_ORDER=2
+MAKE_ENV_powerpc= BYTE_ORDER=2
+MAKE_ENV_powerpcspe= BYTE_ORDER=2
PLIST_FILES= bin/vgmplay bin/vgm2pcm bin/vgm2wav man/man1/vgmplay.1.gz ${EXAMPLESDIR}/vgmplay.ini