aboutsummaryrefslogtreecommitdiff
path: root/audio/virtual_oss/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2016-10-28 13:03:39 +0000
committerKoop Mast <kwm@FreeBSD.org>2016-10-28 13:03:39 +0000
commitbe778b491495bd94c2c1c01de5f87baf93a81e67 (patch)
tree0528060873386122444d75d7e771eeee7f6c8781 /audio/virtual_oss/Makefile
parentc74d8e475623112811f574a520bf928f2564204d (diff)
Notes
Diffstat (limited to 'audio/virtual_oss/Makefile')
-rw-r--r--audio/virtual_oss/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/audio/virtual_oss/Makefile b/audio/virtual_oss/Makefile
new file mode 100644
index 000000000000..afe09f771228
--- /dev/null
+++ b/audio/virtual_oss/Makefile
@@ -0,0 +1,39 @@
+# Created by: Hans Petter Selasky <hselasky@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= virtual_oss
+PORTVERSION= 1.1.1
+CATEGORIES= audio
+MASTER_SITES= http://www.selasky.org/hans_petter/distfiles/ \
+ http://home.selasky.org:8192/distfiles/
+
+MAINTAINER= hselasky@FreeBSD.org
+COMMENT= Virtual OSS multi device mixer application.
+
+LICENSE= BSD2CLAUSE
+
+LIB_DEPENDS= libsamplerate.so:audio/libsamplerate
+
+USES= tar:bzip2 uidfix
+
+OPTIONS_DEFINE= BLUETOOTH DEBUG
+OPTIONS_DEFAULT=BLUETOOTH
+
+.if exists(/usr/lib/libcuse.so)
+MAKE_ARGS= HAVE_CUSE="YES"
+.else
+BUILD_DEPENDS+= cuse4bsd-kmod>=0.1.24:multimedia/cuse4bsd-kmod
+LIB_DEPENDS+= libcuse4bsd.so:multimedia/cuse4bsd-kmod
+.endif
+
+BLUETOOTH_DESC= Build with bluetooth support
+BLUETOOTH_MAKE_ARGS= HAVE_BLUETOOTH="YES"
+DEBUG_DESC= Build with debugging support
+DEBUG_MAKE_ARGS= HAVE_DEBUG="YES"
+
+PLIST_FILES= sbin/virtual_oss \
+ man/man8/virtual_oss.8.gz
+
+MAKE_ARGS+= PTHREAD_LIBS="-lpthread"
+
+.include <bsd.port.mk>