aboutsummaryrefslogtreecommitdiff
path: root/audio/vm-lv2
diff options
context:
space:
mode:
authorRichard Gallamore <ultima@FreeBSD.org>2017-08-20 23:00:26 +0000
committerRichard Gallamore <ultima@FreeBSD.org>2017-08-20 23:00:26 +0000
commitfa978697358289008fcf8f5e986ab5289079b542 (patch)
tree23544cc7ecc3fdcc7fb63e5d671b99b30231f9dd /audio/vm-lv2
parenta3a23ae45dc51bf32004b52c173cc1de71c112e4 (diff)
downloadports-fa978697358289008fcf8f5e986ab5289079b542.tar.gz
ports-fa978697358289008fcf8f5e986ab5289079b542.zip
Currently the following plugins are contained in this plugin bundle:
* Control VM Virtual machine for LV2 Control ports. Features 8 inputs and 8 outputs. * CV VM Virtual machine for LV2 Control Voltage ports. Features 8 inputs and 8 outputs. * Audio VM Virtual machine for LV2 Audio ports. Features 8 inputs and 8 outputs. * Atom VM Virtual machine for LV2 Atom event ports. Features 8 inputs and 8 outputs. WWW: https://open-music-kontrollers.ch/lv2/vm/ PR: 221352 Submitted by: Yuri Victorovich (maintainer) Reviewed by: matthew (mentor) Approved by: matthew (mentor) Differential Revision: https://reviews.freebsd.org/D12090
Notes
Notes: svn path=/head/; revision=448442
Diffstat (limited to 'audio/vm-lv2')
-rw-r--r--audio/vm-lv2/Makefile29
-rw-r--r--audio/vm-lv2/distinfo3
-rw-r--r--audio/vm-lv2/files/patch-pugl_pugl_pugl__x11.c11
-rw-r--r--audio/vm-lv2/pkg-descr12
-rw-r--r--audio/vm-lv2/pkg-plist6
5 files changed, 61 insertions, 0 deletions
diff --git a/audio/vm-lv2/Makefile b/audio/vm-lv2/Makefile
new file mode 100644
index 000000000000..c26c9d0d5418
--- /dev/null
+++ b/audio/vm-lv2/Makefile
@@ -0,0 +1,29 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= vm
+PORTVERSION= 0.4.0
+CATEGORIES= audio
+MASTER_SITES= https://gitlab.com/OpenMusicKontrollers/vm.lv2/repository/archive.tar.gz?ref=${PORTVERSION}&dummy=/
+PKGNAMESUFFIX= -lv2
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= Virtual machine LV2 plugin bundle
+
+LICENSE= ART20
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= lv2>0:audio/lv2
+LIB_DEPENDS= liblilv-0.so:audio/lilv \
+ libserd-0.so:devel/serd \
+ libsord-0.so:devel/sord \
+ libsratom-0.so:audio/sratom
+
+USES= cmake compiler:c++11-lib pkgconfig localbase
+USE_XORG= x11 xext
+USE_GL= gl glu
+
+post-extract:
+ @${MV} ${WRKDIR}/vm* ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+.include <bsd.port.mk>
diff --git a/audio/vm-lv2/distinfo b/audio/vm-lv2/distinfo
new file mode 100644
index 000000000000..4ce8164dc692
--- /dev/null
+++ b/audio/vm-lv2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1502075538
+SHA256 (vm-0.4.0.tar.gz) = 6b816a271caf68efa3649252613a50c5799628590ae761491e0e2652b1a0fbe9
+SIZE (vm-0.4.0.tar.gz) = 1745498
diff --git a/audio/vm-lv2/files/patch-pugl_pugl_pugl__x11.c b/audio/vm-lv2/files/patch-pugl_pugl_pugl__x11.c
new file mode 100644
index 000000000000..bc501aaa8aa4
--- /dev/null
+++ b/audio/vm-lv2/files/patch-pugl_pugl_pugl__x11.c
@@ -0,0 +1,11 @@
+--- pugl/pugl/pugl_x11.c.orig 2017-08-07 03:15:15 UTC
++++ pugl/pugl/pugl_x11.c
+@@ -648,7 +648,7 @@ puglPasteFromClipboard(PuglView* view, s
+ if( (xevent.xselection.selection == impl->clipboard)
+ && (xevent.xselection.target == impl->utf8_string)
+ && (xevent.xselection.property == XA_PRIMARY) ) {
+- ulong nitems, rem;
++ uint32_t nitems, rem;
+ int format;
+ uint8_t* data;
+ Atom type;
diff --git a/audio/vm-lv2/pkg-descr b/audio/vm-lv2/pkg-descr
new file mode 100644
index 000000000000..40d79e36cb3c
--- /dev/null
+++ b/audio/vm-lv2/pkg-descr
@@ -0,0 +1,12 @@
+Currently the following plugins are contained in this plugin bundle:
+* Control VM
+ Virtual machine for LV2 Control ports. Features 8 inputs and 8 outputs.
+* CV VM
+ Virtual machine for LV2 Control Voltage ports. Features 8 inputs
+ and 8 outputs.
+* Audio VM
+ Virtual machine for LV2 Audio ports. Features 8 inputs and 8 outputs.
+* Atom VM
+ Virtual machine for LV2 Atom event ports. Features 8 inputs and 8 outputs.
+
+WWW: https://open-music-kontrollers.ch/lv2/vm/
diff --git a/audio/vm-lv2/pkg-plist b/audio/vm-lv2/pkg-plist
new file mode 100644
index 000000000000..8225d40b56d5
--- /dev/null
+++ b/audio/vm-lv2/pkg-plist
@@ -0,0 +1,6 @@
+lib/lv2/vm.lv2/Cousine-Regular.ttf
+lib/lv2/vm.lv2/manifest.ttl
+lib/lv2/vm.lv2/vm.so
+lib/lv2/vm.lv2/vm.ttl
+lib/lv2/vm.lv2/vm_ui.so
+lib/lv2/vm.lv2/vm_ui.ttl