aboutsummaryrefslogtreecommitdiff
path: root/audio/vmpk
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
commitb1a1d38bf9ef78334b640d30046388a9c055c3a9 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /audio/vmpk
parentbc77780d41178cf3d0327c79ac10737af704f236 (diff)
downloadports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.tar.gz
ports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Notes
Notes: svn path=/head/; revision=473503
Diffstat (limited to 'audio/vmpk')
-rw-r--r--audio/vmpk/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/audio/vmpk/Makefile b/audio/vmpk/Makefile
index 301e01bf39b1..f0d3bcb92412 100644
--- a/audio/vmpk/Makefile
+++ b/audio/vmpk/Makefile
@@ -15,8 +15,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libdrumstick-rt.so:audio/drumstick
-USES= cmake:outsource pkgconfig tar:bz2
-USE_QT5= core gui network svg widgets x11extras \
+USES= cmake:outsource pkgconfig qt:5 tar:bz2
+USE_QT= core gui network svg widgets x11extras \
buildtools_build linguisttools_build qmake_build
USE_XORG= xcb
@@ -26,6 +26,6 @@ OPTIONS_DEFINE= DBUS
OPTIONS_SUB= yes
DBUS_CMAKE_BOOL= ENABLE_DBUS
-DBUS_USE= qt5=dbus
+DBUS_USE= qt=dbus
.include <bsd.port.mk>