aboutsummaryrefslogtreecommitdiff
path: root/audio/vo-aacenc
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2011-06-23 12:52:00 +0000
committerMartin Matuska <mm@FreeBSD.org>2011-06-23 12:52:00 +0000
commitc80799fcb8dcb1a6468021141c804bc5b29f5774 (patch)
tree782e2327537554fffff388e35ebed486f38fbf56 /audio/vo-aacenc
parent53405c875685d2474e42351500bf382a7fdc64ba (diff)
downloadports-c80799fcb8dcb1a6468021141c804bc5b29f5774.tar.gz
ports-c80799fcb8dcb1a6468021141c804bc5b29f5774.zip
VisualOn AAC encoder library
This library contains an encoder implementation of the Advanced Audio Coding (AAC) audio codec. The library is based on a codec implementation by VisualOn as part of the Stagefright framework from the Google Android project. WWW: https://github.com/mstorsjo/vo-aacenc
Notes
Notes: svn path=/head/; revision=276126
Diffstat (limited to 'audio/vo-aacenc')
-rw-r--r--audio/vo-aacenc/Makefile37
-rw-r--r--audio/vo-aacenc/distinfo2
-rw-r--r--audio/vo-aacenc/pkg-descr8
-rw-r--r--audio/vo-aacenc/pkg-plist13
4 files changed, 60 insertions, 0 deletions
diff --git a/audio/vo-aacenc/Makefile b/audio/vo-aacenc/Makefile
new file mode 100644
index 000000000000..e180f4512d90
--- /dev/null
+++ b/audio/vo-aacenc/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: vo-aacenc
+# Date created: 23 Jun 2011
+# Whom: Martin Matuska <mm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vo-aacenc
+PORTVERSION= 0.1.1
+CATEGORIES= audio
+MASTER_SITES= https://github.com/mstorsjo/${PORTNAME}/tarball/v${PORTVERSION}/
+DISTNAME= mstorsjo-${PORTNAME}-v${PORTVERSION}-0-g${GITVERSION}
+
+MAINTAINER= mm@FreeBSD.org
+COMMENT= VisualOn AAC encoder library
+
+LICENSE= ASL
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+GITVERSION= 4646ab8
+FETCH_ARGS= -pRr
+WRKSRC= ${WRKDIR}/mstorsjo-${PORTNAME}-${GITVERSION}
+
+GNU_CONFIGURE= yes
+
+USE_AUTOTOOLS= libtoolize aclocal autoheader autoconf automake
+ACLOCAL_ARGS= -I m4
+AUTOCONF_ARGS= -I m4
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -E -e \
+ 's|^pkgconfigdir = .*|pkgconfigdir = $$(prefix)/libdata/pkgconfig|g' \
+ ${WRKSRC}/Makefile.am
+
+.include <bsd.port.post.mk>
diff --git a/audio/vo-aacenc/distinfo b/audio/vo-aacenc/distinfo
new file mode 100644
index 000000000000..b2bb30f227a2
--- /dev/null
+++ b/audio/vo-aacenc/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mstorsjo-vo-aacenc-v0.1.1-0-g4646ab8.tar.gz) = 5ac421179c6cce74e8ac3f17f5f1ba009ed1df19d8d98d7b4ff8582af79bb813
+SIZE (mstorsjo-vo-aacenc-v0.1.1-0-g4646ab8.tar.gz) = 472343
diff --git a/audio/vo-aacenc/pkg-descr b/audio/vo-aacenc/pkg-descr
new file mode 100644
index 000000000000..8b597d464934
--- /dev/null
+++ b/audio/vo-aacenc/pkg-descr
@@ -0,0 +1,8 @@
+VisualOn AAC encoder library
+
+This library contains an encoder implementation of the Advanced Audio
+Coding (AAC) audio codec. The library is based on a codec implementation
+by VisualOn as part of the Stagefright framework from the Google
+Android project.
+
+WWW: https://github.com/mstorsjo/vo-aacenc
diff --git a/audio/vo-aacenc/pkg-plist b/audio/vo-aacenc/pkg-plist
new file mode 100644
index 000000000000..f2c5f5015951
--- /dev/null
+++ b/audio/vo-aacenc/pkg-plist
@@ -0,0 +1,13 @@
+include/vo-aacenc/cmnMemory.h
+include/vo-aacenc/voAAC.h
+include/vo-aacenc/voAMRWB.h
+include/vo-aacenc/voAudio.h
+include/vo-aacenc/voIndex.h
+include/vo-aacenc/voMem.h
+include/vo-aacenc/voType.h
+lib/libvo-aacenc.a
+lib/libvo-aacenc.la
+lib/libvo-aacenc.so
+lib/libvo-aacenc.so.0
+libdata/pkgconfig/vo-aacenc.pc
+@dirrm include/vo-aacenc