aboutsummaryrefslogtreecommitdiff
path: root/audio/voipong
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2009-08-22 02:17:22 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2009-08-22 02:17:22 +0000
commit0a6ab96fe0ff05b1da98d345c0bbaa99d34a974f (patch)
tree0ba04667437dca5edb338362f39a083216b5f356 /audio/voipong
parent02d56add8efdaaa55a0edb93a87d1ad652c54ce0 (diff)
downloadports-0a6ab96fe0ff05b1da98d345c0bbaa99d34a974f.tar.gz
ports-0a6ab96fe0ff05b1da98d345c0bbaa99d34a974f.zip
- Update to 2.0.
- Respect NOPORTDOCS. PR: ports/137813 (based on) Submitted by: Sylvio Cesar <scjamorim@bsd.com.br> Approved by: "N.Ersen SISECI" <siseci@EnderUNIX.org> (maintainer)
Notes
Notes: svn path=/head/; revision=240083
Diffstat (limited to 'audio/voipong')
-rw-r--r--audio/voipong/Makefile31
-rw-r--r--audio/voipong/distinfo6
-rw-r--r--audio/voipong/files/patch-Makefile.bsd21
-rw-r--r--audio/voipong/files/pkg-message.in7
-rw-r--r--audio/voipong/pkg-plist27
5 files changed, 65 insertions, 27 deletions
diff --git a/audio/voipong/Makefile b/audio/voipong/Makefile
index 18bd43fc9d89..6d648074eef3 100644
--- a/audio/voipong/Makefile
+++ b/audio/voipong/Makefile
@@ -6,31 +6,28 @@
#
PORTNAME= voipong
-PORTVERSION= 1.1
+PORTVERSION= 2.0
CATEGORIES= audio
MASTER_SITES= http://www.enderunix.org/voipong/
MAINTAINER= siseci@EnderUNIX.org
COMMENT= Detect Voice Over IP calls and dump them to separate wave files
-GNU_CONFIGURE= yes
-
-SUB_FILES= pkg-message
-PLIST_FILES= bin/voipong etc/voipong.conf-dist
-PORTDOCS= AUTHORS INSTALL README THANKS
+USE_LDCONFIG= yes
+PORTDOCS= ALGORITHMS AUTHORS ChangeLog COPYING INSTALL KNOWN_BUGS \
+ LICENSE NEWS README THANKS TODO
post-patch:
- @${REINPLACE_CMD} -e 's|^CFLAGS=""||' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e \
- 's|$${prefix}/share/voipong|${DOCSDIR}|; \
- s|COPYING||; s|LICENSE||' \
- ${WRKSRC}/Makefile.in
-.ifdef NOPORTDOCS
- ${REINPLACE_CMD} '/install-data-am:/s/install-${PORTNAME}dataDATA//' \
- ${WRKSRC}/Makefile.in
-.endif
+ ${MV} ${WRKSRC}/Makefile.bsd ${WRKSRC}/Makefile
post-install:
- @${CAT} ${PKGMESSAGE}
-
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${MKDIR} ${DOCSDIR}/users-manual
+ ${INSTALL_DATA} ${WRKSRC}/docs/users-manual/*.html ${DOCSDIR}/users-manual/
+ ${INSTALL_DATA} ${WRKSRC}/docs/users-manual/*.css ${DOCSDIR}/users-manual/
+.for doc in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.endfor
+.endif
.include <bsd.port.mk>
diff --git a/audio/voipong/distinfo b/audio/voipong/distinfo
index 85dc2e17e273..e2f9e858dd7f 100644
--- a/audio/voipong/distinfo
+++ b/audio/voipong/distinfo
@@ -1,3 +1,3 @@
-MD5 (voipong-1.1.tar.gz) = e5b012434e5aeb8188bad1579f7e9f47
-SHA256 (voipong-1.1.tar.gz) = 08973834bdda36a7b71ed0da9bd682858f3e91cbf76cfb5cbd3fea0719b62ae3
-SIZE (voipong-1.1.tar.gz) = 157070
+MD5 (voipong-2.0.tar.gz) = 4b3e16c5d8399bba86b3caf1887550ff
+SHA256 (voipong-2.0.tar.gz) = d22aac1bf7adf2fc9e0cebbc1292b763d16c8d4a0e7ebbd6d4d460201986e9a3
+SIZE (voipong-2.0.tar.gz) = 76426
diff --git a/audio/voipong/files/patch-Makefile.bsd b/audio/voipong/files/patch-Makefile.bsd
new file mode 100644
index 000000000000..3eabf48d91d2
--- /dev/null
+++ b/audio/voipong/files/patch-Makefile.bsd
@@ -0,0 +1,21 @@
+--- Makefile.bsd.orig 2009-08-21 22:13:38.000000000 -0300
++++ Makefile.bsd 2009-08-21 22:15:08.000000000 -0300
+@@ -55,15 +55,15 @@
+
+ install:
+ mkdir -p /usr/local/etc/voipong
+- mkdir -p /usr/local/etc/voipong/modules
++ mkdir -p /usr/local/lib/voipong
+ cp voipong /usr/local/bin/
+ cp voipctl /usr/local/bin/
+ cp etc/voipong.conf /usr/local/etc/voipong/
+ chmod 750 /usr/local/bin/voipong
+ chmod 750 /usr/local/bin/voipctl
+ chmod 600 /usr/local/etc/voipong/voipong.conf
+- cp modvocoder_*.so /usr/local/etc/voipong/modules/
+- chmod 500 /usr/local/etc/voipong/modules/*
++ cp modvocoder_*.so /usr/local/lib/voipong/
++ chmod 500 /usr/local/lib/voipong/*
+
+ cls:
+ $(CLEARX)
diff --git a/audio/voipong/files/pkg-message.in b/audio/voipong/files/pkg-message.in
deleted file mode 100644
index 562bd5c99e98..000000000000
--- a/audio/voipong/files/pkg-message.in
+++ /dev/null
@@ -1,7 +0,0 @@
----------------------------------------------------------------------
-You should now copy
- %%PREFIX%%/etc/voipong.conf-dist
-to
- %%PREFIX%%/etc/voipong.conf
-and edit it as appropriate.
----------------------------------------------------------------------
diff --git a/audio/voipong/pkg-plist b/audio/voipong/pkg-plist
new file mode 100644
index 000000000000..c877c2430f95
--- /dev/null
+++ b/audio/voipong/pkg-plist
@@ -0,0 +1,27 @@
+bin/voipong
+bin/voipctl
+etc/voipong/voipong.conf
+%%PORTDOCS%%%%DOCSDIR%%/users-manual/book.html
+%%PORTDOCS%%%%DOCSDIR%%/users-manual/compilation.html
+%%PORTDOCS%%%%DOCSDIR%%/users-manual/config-netfile.html
+%%PORTDOCS%%%%DOCSDIR%%/users-manual/config.html
+%%PORTDOCS%%%%DOCSDIR%%/users-manual/docbook.css
+%%PORTDOCS%%%%DOCSDIR%%/users-manual/dsom.html
+%%PORTDOCS%%%%DOCSDIR%%/users-manual/examples-msnetmeeting.html
+%%PORTDOCS%%%%DOCSDIR%%/users-manual/examples.html
+%%PORTDOCS%%%%DOCSDIR%%/users-manual/faq.html
+%%PORTDOCS%%%%DOCSDIR%%/users-manual/features.html
+%%PORTDOCS%%%%DOCSDIR%%/users-manual/index.html
+%%PORTDOCS%%%%DOCSDIR%%/users-manual/installation.html
+%%PORTDOCS%%%%DOCSDIR%%/users-manual/installports.html
+%%PORTDOCS%%%%DOCSDIR%%/users-manual/intro.html
+%%PORTDOCS%%%%DOCSDIR%%/users-manual/thanks.html
+%%PORTDOCS%%%%DOCSDIR%%/users-manual/usage-livecd.html
+%%PORTDOCS%%%%DOCSDIR%%/users-manual/usage-nonpriv.html
+%%PORTDOCS%%%%DOCSDIR%%/users-manual/usage-voipctl.html
+%%PORTDOCS%%%%DOCSDIR%%/users-manual/usage.html
+lib/voipong/modvocoder_pcma.so
+lib/voipong/modvocoder_pcmu.so
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/users-manual
+@dirrm etc/voipong
+@dirrm lib/voipong