aboutsummaryrefslogtreecommitdiff
path: root/audio/vorbis-tools
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2021-01-23 22:45:00 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2021-01-23 22:45:00 +0000
commite491d797236b9320efe990ad8859e89009f5d4ba (patch)
treee28f151b401f14b57eff41c18e023d28e6856f99 /audio/vorbis-tools
parentb17c2092b7216d1165ba5422856d7ccfa65357aa (diff)
downloadports-e491d797236b9320efe990ad8859e89009f5d4ba.tar.gz
ports-e491d797236b9320efe990ad8859e89009f5d4ba.zip
audio/vorbis-tools: update to 1.4.2
This release fixes many bugs. Additional user-visible changes: * ogg123: Added support for Opus files * ogginfo: Added support for Opus, FLAC, and speex * ogg123, ogginfo: Added support to decode METADATA_BLOCK_PICTURE * ogginfo: Added support for decoding Skeleton * vorbiscomment: Added -d/--rm to allow removal of tags
Notes
Notes: svn path=/head/; revision=562422
Diffstat (limited to 'audio/vorbis-tools')
-rw-r--r--audio/vorbis-tools/Makefile5
-rw-r--r--audio/vorbis-tools/distinfo5
-rw-r--r--audio/vorbis-tools/files/patch-configure6
-rw-r--r--audio/vorbis-tools/files/patch-ogg123_Makefile.in6
-rw-r--r--audio/vorbis-tools/files/patch-ogg123_vorbis__comments.c4
-rw-r--r--audio/vorbis-tools/files/patch-oggenc_audio.c84
-rw-r--r--audio/vorbis-tools/files/patch-oggenc_oggenc.c21
-rw-r--r--audio/vorbis-tools/files/patch-ogginfo_codec__skeleton.c10
-rw-r--r--audio/vorbis-tools/pkg-descr2
9 files changed, 25 insertions, 118 deletions
diff --git a/audio/vorbis-tools/Makefile b/audio/vorbis-tools/Makefile
index 5473f712f0ff..24adf4e3028f 100644
--- a/audio/vorbis-tools/Makefile
+++ b/audio/vorbis-tools/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= vorbis-tools
-PORTVERSION= 1.4.0
-PORTREVISION= 10
+PORTVERSION= 1.4.2
PORTEPOCH= 3
CATEGORIES= audio
MASTER_SITES= http://downloads.xiph.org/releases/vorbis/
@@ -18,6 +17,8 @@ LIB_DEPENDS= libao.so:audio/libao \
libcurl.so:ftp/curl \
libFLAC.so:audio/flac \
libkate.so:multimedia/libkate \
+ libogg.so:audio/libogg \
+ libopusfile.so:audio/opusfile \
libspeex.so:audio/speex \
libvorbis.so:audio/libvorbis
diff --git a/audio/vorbis-tools/distinfo b/audio/vorbis-tools/distinfo
index f84e32ed667a..1a077ad0b2b6 100644
--- a/audio/vorbis-tools/distinfo
+++ b/audio/vorbis-tools/distinfo
@@ -1,2 +1,3 @@
-SHA256 (vorbis-tools-1.4.0.tar.gz) = a389395baa43f8e5a796c99daf62397e435a7e73531c9f44d9084055a05d22bc
-SIZE (vorbis-tools-1.4.0.tar.gz) = 1346532
+TIMESTAMP = 1611440307
+SHA256 (vorbis-tools-1.4.2.tar.gz) = db7774ec2bf2c939b139452183669be84fda5774d6400fc57fde37f77624f0b0
+SIZE (vorbis-tools-1.4.2.tar.gz) = 1389947
diff --git a/audio/vorbis-tools/files/patch-configure b/audio/vorbis-tools/files/patch-configure
index b7cade5fb297..b5a854e411a2 100644
--- a/audio/vorbis-tools/files/patch-configure
+++ b/audio/vorbis-tools/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2010-03-26 07:07:20 UTC
+--- configure.orig 2021-01-21 09:14:17 UTC
+++ configure
-@@ -20398,7 +20398,7 @@ if test -z "$GCC"; then
+@@ -18084,7 +18084,7 @@ if test -z "$GCC"; then
;;
*)
DEBUG="-g"
@@ -9,7 +9,7 @@
PROFILE="-g -p"
;;
esac
-@@ -20421,8 +20421,8 @@ else
+@@ -18107,8 +18107,8 @@ else
;;
*)
DEBUG="-g -Wall -fsigned-char"
diff --git a/audio/vorbis-tools/files/patch-ogg123_Makefile.in b/audio/vorbis-tools/files/patch-ogg123_Makefile.in
index 282df7d6f2e1..c245da108b0d 100644
--- a/audio/vorbis-tools/files/patch-ogg123_Makefile.in
+++ b/audio/vorbis-tools/files/patch-ogg123_Makefile.in
@@ -1,11 +1,11 @@
---- ogg123/Makefile.in.orig 2010-03-26 07:07:18 UTC
+--- ogg123/Makefile.in.orig 2021-01-21 09:14:18 UTC
+++ ogg123/Makefile.in
-@@ -633,7 +633,7 @@ info: info-am
+@@ -816,7 +816,7 @@ info: info-am
info-am:
-install-data-am: install-docDATA install-man
+install-data-am: install-man
- install-exec-am: install-binPROGRAMS
+ install-dvi: install-dvi-am
diff --git a/audio/vorbis-tools/files/patch-ogg123_vorbis__comments.c b/audio/vorbis-tools/files/patch-ogg123_vorbis__comments.c
index 5ad494448ec1..4cf8dc86c5b9 100644
--- a/audio/vorbis-tools/files/patch-ogg123_vorbis__comments.c
+++ b/audio/vorbis-tools/files/patch-ogg123_vorbis__comments.c
@@ -1,6 +1,6 @@
---- ogg123/vorbis_comments.c.orig 2010-01-27 04:14:11 UTC
+--- ogg123/vorbis_comments.c.orig 2021-01-07 23:31:25 UTC
+++ ogg123/vorbis_comments.c
-@@ -72,7 +72,7 @@ char *lookup_comment_prettyprint (char *
+@@ -74,7 +74,7 @@ char *lookup_comment_prettyprint (const char *comment,
/* Use default formatting */
j = strcspn(comment, "=");
diff --git a/audio/vorbis-tools/files/patch-oggenc_audio.c b/audio/vorbis-tools/files/patch-oggenc_audio.c
deleted file mode 100644
index 2a68741017fb..000000000000
--- a/audio/vorbis-tools/files/patch-oggenc_audio.c
+++ /dev/null
@@ -1,84 +0,0 @@
---- oggenc/audio.c.orig 2010-03-24 08:27:14 UTC
-+++ oggenc/audio.c
-@@ -13,6 +13,7 @@
- #include <config.h>
- #endif
-
-+#include <limits.h>
- #include <stdlib.h>
- #include <stdio.h>
- #include <string.h>
-@@ -245,12 +246,13 @@ static int aiff_permute_matrix[6][6] =
- int aiff_open(FILE *in, oe_enc_opt *opt, unsigned char *buf, int buflen)
- {
- int aifc; /* AIFC or AIFF? */
-- unsigned int len;
-- unsigned char *buffer;
-+ unsigned int len, readlen;
-+ unsigned char buffer[22];
- unsigned char buf2[8];
- aiff_fmt format;
- aifffile *aiff = malloc(sizeof(aifffile));
- int i;
-+ long channels;
-
- if(buf[11]=='C')
- aifc=1;
-@@ -269,19 +271,25 @@ int aiff_open(FILE *in, oe_enc_opt *opt,
- return 0; /* Weird common chunk */
- }
-
-- buffer = alloca(len);
--
-- if(fread(buffer,1,len,in) < len)
-+ readlen = len < sizeof(buffer) ? len : sizeof(buffer);
-+ if(fread(buffer,1,readlen,in) < readlen ||
-+ (len > readlen && !seek_forward(in, len-readlen)))
- {
- fprintf(stderr, _("Warning: Unexpected EOF in reading AIFF header\n"));
- return 0;
- }
-
-- format.channels = READ_U16_BE(buffer);
-+ format.channels = channels = READ_U16_BE(buffer);
- format.totalframes = READ_U32_BE(buffer+2);
- format.samplesize = READ_U16_BE(buffer+6);
- format.rate = (int)read_IEEE80(buffer+8);
-
-+ if(channels <= 0L || SHRT_MAX < channels)
-+ {
-+ fprintf(stderr, _("Warning: Unsupported count of channels in AIFF header\n"));
-+ return 0;
-+ }
-+
- aiff->bigendian = 1;
-
- if(aifc)
-@@ -412,6 +420,7 @@ int wav_open(FILE *in, oe_enc_opt *opt,
- wav_fmt format;
- wavfile *wav = malloc(sizeof(wavfile));
- int i;
-+ long channels;
-
- /* Ok. At this point, we know we have a WAV file. Now we have to detect
- * whether we support the subtype, and we have to find the actual data
-@@ -449,12 +458,18 @@ int wav_open(FILE *in, oe_enc_opt *opt,
- }
-
- format.format = READ_U16_LE(buf);
-- format.channels = READ_U16_LE(buf+2);
-+ format.channels = channels = READ_U16_LE(buf+2);
- format.samplerate = READ_U32_LE(buf+4);
- format.bytespersec = READ_U32_LE(buf+8);
- format.align = READ_U16_LE(buf+12);
- format.samplesize = READ_U16_LE(buf+14);
-
-+ if(channels <= 0L || SHRT_MAX < channels)
-+ {
-+ fprintf(stderr, _("Warning: Unsupported count of channels in WAV header\n"));
-+ return 0;
-+ }
-+
- if(format.format == -2) /* WAVE_FORMAT_EXTENSIBLE */
- {
- if(len<40)
diff --git a/audio/vorbis-tools/files/patch-oggenc_oggenc.c b/audio/vorbis-tools/files/patch-oggenc_oggenc.c
deleted file mode 100644
index 2ae1d255f2b3..000000000000
--- a/audio/vorbis-tools/files/patch-oggenc_oggenc.c
+++ /dev/null
@@ -1,21 +0,0 @@
---- oggenc/oggenc.c.orig 2010-03-26 07:07:07 UTC
-+++ oggenc/oggenc.c
-@@ -97,6 +97,8 @@ int main(int argc, char **argv)
- .3,-1,
- 0,0,0.f,
- 0, 0, 0, 0, 0};
-+ input_format raw_format = {NULL, 0, raw_open, wav_close, "raw",
-+ N_("RAW file reader")};
-
- int i;
-
-@@ -239,9 +241,6 @@ int main(int argc, char **argv)
-
- if(opt.rawmode)
- {
-- input_format raw_format = {NULL, 0, raw_open, wav_close, "raw",
-- N_("RAW file reader")};
--
- enc_opts.rate=opt.raw_samplerate;
- enc_opts.channels=opt.raw_channels;
- enc_opts.samplesize=opt.raw_samplesize;
diff --git a/audio/vorbis-tools/files/patch-ogginfo_codec__skeleton.c b/audio/vorbis-tools/files/patch-ogginfo_codec__skeleton.c
new file mode 100644
index 000000000000..aefd970ec393
--- /dev/null
+++ b/audio/vorbis-tools/files/patch-ogginfo_codec__skeleton.c
@@ -0,0 +1,10 @@
+--- ogginfo/codec_skeleton.c.orig 2021-01-23 22:20:35 UTC
++++ ogginfo/codec_skeleton.c
+@@ -24,6 +24,7 @@
+
+ #include <ogg/ogg.h>
+
++#include "utf8.h"
+ #include "i18n.h"
+
+ #include "private.h"
diff --git a/audio/vorbis-tools/pkg-descr b/audio/vorbis-tools/pkg-descr
index 9c856b6f1b17..cb1c5166be8c 100644
--- a/audio/vorbis-tools/pkg-descr
+++ b/audio/vorbis-tools/pkg-descr
@@ -10,4 +10,4 @@ patent concerns.
This package contains utilities to encode, decode, and cut vorbis
streams, and to add comments to them.
-WWW: http://www.vorbis.com/
+WWW: https://xiph.org/vorbis/