aboutsummaryrefslogtreecommitdiff
path: root/audio/wavegain
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-02-14 20:19:44 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-02-14 20:19:44 +0000
commit5a995850b64ad75a0afe3fb7c92444d0d7d13a17 (patch)
tree48559101b1602addc727e8bf0c60fc30cb96f158 /audio/wavegain
parent3007cf1777f9e5b485e6805fcf7219a3c65beed6 (diff)
downloadports-5a995850b64ad75a0afe3fb7c92444d0d7d13a17.tar.gz
ports-5a995850b64ad75a0afe3fb7c92444d0d7d13a17.zip
- Update to 1.2.8
PR: 131666 Submitted by: "Denise H. G." <darcsis@gmail.com> (maintainer)
Notes
Notes: svn path=/head/; revision=228309
Diffstat (limited to 'audio/wavegain')
-rw-r--r--audio/wavegain/Makefile2
-rw-r--r--audio/wavegain/distinfo6
-rw-r--r--audio/wavegain/files/patch-audio.c10
-rw-r--r--audio/wavegain/files/patch-wavegain.c87
4 files changed, 41 insertions, 64 deletions
diff --git a/audio/wavegain/Makefile b/audio/wavegain/Makefile
index 91378af48e01..7b02343b89e5 100644
--- a/audio/wavegain/Makefile
+++ b/audio/wavegain/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= wavegain
-PORTVERSION= 1.2.6
+PORTVERSION= 1.2.8
CATEGORIES= audio
MASTER_SITES= http://www.rarewares.org/files/others/
DISTNAME= ${PORTNAME}-${PORTVERSION}srcs${EXTRACT_SUFFIX}
diff --git a/audio/wavegain/distinfo b/audio/wavegain/distinfo
index a7613b9b5eee..03a95be37639 100644
--- a/audio/wavegain/distinfo
+++ b/audio/wavegain/distinfo
@@ -1,3 +1,3 @@
-MD5 (wavegain-1.2.6srcs.zip) = 37facb462a3ec4f9831cd00f597ee85e
-SHA256 (wavegain-1.2.6srcs.zip) = 32f3ea5252094c8443a54440ed5e815b044b9feeb82e6494eabbe84f95e6fc08
-SIZE (wavegain-1.2.6srcs.zip) = 160859
+MD5 (wavegain-1.2.8srcs.zip) = bc9b412400dbfb69bcbf961ed4e6eb06
+SHA256 (wavegain-1.2.8srcs.zip) = e1ded05855fa209a67b887fa90e62c7c0a018dab20265a54d26eca40a6cc1436
+SIZE (wavegain-1.2.8srcs.zip) = 72867
diff --git a/audio/wavegain/files/patch-audio.c b/audio/wavegain/files/patch-audio.c
index c54f81ccd6cf..4608acad3b97 100644
--- a/audio/wavegain/files/patch-audio.c
+++ b/audio/wavegain/files/patch-audio.c
@@ -1,8 +1,8 @@
---- audio.c 2005-11-27 16:55:24.000000000 +0800
-+++ audio.c 2008-05-24 22:12:15.000000000 +0800
-@@ -31,20 +31,8 @@
- #include <string.h>
+--- audio.c.orig 2009-02-14 06:54:45.932023788 +0800
++++ audio.c 2009-02-14 06:55:01.958134649 +0800
+@@ -32,20 +32,8 @@
#include <sys/types.h>
+ #include <math.h>
-#ifdef _WIN32
-#include <io.h>
@@ -18,6 +18,6 @@
-#include <malloc.h>
-#endif
-
- #include <math.h>
#include "config.h"
#include "audio.h"
+ #include "i18n.h"
diff --git a/audio/wavegain/files/patch-wavegain.c b/audio/wavegain/files/patch-wavegain.c
index fdbddd058056..40aa6807d45a 100644
--- a/audio/wavegain/files/patch-wavegain.c
+++ b/audio/wavegain/files/patch-wavegain.c
@@ -1,5 +1,5 @@
---- wavegain.c 2005-11-27 16:58:46.000000000 +0800
-+++ wavegain.c 2008-05-25 03:23:17.000000000 +0800
+--- wavegain.c.orig 2009-02-14 07:27:18.005266616 +0800
++++ wavegain.c 2009-02-14 07:29:15.783066588 +0800
@@ -19,20 +19,8 @@
#include <string.h>
#include <ctype.h>
@@ -20,62 +20,41 @@
-
#include "gain_analysis.h"
#include "i18n.h"
- #include "config.h"
-@@ -58,6 +46,14 @@
+ #include "getopt.h"
+@@ -57,6 +45,9 @@
#define ROUND64(x) ( doubletmp = (x) + Dither.Add + (Int64_t)0x001FFFFD80000000L, *(Int64_t*)(&doubletmp) - (Int64_t)0x433FFFFD80000000L )
#endif
-+
-+
-+# include <errno.h>
++#include <errno.h>
+static int xrename(const char *oldpath, const char *newpath);
+
-+
-+
-+
- extern int write_log;
+ extern int write_to_log;
dither_t Dither;
double doubletmp;
-@@ -584,16 +580,26 @@
- close_audio_file(infile, aufile, wg_opts);
- fclose(infile);
-
-- if (!settings->std_out) {
-+ if (!settings->std_out) {
-+
- if (remove(filename) != 0) {
- fprintf(stderr, " Error deleting old file '%s'\n", filename);
+@@ -639,7 +630,14 @@
goto exit;
}
--
+
- if (rename(TEMP_NAME, filename) != 0) {
-+
-+ /*
-+ * int rename(const char *old, const char *new);
-+ * In POSIX, rename will fail if the 'old' and 'new' names are on different mounted file systems.
-+ * ( From http://en.wikipedia.org/wiki/Rename_%28C%29 )
-+ * Function 'xrename' from 'normalize-0.7.6' is one clever solution
-+ */
-+
-+ /*if (rename(TEMP_NAME, filename) != 0) { */
-+ if (xrename(TEMP_NAME, filename) != 0) {
++ /*
++ * int rename(const char *old, const char *new);
++ * In POSIX, rename will fail if the 'old' and 'new' names are on different mounted file systems.
++ * ( From http://en.wikipedia.org/wiki/Rename_%28C%29 )
++ * Function 'xrename' from 'normalize-0.7.6' is one clever solution
++ */
++ /*if (rename(TEMP_NAME, filename) != 0) {*/
++ if (xrename(TEMP_NAME, filename) != 0) {
fprintf(stderr, " Error renaming '" TEMP_NAME "' to '%s' (uh-oh)\n", filename);
goto exit;
}
-+
- }
-
- result = 1;
-@@ -603,3 +609,65 @@
+@@ -650,4 +648,61 @@
+ return result;
}
-
-+
-+
+/* From normalize-0.7.6/nid3lib/write.c
+ * Move the file "oldpath" to "newpath", or copy and delete if they
+ * are on different filesystems.
-+ */
++*/
+static int
+xrename(const char *oldpath, const char *newpath)
+{
@@ -95,40 +74,38 @@
+ if (errno == EXDEV) {
+ /* files are on different filesystems, so we have to copy */
+ if (unlink(newpath) == -1 && errno != ENOENT)
-+ return -1;
++ return -1;
+
+ in = fopen(oldpath, "rb");
+ if (in == NULL)
-+ return -1;
++ return -1;
+ out = fopen(newpath, "wb");
+ if (out == NULL) {
-+ fclose(in);
-+ return -1;
++ fclose(in);
++ return -1;
+ }
+
+ while ((sz = fread(buf, 1, 4096, in)) > 0)
-+ fwrite(buf, 1, sz, out);
++ fwrite(buf, 1, sz, out);
+
+ if (ferror(in) || ferror(out)) {
-+ fclose(in);
-+ fclose(out);
-+ return -1;
++ fclose(in);
++ fclose(out);
++ return -1;
+ }
+ if (fclose(in) == EOF) {
-+ fclose(out);
-+ return -1;
++ fclose(out);
++ return -1;
+ }
+ if (fclose(out) == EOF)
-+ return -1;
++ return -1;
+
+ if (unlink(oldpath) == -1)
-+ return -1;
++ return -1;
+ } else {
+ return -1;
+ }
+ }
-+
+
+ return 0;
+}
-+
-+