aboutsummaryrefslogtreecommitdiff
path: root/audio/webrtc-audio-processing
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-12-10 04:35:50 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-12-10 04:35:50 +0000
commit72f25029fa3262d76337b1af6218f9a29f43121c (patch)
tree7ca50f466dfc65fa68ca506e673f9dcebd0d87ce /audio/webrtc-audio-processing
parent741896107615f686c0cb8295e74badcdded7a8a1 (diff)
downloadports-72f25029fa3262d76337b1af6218f9a29f43121c.tar.gz
ports-72f25029fa3262d76337b1af6218f9a29f43121c.zip
audio/webrtc-audio-processing: unbreak on armv6 after r557409
In file included from webrtc/third_party/pffft/src/pffft.c:155: /usr/lib/clang/11.0.0/include/arm_neon.h:32:2: error: "NEON support not enabled" #error "NEON support not enabled" ^ webrtc/third_party/pffft/src/pffft.c:156:9: error: unknown type name 'float32x4_t' typedef float32x4_t v4sf; ^
Notes
Notes: svn path=/head/; revision=557411
Diffstat (limited to 'audio/webrtc-audio-processing')
-rw-r--r--audio/webrtc-audio-processing/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/audio/webrtc-audio-processing/Makefile b/audio/webrtc-audio-processing/Makefile
index bbde55f43dde..e1720208cce9 100644
--- a/audio/webrtc-audio-processing/Makefile
+++ b/audio/webrtc-audio-processing/Makefile
@@ -18,6 +18,7 @@ LIB_DEPENDS= libabsl_strings.so:devel/abseil
USES= compiler:c++14-lang localbase:ldflags meson
USE_LDCONFIG= yes
+CFLAGS_armv6= -DPFFFT_SIMD_DISABLE # https://gitlab.freedesktop.org/pulseaudio/webrtc-audio-processing/-/issues/6
CFLAGS_i386= -msse # https://gitlab.freedesktop.org/pulseaudio/webrtc-audio-processing/-/issues/5
post-patch: