aboutsummaryrefslogtreecommitdiff
path: root/audio/webrtc-audio-processing
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-12-29 22:28:14 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-12-29 22:28:14 +0000
commitc78beee722c91772ffd7309d95554ac2118834e2 (patch)
tree46a63b3d4d728cf2badf58fd57548e2b24bff723 /audio/webrtc-audio-processing
parentd51c9acbfd8ea08f970d8edd55b49c649004d9c4 (diff)
downloadports-c78beee722c91772ffd7309d95554ac2118834e2.tar.gz
ports-c78beee722c91772ffd7309d95554ac2118834e2.zip
audio/webrtc-audio-processing: Sync -std= with devel/abseil to match ABI
PR: 250376 Approved by: jbeich (maintainer)
Notes
Notes: svn path=/head/; revision=559625
Diffstat (limited to 'audio/webrtc-audio-processing')
-rw-r--r--audio/webrtc-audio-processing/Makefile3
-rw-r--r--audio/webrtc-audio-processing/files/patch-meson.build13
2 files changed, 15 insertions, 1 deletions
diff --git a/audio/webrtc-audio-processing/Makefile b/audio/webrtc-audio-processing/Makefile
index 1261ae1a2724..b4281bc77f55 100644
--- a/audio/webrtc-audio-processing/Makefile
+++ b/audio/webrtc-audio-processing/Makefile
@@ -2,6 +2,7 @@
PORTNAME= webrtc-audio-processing
DISTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= https://freedesktop.org/software/pulseaudio/${PORTNAME}/
@@ -19,7 +20,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= cmake:devel/cmake
LIB_DEPENDS= libabsl_strings.so:devel/abseil
-USES= compiler:c++14-lang meson
+USES= compiler:c++17-lang meson
USE_LDCONFIG= yes
CFLAGS_i386= -msse # https://gitlab.freedesktop.org/pulseaudio/webrtc-audio-processing/-/issues/5
diff --git a/audio/webrtc-audio-processing/files/patch-meson.build b/audio/webrtc-audio-processing/files/patch-meson.build
new file mode 100644
index 000000000000..a006f0ca07e7
--- /dev/null
+++ b/audio/webrtc-audio-processing/files/patch-meson.build
@@ -0,0 +1,13 @@
+- Sync -std= with devel/abseil to match ABI
+
+--- meson.build.orig 2020-12-12 16:13:37 UTC
++++ meson.build
+@@ -4,7 +4,7 @@ project('webrtc-audio-processing-1', 'c', 'cpp',
+ default_options : [ 'warning_level=1',
+ 'buildtype=debugoptimized',
+ 'c_std=c11',
+- 'cpp_std=c++14',
++ 'cpp_std=c++17',
+ ]
+ )
+