aboutsummaryrefslogtreecommitdiff
path: root/audio/welle.io
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2020-10-23 19:50:54 +0000
committerSteve Wills <swills@FreeBSD.org>2020-10-23 19:50:54 +0000
commit0b89c7a0cf042dd40314c491e60e9722adb0544d (patch)
tree3bc0ca2d4b48d065113043a79a3caba0fdf60833 /audio/welle.io
parentc1353b7b79d2fdf76300cff902c400ca03d3541f (diff)
downloadports-0b89c7a0cf042dd40314c491e60e9722adb0544d.tar.gz
ports-0b89c7a0cf042dd40314c491e60e9722adb0544d.zip
audio/welle.io: create port
welle.io is a graphical SDR DAB/DAB+ receiver built with Qt5 with extensive hardware support. Possible backends are RTL-SDR, RTL_TCP, AirSpy, SoapySDR, raw files as well as gr-osmosdr and uhd. WWW: https://www.welle.io/ PR: 250564 Submitted by: Nico Sonack <nsonack@outlook.com>
Notes
Notes: svn path=/head/; revision=553136
Diffstat (limited to 'audio/welle.io')
-rw-r--r--audio/welle.io/Makefile55
-rw-r--r--audio/welle.io/distinfo3
-rw-r--r--audio/welle.io/files/patch-CMakeLists.txt11
-rw-r--r--audio/welle.io/pkg-descr5
-rw-r--r--audio/welle.io/pkg-plist8
5 files changed, 82 insertions, 0 deletions
diff --git a/audio/welle.io/Makefile b/audio/welle.io/Makefile
new file mode 100644
index 000000000000..e288706650a7
--- /dev/null
+++ b/audio/welle.io/Makefile
@@ -0,0 +1,55 @@
+# $FreeBSD$
+
+PORTNAME= welle.io
+DISTVERSION= 2.2
+CATEGORIES= audio hamradio
+MASTER_SITES= https://github.com/albrechtl/welle.io/
+
+MAINTAINER= nsonack@outlook.com
+COMMENT= SDR DAB/DAB+ Receiver
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libasound.so:audio/alsa-lib \
+ libfaad.so:audio/faad \
+ libmp3lame.so:audio/lame \
+ libmpg123.so:audio/mpg123
+
+USES= cmake pkgconfig qt:5
+USE_QT= charts core declarative gui multimedia network quickcontrols2 \
+ widgets buildtools_build qmake_build
+
+USE_GITHUB= yes
+GH_ACCOUNT= AlbrechtL
+GH_TAGNAME= c39d3420cc30281e03835b3182f34d8617eb7ebf
+
+OPTIONS_DEFINE= AIRSPY CLI FFTW RTLSDR SOAPY
+OPTIONS_DEFAULT= FFTW RTLSDR
+
+RTLSDR_DESC= RTL-SDR support
+AIRSPY_DESC= AirSpy support
+SOAPY_DESC= SoapySDR support
+FFTW_DESC= Use FFTW3 instead of KISSFFT
+CLI_DESC= Build the welle-cli tool
+
+RTLSDR_DEPENDS= rtl-sdr:comms/rtl-sdr
+RTLSDR_LIB_DEPENDS= librtlsdr.so:comms/rtl-sdr
+RTLSDR_CMAKE_BOOL= RTLSDR
+
+FFTW_CMAKE_BOOL_OFF= KISS_FFT
+FFTW_LIB_DEPENDS= libfftw3f.so:math/fftw3-float
+FFTW_BUILD_DEPENDS= fftw3>=0:math/fftw3
+
+CLI_CMAKE_BOOL= BUILD_WELLE_CLI
+CLI_PLIST_FILES= bin/welle-cli \
+ share/welle-io/html/index.html \
+ share/welle-io/html/index.js
+
+SOAPY_CMAKE_BOOL= SOAPYSDR
+SOAPY_LIB_DEPENDS= libSoapySDR.so:misc/soapysdr
+
+AIRSPY_CMAKE_BOOL= AIRSPY
+AIRSPY_LIB_DEPENDS= libairspy.so:comms/airspy
+
+.include <bsd.port.mk>
diff --git a/audio/welle.io/distinfo b/audio/welle.io/distinfo
new file mode 100644
index 000000000000..c6ed78435527
--- /dev/null
+++ b/audio/welle.io/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1603467804
+SHA256 (AlbrechtL-welle.io-2.2-c39d3420cc30281e03835b3182f34d8617eb7ebf_GH0.tar.gz) = 0fbb557b3529b85c6fb2bc7a8774aca84eac6bb43f8429952533862f29c54364
+SIZE (AlbrechtL-welle.io-2.2-c39d3420cc30281e03835b3182f34d8617eb7ebf_GH0.tar.gz) = 1651149
diff --git a/audio/welle.io/files/patch-CMakeLists.txt b/audio/welle.io/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..193879b16598
--- /dev/null
+++ b/audio/welle.io/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2020-10-23 19:39:38 UTC
++++ CMakeLists.txt
+@@ -104,7 +104,7 @@ include_directories(
+ src/input
+ src/gui
+ src/libs/fec
+- ${FFTW3F_INCLUDE_DIRS}
++ ${FFTW3F_INCLUDE_DIR}
+ ${KISS_INCLUDE_DIRS}
+ ${FAAD_INCLUDE_DIRS}
+ ${LIBRTLSDR_INCLUDE_DIRS}
diff --git a/audio/welle.io/pkg-descr b/audio/welle.io/pkg-descr
new file mode 100644
index 000000000000..19ddd34c651d
--- /dev/null
+++ b/audio/welle.io/pkg-descr
@@ -0,0 +1,5 @@
+welle.io is a graphical SDR DAB/DAB+ receiver built with Qt5 with extensive
+hardware support. Possible backends are RTL-SDR, RTL_TCP, AirSpy, SoapySDR,
+raw files as well as gr-osmosdr and uhd.
+
+WWW: https://www.welle.io/
diff --git a/audio/welle.io/pkg-plist b/audio/welle.io/pkg-plist
new file mode 100644
index 000000000000..b76cf6378edd
--- /dev/null
+++ b/audio/welle.io/pkg-plist
@@ -0,0 +1,8 @@
+share/applications/welle-io.desktop
+share/icons/hicolor/16x16/apps/welle-io.png
+share/icons/hicolor/24x24/apps/welle-io.png
+share/icons/hicolor/32x32/apps/welle-io.png
+share/icons/hicolor/48x48/apps/welle-io.png
+share/icons/hicolor/128x128/apps/welle-io.png
+share/icons/hicolor/256x256/apps/welle-io.png
+bin/welle-io