aboutsummaryrefslogtreecommitdiff
path: root/audio/x11amp
diff options
context:
space:
mode:
authorMarcel Moolenaar <marcel@FreeBSD.org>2004-02-25 06:54:24 +0000
committerMarcel Moolenaar <marcel@FreeBSD.org>2004-02-25 06:54:24 +0000
commit46bf369b65803c0ebe4f4b81bec4811a7f0eea55 (patch)
tree66efd0cd7dee5b276ad368675b13098578923d26 /audio/x11amp
parenta3d3dcf2ce6cbcdf4ad94b31107097e0e550f50a (diff)
downloadports-46bf369b65803c0ebe4f4b81bec4811a7f0eea55.tar.gz
ports-46bf369b65803c0ebe4f4b81bec4811a7f0eea55.zip
Notes
Diffstat (limited to 'audio/x11amp')
-rw-r--r--audio/x11amp/Makefile4
-rw-r--r--audio/x11amp/files/patch-Effect::voice::about.c14
-rw-r--r--audio/x11amp/files/patch-General::ir::about.c15
3 files changed, 29 insertions, 4 deletions
diff --git a/audio/x11amp/Makefile b/audio/x11amp/Makefile
index 5907e19ff11b..947dc949e002 100644
--- a/audio/x11amp/Makefile
+++ b/audio/x11amp/Makefile
@@ -25,10 +25,6 @@ MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}"
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 501000
-BROKEN= "Does not compile"
-.endif
-
post-extract:
@${CP} ${FILESDIR}/main.xpm ${WRKSRC}/x11amp/defskin
diff --git a/audio/x11amp/files/patch-Effect::voice::about.c b/audio/x11amp/files/patch-Effect::voice::about.c
new file mode 100644
index 000000000000..356aa70de19d
--- /dev/null
+++ b/audio/x11amp/files/patch-Effect::voice::about.c
@@ -0,0 +1,14 @@
+--- Effect/voice/about.c.orig Tue Feb 24 22:46:03 2004
++++ Effect/voice/about.c Tue Feb 24 22:46:43 2004
+@@ -31,9 +31,8 @@
+ dialog=gtk_dialog_new();
+ gtk_window_set_title(GTK_WINDOW(dialog),"About Voice Removal Plugin 0.9");
+ gtk_container_border_width(GTK_CONTAINER(dialog),5);
+- label=gtk_label_new("X11AMP Voice Removal Plugin 0.9\n
+-A simple voice removal plugin by
+-Anders Carlsson <anders.carlsson@tordata.se>"
++ label=gtk_label_new("X11AMP Voice Removal Plugin 0.9\n"
++"A simple voice removal plugin by Anders Carlsson <anders.carlsson@tordata.se>"
+ );
+ gtk_box_pack_start(GTK_BOX(GTK_DIALOG(dialog)->vbox),label,TRUE,TRUE,0);
+ gtk_widget_show(label);
diff --git a/audio/x11amp/files/patch-General::ir::about.c b/audio/x11amp/files/patch-General::ir::about.c
new file mode 100644
index 000000000000..11efe9decdcd
--- /dev/null
+++ b/audio/x11amp/files/patch-General::ir::about.c
@@ -0,0 +1,15 @@
+--- General/ir/about.c.orig Tue Feb 24 22:47:57 2004
++++ General/ir/about.c Tue Feb 24 22:48:46 2004
+@@ -34,9 +34,9 @@
+ gtk_container_border_width(GTK_CONTAINER(frame),5);
+ gtk_box_pack_start(GTK_BOX(vbox),frame,FALSE,FALSE,0);
+
+- label=gtk_label_new("\nCreated by Charles Sielski <stray@teklabs.net>\n
+- Control X11amp with your TV/VCR/Stereo remote \n
+- IRman page - http://www.evation.com/irman/\n");
++ label=gtk_label_new("Created by Charles Sielski <stray@teklabs.net>\n"
++ "Control X11amp with your TV/VCR/Stereo remote\n"
++ "IRman page - http://www.evation.com/irman/\n");
+
+ gtk_container_add(GTK_CONTAINER(frame),label);
+