aboutsummaryrefslogtreecommitdiff
path: root/audio/xaylet/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-07-13 13:28:36 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-07-13 13:28:36 +0000
commit63f061b66d7dc85b95837c82721bba779868728d (patch)
treee7288066687c2a665f73f9ffc11bb84a1de44b0d /audio/xaylet/Makefile
parent1f984e07c67a24985782a2a57efe0fed02ea7d35 (diff)
downloadports-63f061b66d7dc85b95837c82721bba779868728d.tar.gz
ports-63f061b66d7dc85b95837c82721bba779868728d.zip
Notes
Diffstat (limited to 'audio/xaylet/Makefile')
-rw-r--r--audio/xaylet/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/audio/xaylet/Makefile b/audio/xaylet/Makefile
new file mode 100644
index 000000000000..0cda42435dcf
--- /dev/null
+++ b/audio/xaylet/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: xaylet
+# Date created: 9 Jul 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PKGNAMEPREFIX= x
+
+COMMENT= A x11 player for the .ay audio file format
+
+ALL_TARGET= xaylet
+
+MASTERDIR= ${.CURDIR}/../aylet
+
+USE_X_PREFIX= yes
+USE_GNOME= gtk12
+
+DESCR= ${.CURDIR}/pkg-descr
+PLIST= ${.CURDIR}/pkg-plist
+
+MAN1= xaylet.1
+PLIST_FILES= bin/xaylet
+
+post-patch: aylet-post-patch
+ ${MV} ${WRKSRC}/${PORTNAME}.1 ${WRKSRC}/xaylet.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/xaylet ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/xaylet.1 ${MANPREFIX}/man/man1
+
+.include "${MASTERDIR}/Makefile"