aboutsummaryrefslogtreecommitdiff
path: root/audio/xfce4-pulseaudio-plugin
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2019-01-09 11:01:26 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2019-01-09 11:01:26 +0000
commit38f666cd29ca9fc34b9fee831d83208f5ea2bffe (patch)
tree4c0049899809b2e9381d3c46fb3d0ef3d5a4c97d /audio/xfce4-pulseaudio-plugin
parenteb4c24d06d7992f7f34799949ff3ffa8654d2b74 (diff)
downloadports-38f666cd29ca9fc34b9fee831d83208f5ea2bffe.tar.gz
ports-38f666cd29ca9fc34b9fee831d83208f5ea2bffe.zip
- Enable mpris2 and wnck support in xfce4-pulseaudio-plugin
- Add Uses=gnome - While here silence some portlint warnings PR: 234768 Submitted by: Olivier Duchateau <duchateau.olivier@gmail.com>
Notes
Notes: svn path=/head/; revision=489766
Diffstat (limited to 'audio/xfce4-pulseaudio-plugin')
-rw-r--r--audio/xfce4-pulseaudio-plugin/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/audio/xfce4-pulseaudio-plugin/Makefile b/audio/xfce4-pulseaudio-plugin/Makefile
index 399f50fa54ea..0baedf9815b0 100644
--- a/audio/xfce4-pulseaudio-plugin/Makefile
+++ b/audio/xfce4-pulseaudio-plugin/Makefile
@@ -3,6 +3,7 @@
PORTNAME= xfce4-pulseaudio-plugin
PORTVERSION= 0.4.1
+PORTREVISION= 1
CATEGORIES= audio xfce
MASTER_SITES= XFCE/src/panel-plugins/${PORTNAME}/${PORTVERSION:R}
DIST_SUBDIR= xfce4
@@ -17,15 +18,18 @@ LIB_DEPENDS= libpulse-mainloop-glib.so:audio/pulseaudio \
libdbus-glib-1.so:devel/dbus-glib
RUN_DEPENDS= pavucontrol>=2.0:audio/pavucontrol
-USES= gettext gmake libtool pkgconfig tar:bzip2 xfce:gtk3
-GNU_CONFIGURE= yes
-USE_GNOME= glib20 gtk30 intltool cairo
+USES= gettext gmake gnome libtool pkgconfig tar:bzip2 xfce:gtk3
+USE_GNOME= glib20 gtk30 intltool cairo libwnck3
USE_XFCE= panel
USE_XORG= x11
+
+GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
INSTALL_TARGET= install-strip
-CONFIGURE_ARGS=--with-mixer-command=${LOCALBASE}/bin/pavucontrol
+CONFIGURE_ARGS=--with-mixer-command=${LOCALBASE}/bin/pavucontrol \
+ --enable-mpris2 \
+ --enable-wnck
CFLAGS+= -Wno-return-type
OPTIONS_DEFINE= KEYBINDER