aboutsummaryrefslogtreecommitdiff
path: root/audio/xmms-jack
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2004-04-07 21:45:33 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2004-04-07 21:45:33 +0000
commit03ab2bbfc4e3860da447569b7e27542b9837f66b (patch)
treec0247d3dd47624136a62144956c7ff38102e05c0 /audio/xmms-jack
parent62b35c567c3849adb39c53598b31d168df3a5ad8 (diff)
downloadports-03ab2bbfc4e3860da447569b7e27542b9837f66b.tar.gz
ports-03ab2bbfc4e3860da447569b7e27542b9837f66b.zip
Notes
Diffstat (limited to 'audio/xmms-jack')
-rw-r--r--audio/xmms-jack/Makefile50
-rw-r--r--audio/xmms-jack/distinfo2
-rw-r--r--audio/xmms-jack/files/patch-configure10
-rw-r--r--audio/xmms-jack/pkg-descr6
4 files changed, 68 insertions, 0 deletions
diff --git a/audio/xmms-jack/Makefile b/audio/xmms-jack/Makefile
new file mode 100644
index 000000000000..ed3b089c5c68
--- /dev/null
+++ b/audio/xmms-jack/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: xmms-jack
+# Date created: 13 Mar 2004
+# Whom: David Yeske <dyeske@yahoo.com>
+#
+# $FreeBSD$
+
+PORTNAME= jack
+PORTVERSION= 0.9
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= xmms-jack
+PKGNAMEPREFIX= xmms-
+DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= dyeske@yahoo.com
+COMMENT= XMMS plugin for jack
+
+LIB_DEPENDS= xmms.4:${PORTSDIR}/multimedia/xmms \
+ jack.0:${PORTSDIR}/audio/jack
+
+WRKSRC= ${WRKDIR}/xmms-jack
+
+USE_X_PREFIX= yes
+USE_GNOME= gtk12 gnometarget
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+USE_REINPLACE= yes
+
+PLIST_FILES= lib/xmms/Output/libjackout.so
+
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} <= 500000
+BROKEN= "Does not compile"
+.endif
+
+post-patch:
+ @${RM} -rf ${WRKSRC}/.libs
+ @${RM} -rf ${WRKSRC}/autom4te.cache
+ @${RM} -rf ${WRKSRC}/libjackout.la
+
+ ${REINPLACE_CMD} -e \
+ 's|-lpthread|${PTHREAD_LIBS}|g; \
+ s|-ldl||' \
+ ${WRKSRC}/configure
+
+.include <bsd.port.post.mk>
diff --git a/audio/xmms-jack/distinfo b/audio/xmms-jack/distinfo
new file mode 100644
index 000000000000..7333884ee492
--- /dev/null
+++ b/audio/xmms-jack/distinfo
@@ -0,0 +1,2 @@
+MD5 (xmms-jack-0.9.tar.gz) = d7500fd15e7b58e8ad5b6a655e9b37cf
+SIZE (xmms-jack-0.9.tar.gz) = 652989
diff --git a/audio/xmms-jack/files/patch-configure b/audio/xmms-jack/files/patch-configure
new file mode 100644
index 000000000000..614f7a77b36c
--- /dev/null
+++ b/audio/xmms-jack/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Fri Jun 27 20:07:06 2003
++++ configure Fri Jun 27 20:07:21 2003
+@@ -8169,6 +8169,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/audio/xmms-jack/pkg-descr b/audio/xmms-jack/pkg-descr
new file mode 100644
index 000000000000..8d4d33e34ebf
--- /dev/null
+++ b/audio/xmms-jack/pkg-descr
@@ -0,0 +1,6 @@
+Jack output plugin for XMMS.
+
+WWW: http://xmms-jack.sourceforge.net/
+
+- David
+dyeske@yahoo.com