aboutsummaryrefslogtreecommitdiff
path: root/audio/xmms-mad/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-09-03 03:17:55 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-09-03 03:17:55 +0000
commit092135c4998244b1b229fc55b0ba1462a801e3ec (patch)
tree447f40f12d039f95bfe5f5f8b1d59fff0b0dcdb3 /audio/xmms-mad/Makefile
parent5dc9b7f571c5ff107f23c55359449e1320f5bc23 (diff)
downloadports-092135c4998244b1b229fc55b0ba1462a801e3ec.tar.gz
ports-092135c4998244b1b229fc55b0ba1462a801e3ec.zip
Notes
Diffstat (limited to 'audio/xmms-mad/Makefile')
-rw-r--r--audio/xmms-mad/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/audio/xmms-mad/Makefile b/audio/xmms-mad/Makefile
new file mode 100644
index 000000000000..e22d0a9c7b5d
--- /dev/null
+++ b/audio/xmms-mad/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: xmms-mad
+# Date created: 30 Aug 2002
+# Whom: David Yeske <dyeske@yahoo.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmms-mad
+PORTVERSION= 0.1.1
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= xmms-mad
+
+MAINTAINER= dyeske@yahoo.com
+
+LIB_DEPENDS= mad.1:${PORTSDIR}/audio/mad
+BUILD_DEPENDS= xmms-config:${PORTSDIR}/audio/xmms
+RUN_DEPENDS= xmms:${PORTSDIR}/audio/xmms
+
+USE_X_PREFIX= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>