aboutsummaryrefslogtreecommitdiff
path: root/audio/xmms-mad
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-02-23 20:38:37 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-02-23 20:38:37 +0000
commit390eeefc25466b2020e8fc6213bb320149fe8eda (patch)
treeebe49d31ad45c3c466a8cdef6fd6f8908e951a04 /audio/xmms-mad
parentc296879d02adabc55c86fb6e20fc4091d542ae20 (diff)
downloadports-390eeefc25466b2020e8fc6213bb320149fe8eda.tar.gz
ports-390eeefc25466b2020e8fc6213bb320149fe8eda.zip
Notes
Diffstat (limited to 'audio/xmms-mad')
-rw-r--r--audio/xmms-mad/Makefile22
-rw-r--r--audio/xmms-mad/distinfo6
-rw-r--r--audio/xmms-mad/files/patch-config::ltmain.sh16
-rw-r--r--audio/xmms-mad/files/patch-src::input.c13
4 files changed, 15 insertions, 42 deletions
diff --git a/audio/xmms-mad/Makefile b/audio/xmms-mad/Makefile
index c1715a0bd8b2..36e5f302449a 100644
--- a/audio/xmms-mad/Makefile
+++ b/audio/xmms-mad/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= xmms-mad
-PORTVERSION= 0.1.1
-PORTREVISION= 6
+PORTVERSION= 0.10
CATEGORIES= audio
MASTER_SITES= SF
@@ -15,19 +14,22 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A XMMS input plugin that uses libmad
LIB_DEPENDS= mad.2:${PORTSDIR}/audio/libmad \
- id3tag.0:${PORTSDIR}/audio/libid3tag
-BUILD_DEPENDS= xmms-config:${PORTSDIR}/multimedia/xmms
-RUN_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
+ id3tag.0:${PORTSDIR}/audio/libid3tag \
+ xmms.4:${PORTSDIR}/multimedia/xmms
-PLIST_FILES= lib/xmms/Input/libxmmsmad.so
+USE_BZIP2= yes
USE_GNOME= gtk12
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_LDCONFIG= yes
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
+PLIST_FILES= lib/xmms/Input/libxmmsmad.so
-CONFIGURE_ENV= CFLAGS="${CFLAGS} -L${LOCALBASE}/lib"
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
-post-patch:
- @${REINPLACE_CMD} -e '/objformat=/s|=.*|=elf|' ${WRKSRC}/configure
+do-install:
+ cd ${WRKSRC}/src/.libs \
+ && ${INSTALL_DATA} libxmmsmad.so ${PREFIX}/lib/xmms/Input
.include <bsd.port.mk>
diff --git a/audio/xmms-mad/distinfo b/audio/xmms-mad/distinfo
index 871b661940fd..7fc41ced2373 100644
--- a/audio/xmms-mad/distinfo
+++ b/audio/xmms-mad/distinfo
@@ -1,3 +1,3 @@
-MD5 (xmms-mad-0.1.1.tar.gz) = c0a55a41f4e68f33d581cc88c2a21762
-SHA256 (xmms-mad-0.1.1.tar.gz) = 70ebba5eaf54d684661aa3d89cd4085d17a5e5ceef0510a97f0df506537d00dc
-SIZE (xmms-mad-0.1.1.tar.gz) = 200293
+MD5 (xmms-mad-0.10.tar.bz2) = 410b30968bdb4adce0baec8acc7f2ed4
+SHA256 (xmms-mad-0.10.tar.bz2) = c0c89d93442c85296386199dc08a8ad9b480a29deea31936e5688c2bcc9a5265
+SIZE (xmms-mad-0.10.tar.bz2) = 228844
diff --git a/audio/xmms-mad/files/patch-config::ltmain.sh b/audio/xmms-mad/files/patch-config::ltmain.sh
deleted file mode 100644
index f002aebec32f..000000000000
--- a/audio/xmms-mad/files/patch-config::ltmain.sh
+++ /dev/null
@@ -1,16 +0,0 @@
---- config/ltmain.sh.orig Mon Sep 2 23:58:38 2002
-+++ config/ltmain.sh Mon Sep 2 23:59:23 2002
-@@ -4246,11 +4246,13 @@
- IFS="$save_ifs"
- fi
-
-+ if /usr/bin/false; then
- # Install the pseudo-library for information purposes.
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/audio/xmms-mad/files/patch-src::input.c b/audio/xmms-mad/files/patch-src::input.c
deleted file mode 100644
index f17277c38a12..000000000000
--- a/audio/xmms-mad/files/patch-src::input.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/input.c.orig Sat Aug 31 02:39:43 2002
-+++ src/input.c Sat Aug 31 02:41:14 2002
-@@ -20,6 +20,10 @@
- */
- #include "config.h"
-
-+#ifdef HAVE_SYS_TYPES_H
-+#include <sys/types.h>
-+#endif /* HAVE_SYS_TYPES_H */
-+
- #ifdef HAVE_ASSERT_H
- #include <assert.h>
- #endif /* HAVE_ASSERT_H */