aboutsummaryrefslogtreecommitdiff
path: root/audio/xmp
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2013-02-16 14:21:33 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2013-02-16 14:21:33 +0000
commit56435ea646a2bc0ea0fb620231ed9d9b3846d668 (patch)
tree3ed27c806c660bad2a35f985c893e7e4ef475126 /audio/xmp
parent00a6e20d0383c8a30fac4cd18758d3035018bf42 (diff)
downloadports-56435ea646a2bc0ea0fb620231ed9d9b3846d668.tar.gz
ports-56435ea646a2bc0ea0fb620231ed9d9b3846d668.zip
- Work around a case where .if !exists(${ETCDIR}/${f}) fails
- Consistent usage of %%ETCDIR%%
Notes
Notes: svn path=/head/; revision=312354
Diffstat (limited to 'audio/xmp')
-rw-r--r--audio/xmp/Makefile6
-rw-r--r--audio/xmp/pkg-plist10
2 files changed, 7 insertions, 9 deletions
diff --git a/audio/xmp/Makefile b/audio/xmp/Makefile
index 9cd94cbad16a..5573931693b3 100644
--- a/audio/xmp/Makefile
+++ b/audio/xmp/Makefile
@@ -50,11 +50,9 @@ post-patch:
@${REINPLACE_CMD} -e 's|\ install-conf||' ${WRKSRC}/Makefile.in
post-install:
- ${MKDIR} ${PREFIX}/etc/xmp
+ ${MKDIR} ${ETCDIR}
.for f in ${CONFIG_FILES}
-.if !exists(${ETCDIR}/${f})
- ${INSTALL_DATA} ${WRKSRC}/src/${f} ${ETCDIR}/${f}
-.endif
+ @test -f ${ETCDIR}/${f} || ${INSTALL_DATA} ${WRKSRC}/src/${f} ${ETCDIR}/${f}
${INSTALL_DATA} ${WRKSRC}/src/${f} ${ETCDIR}/${f}.sample
.endfor
diff --git a/audio/xmp/pkg-plist b/audio/xmp/pkg-plist
index 442a6cd22541..bf7dd6559cef 100644
--- a/audio/xmp/pkg-plist
+++ b/audio/xmp/pkg-plist
@@ -1,8 +1,8 @@
-@unexec if cmp -s %D/etc/xmp/xmp.conf %D/etc/xmp/xmp.conf.sample; then rm -f %D/etc/xmp/xmp.conf; fi
-etc/xmp/xmp.conf.sample
+@unexec if cmp -s %D/%%ETCDIR%%/xmp.conf %D/%%ETCDIR%%/xmp.conf.sample; then rm -f %D/%%ETCDIR%%/xmp.conf; fi
+%%ETCDIR%%/xmp.conf.sample
@exec [ -f %B/xmp.conf ] || cp %B/%f %B/xmp.conf
bin/xmp
-@unexec if cmp -s %D/etc/xmp/modules.conf %D/etc/xmp/modules.conf.sample; then rm -f %D/etc/xmp/modules.conf; fi
-etc/xmp/modules.conf.sample
+@unexec if cmp -s %D/%%ETCDIR%%/modules.conf %D/%%ETCDIR%%/modules.conf.sample; then rm -f %D/%%ETCDIR%%/modules.conf; fi
+%%ETCDIR%%/modules.conf.sample
@exec [ -f %B/modules.conf ] || cp %B/%f %B/modules.conf
-@dirrmtry etc/xmp
+@dirrmtry %%ETCDIR%%