aboutsummaryrefslogtreecommitdiff
path: root/audio/xmp
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2010-07-01 06:47:22 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2010-07-01 06:47:22 +0000
commitc4d2ed7cb46f487e4c8a440c8ce511ff0f0a4ea0 (patch)
treefe97267d8815e37b1fea6659889fd3d6a9e0f391 /audio/xmp
parenta623b63344522b0bfd8363779a50fef161ab30e5 (diff)
downloadports-c4d2ed7cb46f487e4c8a440c8ce511ff0f0a4ea0.tar.gz
ports-c4d2ed7cb46f487e4c8a440c8ce511ff0f0a4ea0.zip
Prevent unconditional linking against ALSA
PR: 148271 Submitted by: swell.k@gmail.com Feature safe: yes
Notes
Notes: svn path=/head/; revision=257250
Diffstat (limited to 'audio/xmp')
-rw-r--r--audio/xmp/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/audio/xmp/Makefile b/audio/xmp/Makefile
index d648df600298..1717abd12610 100644
--- a/audio/xmp/Makefile
+++ b/audio/xmp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xmp
PORTVERSION= 3.2.0
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= audio
MASTER_SITES= SF
@@ -23,7 +24,8 @@ CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc
MAN1= xmp.1
-OPTIONS= ARTS "aRts output driver" off \
+OPTIONS= ALSA "ALSA output driver" off \
+ ARTS "aRts output driver" off \
AUDACIOUS "Audacious plugin" off \
BMP "BeepMP plugin" off \
ESOUND "EsounD output driver" off \
@@ -40,6 +42,14 @@ MAKE_JOBS_SAFE= yes
PORTDOCS= *
.endif
+.if defined(WITH_ALSA)
+LIB_DEPENDS+= asound.2:${PORTSDIR}/audio/alsa-lib
+RUN_DEPENDS+= ${LOCALBASE}/lib/alsa-lib/libasound_module_pcm_oss.so:${PORTSDIR}/audio/alsa-plugins
+CONFIGURE_ARGS+= --enable-alsa
+.else
+CONFIGURE_ARGS+= --disable-alsa
+.endif
+
.if defined(WITH_ARTS)
LIB_DEPENDS+= artsc.0:${PORTSDIR}/audio/arts
CONFIGURE_ARGS+= --enable-arts