aboutsummaryrefslogtreecommitdiff
path: root/audio/xmp
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2009-10-05 14:43:14 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2009-10-05 14:43:14 +0000
commitd0bfb85ac2101830782c7a6156c3e6d16886ff37 (patch)
tree00879d8119d5eb29c15ae8789fd815227f9ec10e /audio/xmp
parentf54f649ac56656be69c11770d1577614ad23fecc (diff)
downloadports-d0bfb85ac2101830782c7a6156c3e6d16886ff37.tar.gz
ports-d0bfb85ac2101830782c7a6156c3e6d16886ff37.zip
- Update to 2.7.1
- Only use -fPIC on amd64 and ia64 - Remove license information from pkg-descr and generally update description - Use PLIST_SUB instead of @rmtry on conditional file Feature safe: yes
Notes
Notes: svn path=/head/; revision=242494
Diffstat (limited to 'audio/xmp')
-rw-r--r--audio/xmp/Makefile25
-rw-r--r--audio/xmp/distinfo6
-rw-r--r--audio/xmp/files/patch-src-drivers-oss_seq.c28
-rw-r--r--audio/xmp/pkg-descr15
-rw-r--r--audio/xmp/pkg-plist8
5 files changed, 33 insertions, 49 deletions
diff --git a/audio/xmp/Makefile b/audio/xmp/Makefile
index c4b283154629..6f21f54a4f3e 100644
--- a/audio/xmp/Makefile
+++ b/audio/xmp/Makefile
@@ -1,12 +1,12 @@
# New ports collection makefile for: xmp
-# Date created: 18 September 1999
-# Whom: Anders Nordby <anders@fix.no>
+# Date created: 18 September 1999
+# Whom: Anders Nordby <anders@fix.no>
#
# $FreeBSD$
#
PORTNAME= xmp
-PORTVERSION= 2.5.1
+PORTVERSION= 2.7.1
CATEGORIES= audio
MASTER_SITES= SF
@@ -27,10 +27,12 @@ MLINKS= xmp.1 xxmp.1
OPTIONS= XMMS "Build XMMS plugin" off \
ESOUND "EsounD support" off
-CFLAGS+= -fPIC
-
.include <bsd.port.pre.mk>
+.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
+CFLAGS+= -fPIC
+.endif
+
.if defined(WITH_ESOUND)
USE_GNOME+= esound
.else
@@ -40,19 +42,10 @@ CONFIGURE_ARGS+= --disable-esd
.if defined(WITH_XMMS)
LIB_DEPENDS+= xmms.4:${PORTSDIR}/multimedia/xmms
CONFIGURE_ARGS+= --enable-xmms-plugin
+PLIST_SUB+= XMMS=""
.else
CONFIGURE_ARGS+= --disable-xmms
+PLIST_SUB+= XMMS="@comment "
.endif
-post-patch:
-.for f in docs/xmp.1 etc/xmp.conf etc/xmp-modules.conf
- @${REINPLACE_CMD} -e "s|/etc/xmp|${PREFIX}/etc/xmp|g" ${WRKSRC}/${f}
-.endfor
- @${REINPLACE_CMD} -E -e 's|(^DDIRS.*)etc|\1|' ${WRKSRC}/Makefile
-
-post-install:
- @${MKDIR} ${PREFIX}/etc/xmp
- @${INSTALL_DATA} ${WRKSRC}/etc/xmp.conf ${PREFIX}/etc/xmp/xmp.conf.default
- @${INSTALL_DATA} ${WRKSRC}/etc/xmp-modules.conf ${PREFIX}/etc/xmp/xmp-modules.conf.default
-
.include <bsd.port.post.mk>
diff --git a/audio/xmp/distinfo b/audio/xmp/distinfo
index c4a70d71fb8e..0ed4ceb6be8c 100644
--- a/audio/xmp/distinfo
+++ b/audio/xmp/distinfo
@@ -1,3 +1,3 @@
-MD5 (xmp-2.5.1.tar.gz) = 79040d5ae0efaf7ea116c5fe05d99b75
-SHA256 (xmp-2.5.1.tar.gz) = af9dedfc6f312c1f68fb73f286be26b67755877c6b53803b9dea9f3d189b992f
-SIZE (xmp-2.5.1.tar.gz) = 772595
+MD5 (xmp-2.7.1.tar.gz) = bbed5ba3dc9bd8ff38133b31fd5b8846
+SHA256 (xmp-2.7.1.tar.gz) = 84b1bfc00e254fe1eb1e6a2932c27b2695f6d401fbe4e244b740289e9101c805
+SIZE (xmp-2.7.1.tar.gz) = 794986
diff --git a/audio/xmp/files/patch-src-drivers-oss_seq.c b/audio/xmp/files/patch-src-drivers-oss_seq.c
index 78b7d5fbf018..0ccf36f16214 100644
--- a/audio/xmp/files/patch-src-drivers-oss_seq.c
+++ b/audio/xmp/files/patch-src-drivers-oss_seq.c
@@ -1,26 +1,26 @@
---- src/drivers/oss_seq.c.orig 2008-04-16 20:48:53.000000000 +0200
-+++ src/drivers/oss_seq.c 2008-04-16 20:49:05.000000000 +0200
-@@ -141,7 +141,6 @@
+--- ./src/drivers/oss_seq.c.orig 2009-10-05 14:12:41.000000000 +0200
++++ ./src/drivers/oss_seq.c 2009-10-05 14:14:09.000000000 +0200
+@@ -138,7 +138,6 @@
#endif
- if (num > SEQ_NUM_VOICES)
- return SEQ_NUM_VOICES;
-- GUS_NUMVOICES (dev, num);
- break;
- }
+ if (num > SEQ_NUM_VOICES)
+ return SEQ_NUM_VOICES;
+- GUS_NUMVOICES(dev, num);
+ break;
+ }
-@@ -151,7 +150,6 @@
+@@ -147,7 +146,6 @@
static void voicepos(int ch, int pos)
{
-- GUS_VOICE_POS (dev, ch, pos);
+- GUS_VOICE_POS(dev, ch, pos);
}
-
-@@ -204,7 +202,6 @@
+ static void echoback(int msg)
+@@ -194,7 +192,6 @@
static void setpan(struct xmp_context *ctx, int ch, int pan)
{
-- GUS_VOICEBALA(dev, ch, (pan + 0x80) >> 4)
+- GUS_VOICEBALA(dev, ch, (pan + 0x80) >> 4)
}
-
+ static void setbend(int ch, int bend)
diff --git a/audio/xmp/pkg-descr b/audio/xmp/pkg-descr
index d08e8e9622fc..994d1fe6a4a7 100644
--- a/audio/xmp/pkg-descr
+++ b/audio/xmp/pkg-descr
@@ -1,14 +1,5 @@
-This is the Extended Module Player, an open source module player for UNIX
-distributed under the terms of the GNU GPL. xmp currently runs on several
-platforms, including ALSA, OSS (for Linux on i386 and Alpha and FreeBSD),
-BSD, SunOS, Solaris, S/Linux and HP-UX. On PC class machines with GUS or
-AWE cards xmp takes advantage of the OSS sequencer to play modules with
-virtually no system load. Using software mixing, xmp plays at rates up to
-48 kHz in mono or stereo, 8 or 16 bits, signed or unsigned, little or big
-endian samples with 32 bit linear interpolation.
-
-The current version of xmp supports many Amiga and PC module formats
-(including packed, Powerpacked and SQSHed modules) -- currently 47 known
-formats.
+The Extended Module Player, or xmp, is a portable command-line module player
+supports over 80 mainstream and obscure module formats from Amiga, Atari,
+Acorn, Apple IIgs and PC.
WWW: http://xmp.sourceforge.net/
diff --git a/audio/xmp/pkg-plist b/audio/xmp/pkg-plist
index 3972708e577e..820ca30bac2c 100644
--- a/audio/xmp/pkg-plist
+++ b/audio/xmp/pkg-plist
@@ -1,5 +1,5 @@
bin/xmp
-etc/xmp/xmp.conf.default
-etc/xmp/xmp-modules.conf.default
-@dirrmtry etc/xmp
-@rmtry lib/xmms/Input/xmp-xmms.so
+etc/xmp/xmp.conf
+etc/xmp/modules.conf
+%%XMMS%%lib/xmms/Input/xmp-xmms.so
+@dirrm etc/xmp