aboutsummaryrefslogtreecommitdiff
path: root/audio/yell
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-08-13 18:41:51 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-08-13 18:41:51 +0000
commit92090216409817821b0d5ae827a16d495258fd7d (patch)
tree6012035aa4d9ee5b01ba01ca3fe4b0a47c1397c3 /audio/yell
parentc4cafa53d10d2bf10ccbc22f3b500cadb133251e (diff)
downloadports-92090216409817821b0d5ae827a16d495258fd7d.tar.gz
ports-92090216409817821b0d5ae827a16d495258fd7d.zip
Add yell, a little command line utility playing a short tune on your
speaker device. I mainly use it to yell the "sysop" on a remote machine. It could also be used as a notification for finished tasks (eg. make buildworld && yell). PR: ports/70277 Submitted by: Emanuel Haupt <ehaupt@critical.ch>
Notes
Notes: svn path=/head/; revision=116141
Diffstat (limited to 'audio/yell')
-rw-r--r--audio/yell/Makefile39
-rw-r--r--audio/yell/distinfo2
-rw-r--r--audio/yell/pkg-descr9
-rw-r--r--audio/yell/pkg-message6
4 files changed, 56 insertions, 0 deletions
diff --git a/audio/yell/Makefile b/audio/yell/Makefile
new file mode 100644
index 000000000000..0a78b454c080
--- /dev/null
+++ b/audio/yell/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: yell
+# Date created: 10 August 2004
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= yell
+PORTVERSION= 1.0
+CATEGORIES= audio
+MASTER_SITES= http://www.critical.ch/yell/
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= A command line speaker bell using machine/speaker.h
+
+PLIST_FILES= bin/yell
+
+pre-everything::
+.if !defined(WITH_SUID)
+ @${ECHO_CMD} ""
+ @${ECHO_CMD} "You can define WITH_SUID if you want yell to be installed with"
+ @${ECHO_CMD} "the sticky bit (mode 4110)"
+ @${ECHO_CMD} ""
+.endif
+
+do-build:
+ ${CC} ${WRKSRC}/yell.c ${CFLAGS} -o ${WRKSRC}/${PORTNAME}
+
+do-install:
+.if defined(WITH_SUID)
+ ${INSTALL_PROGRAM} -m 4110 ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+.else
+ ${INSTALL_PROGRAM} -m 0100 ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/audio/yell/distinfo b/audio/yell/distinfo
new file mode 100644
index 000000000000..a0393ff6852c
--- /dev/null
+++ b/audio/yell/distinfo
@@ -0,0 +1,2 @@
+MD5 (yell-1.0.tar.gz) = 63b682dd3e34e953197ef2294ad80a5f
+SIZE (yell-1.0.tar.gz) = 914
diff --git a/audio/yell/pkg-descr b/audio/yell/pkg-descr
new file mode 100644
index 000000000000..fe7aa66e7bcf
--- /dev/null
+++ b/audio/yell/pkg-descr
@@ -0,0 +1,9 @@
+Yell is a little command line utility playing a short tune on your
+speaker device. I mainly use it to yell the "sysop" on a remote
+machine. It could also be used as a notification for finished tasks
+(eg. make buildworld && yell).
+
+WWW: http://www.critical.ch/yell
+
+- ehaupt
+ehaupt@critical.ch
diff --git a/audio/yell/pkg-message b/audio/yell/pkg-message
new file mode 100644
index 000000000000..a662b2287298
--- /dev/null
+++ b/audio/yell/pkg-message
@@ -0,0 +1,6 @@
+*******************************************************************************
+yell is now installed. Make sure that speaker.ko is loaded on your system.
+Under FreeBSD 5.x you can put atspeaker_load="YES" in your /boot/loader.conf.
+You can manually load speaker.ko by typing "kldload speaker" or recompile your
+kernel with "device speaker".
+*******************************************************************************