aboutsummaryrefslogtreecommitdiff
path: root/audio/yoshimi/Makefile
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2017-11-11 14:49:27 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2017-11-11 14:49:27 +0000
commit1cd203d9be0e24f165775e7edf355cb8e4bf4761 (patch)
tree21f44ccaafa206c9052928989da2722888905e28 /audio/yoshimi/Makefile
parent41cd01ca6665d5aee8597751e0dca3f577fbf32d (diff)
downloadports-1cd203d9be0e24f165775e7edf355cb8e4bf4761.tar.gz
ports-1cd203d9be0e24f165775e7edf355cb8e4bf4761.zip
Notes
Diffstat (limited to 'audio/yoshimi/Makefile')
-rw-r--r--audio/yoshimi/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/audio/yoshimi/Makefile b/audio/yoshimi/Makefile
new file mode 100644
index 000000000000..0e1640c84425
--- /dev/null
+++ b/audio/yoshimi/Makefile
@@ -0,0 +1,38 @@
+# $FreeBSD$
+
+PORTNAME= yoshimi
+DISTVERSION= 1.5.4.1-28
+DISTVERSIONSUFFIX= -g31291f0d
+CATEGORIES= audio
+
+MAINTAINER= hello@blubee.me
+COMMENT= Sophisticated software synthesizer
+
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= lv2>0:audio/lv2 \
+ dssi>0:audio/dssi \
+ ${LOCALBASE}/include/fftw3.h:math/fftw3
+LIB_DEPENDS= libargp.so:devel/argp-standalone \
+ libfftw3f.so:math/fftw3-float \
+ libfltk.so:x11-toolkits/fltk \
+ libfreetype.so:print/freetype2 \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libjack.so:audio/jack \
+ libmxml.so:textproc/mxml
+
+USES= cmake:outsource ncurses pkgconfig readline:port
+USE_GITHUB= yes
+USE_GNOME= cairo
+USE_GL= gl glu
+USE_XORG= x11 ice sm xext
+
+CMAKE_SOURCE_PATH= ${WRKSRC}/src
+INSTALLS_ICONS= yes
+
+post-install:
+ @${MV} ${STAGEDIR}${PREFIX}/share/yoshimi/yoshimi-user-manual.pdf \
+ ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>