aboutsummaryrefslogtreecommitdiff
path: root/audio/zam-plugins-lv2
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2019-07-25 02:33:12 +0000
committerMark Linimon <linimon@FreeBSD.org>2019-07-25 02:33:12 +0000
commita00547aa72ab3b19fa4ac7e625957268b5bde020 (patch)
tree8f064e1af03aea8995df1486c606791119cc6924 /audio/zam-plugins-lv2
parent666c4ef78a350b5898d1a5f05185d7ff8b1948ac (diff)
downloadports-a00547aa72ab3b19fa4ac7e625957268b5bde020.tar.gz
ports-a00547aa72ab3b19fa4ac7e625957268b5bde020.zip
Prepare for powerpc-on-clang by deleting hard-coded tests for architecture
as a stand-in for "are we running on gcc". In some cases we only need to specifically test for "are we on the ancient base gcc", e.g, the usage of 'pragma'. While here, in some cases turn off SSE functions more specifically based on ARCH, and turn off -mtune=generic everywhere. These are part of a larger work in progress; these commits are for ports that would have been touched by the the powerpc-on-clang test regardless. Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=507308
Diffstat (limited to 'audio/zam-plugins-lv2')
-rw-r--r--audio/zam-plugins-lv2/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/audio/zam-plugins-lv2/Makefile b/audio/zam-plugins-lv2/Makefile
index 67b16f120776..500588bdd973 100644
--- a/audio/zam-plugins-lv2/Makefile
+++ b/audio/zam-plugins-lv2/Makefile
@@ -36,8 +36,10 @@ post-extract:
post-patch:
@${REINPLACE_CMD} -e 's|#!/bin/bash|#!/bin/sh|' ${WRKSRC}/dpf/utils/generate-ttl.sh
-.if ${ARCH} == aarch64 || ${ARCH:Marmv*} || ${ARCH:Mmips*} || ${ARCH:Mpowerpc*} || ${ARCH} == sparc64
- ${REINPLACE_CMD} -e 's/-mtune=generic -msse -msse2//' \
+ ${REINPLACE_CMD} -e 's/-mtune=generic//' \
+ ${WRKSRC}/dpf/Makefile.base.mk
+.if ! ${ARCH} == amd64 && ! ${ARCH} == i386
+ ${REINPLACE_CMD} -e 's/-msse -msse2//' \
${WRKSRC}/dpf/Makefile.base.mk
.endif