aboutsummaryrefslogtreecommitdiff
path: root/audio/zinf/files
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2002-08-08 19:17:19 +0000
committerAnders Nordby <anders@FreeBSD.org>2002-08-08 19:17:19 +0000
commit266f4a970ebce5d9be4330275dd5051801c26d9c (patch)
tree2191c386bf51d1cf060d251e99c8278f11b3a578 /audio/zinf/files
parent851dbf9a25a6c6456afb30885db76aae853ceb90 (diff)
downloadports-266f4a970ebce5d9be4330275dd5051801c26d9c.tar.gz
ports-266f4a970ebce5d9be4330275dd5051801c26d9c.zip
Notes
Diffstat (limited to 'audio/zinf/files')
-rw-r--r--audio/zinf/files/patch-aa73
-rw-r--r--audio/zinf/files/patch-ac10
-rw-r--r--audio/zinf/files/patch-ad20
-rw-r--r--audio/zinf/files/patch-io-signature-src-signaturepmo.cpp10
-rw-r--r--audio/zinf/files/patch-zlib-infcodes.c21
-rw-r--r--audio/zinf/files/patch-zlib-inffast.c67
-rw-r--r--audio/zinf/files/patch-zlib-zconf.h28
-rw-r--r--audio/zinf/files/sdr2.plugin.S100.audio.rtp.mpa.zinf (renamed from audio/zinf/files/sdr2.plugin.S100.audio.rtp.mpa.freeamp)2
8 files changed, 159 insertions, 72 deletions
diff --git a/audio/zinf/files/patch-aa b/audio/zinf/files/patch-aa
index a28137bd431c..e9529418ee8e 100644
--- a/audio/zinf/files/patch-aa
+++ b/audio/zinf/files/patch-aa
@@ -1,6 +1,6 @@
---- configure.in.orig Mon Dec 10 16:42:31 2001
-+++ configure.in Thu Mar 14 23:34:42 2002
-@@ -179,8 +179,8 @@
+--- configure.in.orig Mon Jun 24 01:44:27 2002
++++ configure.in Sat Aug 3 22:49:49 2002
+@@ -172,8 +172,8 @@
;;
freebsd*)
host_os="freebsd"
@@ -11,19 +11,18 @@
;;
netbsd*)
host_os="freebsd"
-@@ -331,9 +331,9 @@
- sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\2/'`
+@@ -325,8 +325,10 @@
esd_micro_version=`$ESD_CONFIG $esd_config_args --version | \
sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
-- ac_save_CFLAGS="$CFLAGS"
+ ac_save_CFLAGS="$CFLAGS"
+ ac_save_CPPFLAGS="$CPPFLAGS"
ac_save_LIBS="$LIBS"
-- CFLAGS="$CFLAGS $ESD_CFLAGS"
+ CFLAGS="$CFLAGS $ESD_CFLAGS"
+ CPPFLAGS="$CPPFLAGS $ESD_CFLAGS"
LIBS="$LIBS $ESD_LIBS"
rm -f conf.esdtest
AC_MSG_CHECKING(for ESD - version >= $min_esd_version)
-@@ -392,7 +392,7 @@
+@@ -385,7 +387,7 @@
}
],, have_esound=false, have_esound=false)
@@ -32,7 +31,7 @@
LIBS="$ac_save_LIBS"
AC_LANG_RESTORE
rm -f conf.esdtest
-@@ -419,7 +419,7 @@
+@@ -412,7 +414,7 @@
dnl optional freetype support..
save_CPPFLAGS="$CPPFLAGS"
@@ -41,7 +40,7 @@
AC_LANG_SAVE
AC_LANG_C
AC_CHECK_HEADERS(freetype.h, have_freetype="true", have_freetype="false")
-@@ -465,9 +465,9 @@
+@@ -459,9 +461,9 @@
gtk_config_major=`$GTK_CONFIG --version | sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\1/'`
gtk_config_minor=`$GTK_CONFIG --version | sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\2/'`
gtk_config_micro=`$GTK_CONFIG --version | sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
@@ -53,7 +52,7 @@
LIBS="$GTK_LIBS $LIBS"
AC_TRY_RUN([
-@@ -494,7 +494,7 @@
+@@ -488,7 +490,7 @@
gtk_major_version, gtk_minor_version, gtk_micro_version);
return 1;
}], , have_gtk=false, have_gtk=false])
@@ -62,17 +61,17 @@
LIBS="$ac_save_LIBS"
if test "$have_gtk" = "false"; then
AC_MSG_RESULT(no)
-@@ -515,7 +515,7 @@
+@@ -509,7 +511,7 @@
OSINC="$OSINC -I$srcdir/ui/download/unix/include"
OSINC="$OSINC -I$srcdir/ui/musicbrowser/include"
OSINC="$OSINC -I$srcdir/ftc/kjofol"
- CFLAGS="$CFLAGS $GTK_CFLAGS"
+ CPPFLAGS="$CPPFLAGS $GTK_CFLAGS"
AC_DEFINE(HAVE_GTK)
- elif test "$host_os" = "beos"; then
- OSDEPPLUGINS="$OSDEPPLUGINS plugins/musicbrowser.ui"
-@@ -541,17 +541,10 @@
- AC_SUBST(GTK_LIBS)
+ else
+ GTK_CFLAGS=""
+@@ -530,18 +532,10 @@
+ AC_SUBST(GTK_PREFIX)
AC_SUBST(EXTRALIBS)
-AC_SUBST(CFLAGS)
@@ -80,7 +79,8 @@
dnl orbit crap
-save_CPPFLAGS="$CPPFLAGS"
--CPPFLAGS="$CPPFLAGS $GTK_CFLAGS"
+-ORBIT_CPP_CFLAGS=`orbit-config --cflags server`
+-CPPFLAGS="$CPPFLAGS $GTK_CFLAGS $ORBIT_CPP_CFLAGS"
-AC_LANG_SAVE
-AC_LANG_C
-AC_CHECK_HEADERS(orb/orbit.h, have_orbit="true", have_orbit="false")
@@ -91,7 +91,7 @@
ORBIT_LIBS=""
ORBIT_IDL=""
-@@ -661,7 +654,7 @@
+@@ -651,7 +645,7 @@
alsa_min_major_version=0
alsa_min_minor_version=5
alsa_min_micro_version=0
@@ -100,7 +100,7 @@
ac_save_LIBS="$LIBS"
LIBS="$LIBS -lasound"
-@@ -706,7 +699,7 @@
+@@ -696,7 +690,7 @@
], , have_alsa=false, have_alsa=false
)
AC_LANG_RESTORE
@@ -109,18 +109,17 @@
LIBS="$ac_save_LIBS"
if test "$have_alsa" = "false"; then
AC_MSG_RESULT(no)
-@@ -726,6 +719,10 @@
+@@ -716,6 +710,9 @@
AC_MSG_RESULT([compiling alsa pmo plugin])
fi
-+
+AC_ARG_ENABLE(vorbis, [ --disable-vorbis Don't compile the Vorbis output plugin], enable_vorbis=no, enable_vorbis=yes)
+
+if test "x$enable_vorbis" = "xyes"; then
AC_CHECK_LIB(ogg, ogg_sync_init, have_ogg="yes",)
AC_CHECK_LIB(vorbisfile, ov_info, have_vorbis="yes",, -lvorbis -logg)
-@@ -736,6 +733,7 @@
+@@ -726,6 +723,7 @@
OSDEPPLUGINS="$OSDEPPLUGINS plugins/vorbis.mdf";
AC_MSG_RESULT([compiling vorbis codec plugin])
fi
@@ -128,25 +127,7 @@
fi
ID3_LIBS=""
-@@ -749,6 +747,9 @@
- dnl Partly taken from SDL's configure.in
- dnl -------------------------------------------------------------
-
-+AC_ARG_ENABLE(arts, [ --disable-arts Don't compile the libArts output plugin], enable_arts=no, enable_arts=yes)
-+
-+if test "x$enable_arts" = "xyes"; then
- AC_PATH_PROG(ARTSCCONFIG, artsc-config)
- if test x$ARTSCCONFIG = x -o x$ARTSCCONFIG = x'"$ARTSCCONFIG"'; then
- : # arts isn't installed
-@@ -765,6 +766,7 @@
- AC_MSG_RESULT([compiling arts pmo plugin])
- ])
- fi
-+fi
-
- AC_SUBST(ARTS_LIBS)
- AC_SUBST(EXTRALIBS)
-@@ -819,9 +821,9 @@
+@@ -813,9 +811,9 @@
gdk_pixbuf_micro_version=`$GDK_PIXBUF_CONFIG $gdk_pixbuf_config_args --version | \
sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
if test "x$enable_gdk_pixbuftest" = "xyes" ; then
@@ -158,7 +139,7 @@
LIBS="$LIBS $GDK_PIXBUF_LIBS"
dnl
dnl Now check if the installed GDK_PIXBUF is sufficiently new. (Also sanity
-@@ -883,7 +885,7 @@
+@@ -877,7 +875,7 @@
}
],, no_gdk_pixbuf=yes,[echo $ac_n "cross compiling; assumed OK... $ac_c"])
@@ -167,7 +148,7 @@
LIBS="$ac_save_LIBS"
fi
fi
-@@ -902,7 +904,7 @@
+@@ -896,7 +894,7 @@
:
else
echo "*** Could not run GDK_PIXBUF test program, checking why..."
@@ -176,7 +157,7 @@
LIBS="$LIBS $GDK_PIXBUF_LIBS"
AC_TRY_LINK([
#include <stdio.h>
-@@ -921,7 +923,7 @@
+@@ -915,7 +913,7 @@
echo "*** exact error that occured. This usually means GDK_PIXBUF was incorrectly installed"
echo "*** or that you have moved GDK_PIXBUF since it was installed. In the latter case, you"
echo "*** may want to edit the gdk-pixbuf-config script: $GDK_PIXBUF_CONFIG" ])
@@ -185,7 +166,7 @@
LIBS="$ac_save_LIBS"
fi
fi
-@@ -933,8 +935,8 @@
+@@ -927,8 +925,8 @@
AC_SUBST(GDK_PIXBUF_LIBS)
rm -f conf.gdk_pixbuftest
@@ -196,7 +177,7 @@
AC_LANG_SAVE
AC_LANG_CPLUSPLUS
-@@ -944,7 +946,7 @@
+@@ -938,7 +936,7 @@
echo "*** Download the library from "
echo "*** http://www.musicbrainz.org/download.html"
echo "***"
diff --git a/audio/zinf/files/patch-ac b/audio/zinf/files/patch-ac
index 9ac6033089d5..3ccdbc6010ff 100644
--- a/audio/zinf/files/patch-ac
+++ b/audio/zinf/files/patch-ac
@@ -1,15 +1,15 @@
---- Makefile.header.in.orig Sun Jan 28 15:43:24 2001
-+++ Makefile.header.in Sat Jun 30 07:33:57 2001
-@@ -71,7 +71,7 @@
+--- Makefile.header.in.orig Sat Aug 3 22:50:21 2002
++++ Makefile.header.in Sat Aug 3 22:51:50 2002
+@@ -72,7 +72,7 @@
- INCLUDES = -I. -I$(srcdir)/lib/gdbm -I$(srcdir)/base/include -I$(srcdir)/config -I$(srcdir)/io/include -I$(srcdir)/ui/include -I$(srcdir)/lmc/include -I$(srcdir)/io/soundcard/unix/$(UNIX_AUDIO_API)/include -I$(srcdir)/lmc/xingmp3/include -I$(srcdir)/lmc/cd/include -I$(srcdir)/plm/portable/pmp300/sba -I$(srcdir)/lib/xml/include -I$(srcdir)/lib/zlib/include -I$(srcdir)/lib/unzip/include -I$(srcdir)/io/cd/unix/include -I$(srcdir)/base/aps -I$(srcdir)/io/wavout/include -I$(srcdir)/ui/lcd/include -I$(srcdir)/ui/irman/include -I$(srcdir)/lib/http/include -I$(srcdir)/io/signature/include -I$(srcdir)/plm/metadata/id3v2 $(OSINC)
+ INCLUDES = -I. -I$(srcdir)/lib/gdbm -I$(srcdir)/base/include -I$(srcdir)/config -I$(srcdir)/io/include -I$(srcdir)/ui/include -I$(srcdir)/lmc/include -I$(srcdir)/io/soundcard/unix/$(UNIX_AUDIO_API)/include -I$(srcdir)/lmc/xingmp3/include -I$(srcdir)/lmc/cd/include -I$(srcdir)/plm/portable/pmp300/sba -I$(srcdir)/lib/xml/include -I$(srcdir)/lib/zlib/include -I$(srcdir)/lib/unzip/include -I$(srcdir)/io/cd/unix/include -I$(srcdir)/base/aps -I$(srcdir)/io/wavout/include -I$(srcdir)/ui/lcd/include -I$(srcdir)/ui/irman/include -I$(srcdir)/lib/http/include -I$(srcdir)/io/signature/include -I$(srcdir)/plm/metadata/id3v2 -I$(srcdir)/lmc/wav/include $(OSINC)
-CXXFLAGS = $(EXTRA_CXXFLAGS)
+CXXFLAGS = @CXXFLAGS@ -D_REENTRANT
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
mkinstalldirs = $(SHELL) $(srcdir)/config/mkinstalldirs
CONFIG_HEADER = ./config/config.h
-@@ -87,8 +87,8 @@
+@@ -88,8 +88,8 @@
X_EXTRA_LIBS = @X_EXTRA_LIBS@
X_PRE_LIBS = @X_PRE_LIBS@
diff --git a/audio/zinf/files/patch-ad b/audio/zinf/files/patch-ad
index 9e5f9a6a6c07..6657f35b715e 100644
--- a/audio/zinf/files/patch-ad
+++ b/audio/zinf/files/patch-ad
@@ -1,11 +1,11 @@
---- Makefile-plugins.in.orig Tue Oct 16 13:31:05 2001
-+++ Makefile-plugins.in Wed Dec 12 03:25:45 2001
-@@ -232,7 +232,7 @@
- UNIXFREEAMPUIOBJ += ui/freeamp/unix/src/GTKPreferenceWindow.o
- UNIXFREEAMPUIOBJ += ui/freeamp/unix/src/GTKFileSelector.o
- UNIXFREEAMPUIOBJ += ui/musicbrowser/unix/src/gtkmessagedialog.o
--UNIXFREEAMPUILIBS = $(TTF_LIBS) $(GDK_PIXBUF_LIBS)
-+UNIXFREEAMPUILIBS = $(TTF_LIBS) $(GDK_PIXBUF_LIBS) $(GTK_LIBS)
+--- Makefile-plugins.in.orig Sat Aug 3 22:53:07 2002
++++ Makefile-plugins.in Sat Aug 3 22:54:02 2002
+@@ -200,7 +200,7 @@
+ UNIXZINFUIOBJ += ui/zinf/unix/src/GTKPreferenceWindow.o
+ UNIXZINFUIOBJ += ui/zinf/unix/src/GTKFileSelector.o
+ UNIXZINFUIOBJ += ui/musicbrowser/unix/src/gtkmessagedialog.o
+-UNIXZINFUILIBS = $(TTF_LIBS) $(GDK_PIXBUF_LIBS)
++UNIXZINFUILIBS = $(TTF_LIBS) $(GDK_PIXBUF_LIBS) $(GTK_LIBS)
- BEOSFREEAMPUIOBJ = ui/freeamp/beos/src/BeOSWindow.o
- BEOSFREEAMPUIOBJ += ui/freeamp/beos/src/BeOSBitmap.o
+ plugins/zinf.ui: $(ZINFUIOBJ)
+ $(LINKMOD) -o $@ $(ZINFUIOBJ) $(ZINFUILIBS)
diff --git a/audio/zinf/files/patch-io-signature-src-signaturepmo.cpp b/audio/zinf/files/patch-io-signature-src-signaturepmo.cpp
deleted file mode 100644
index c16ea2f477e1..000000000000
--- a/audio/zinf/files/patch-io-signature-src-signaturepmo.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./io/signature/src/signaturepmo.cpp.orig Thu Oct 26 18:51:32 2000
-+++ ./io/signature/src/signaturepmo.cpp Sun Apr 7 01:40:32 2002
-@@ -27,7 +27,6 @@
- #endif
- #include <stdio.h>
- #include <stdlib.h>
--#include <malloc.h>
-
- /* project headers */
- #include "config.h"
diff --git a/audio/zinf/files/patch-zlib-infcodes.c b/audio/zinf/files/patch-zlib-infcodes.c
new file mode 100644
index 000000000000..635646f8bddb
--- /dev/null
+++ b/audio/zinf/files/patch-zlib-infcodes.c
@@ -0,0 +1,21 @@
+--- lib/zlib/src/infcodes.c.orig Thu Jun 20 08:40:24 2002
++++ lib/zlib/src/infcodes.c Sun Aug 4 16:45:11 2002
+@@ -197,8 +197,18 @@
+ c->mode = COPY;
+ case COPY: /* o: copying bytes in window, waiting for space */
+ f = q - c->sub.copy.dist;
++#ifdef __FreeBSD__
++ {
++ /* Work-around for a FreeBSD gcc bug. */
++ volatile inflate_blocks_statef *s1 = s;
++
++ while (f < s1->window) /* modulo window size-"while" instead */
++ f += s1->end - s1->window; /* of "if" handles invalid distances */
++ }
++#else
+ while (f < s->window) /* modulo window size-"while" instead */
+ f += s->end - s->window; /* of "if" handles invalid distances */
++#endif
+ while (c->len)
+ {
+ NEEDOUT
diff --git a/audio/zinf/files/patch-zlib-inffast.c b/audio/zinf/files/patch-zlib-inffast.c
new file mode 100644
index 000000000000..59c283dd0e5b
--- /dev/null
+++ b/audio/zinf/files/patch-zlib-inffast.c
@@ -0,0 +1,67 @@
+--- lib/zlib/src/inffast.c.orig Thu Jun 20 08:40:24 2002
++++ lib/zlib/src/inffast.c Sun Aug 4 17:16:50 2002
+@@ -1,5 +1,5 @@
+ /* inffast.c -- process literals and length/distance pairs fast
+- * Copyright (C) 1995-1998 Mark Adler
++ * Copyright (C) 1995-2002 Mark Adler
+ * For conditions of distribution and use, see copyright notice in zlib.h
+ */
+
+@@ -93,28 +93,41 @@
+
+ /* do the copy */
+ m -= c;
+- if ((uInt)(q - s->window) >= d) /* offset before dest */
+- { /* just copy */
+- r = q - d;
+- *q++ = *r++; c--; /* minimum count is three, */
+- *q++ = *r++; c--; /* so unroll loop a little */
+- }
+- else /* else offset after destination */
++ r = q - d;
++ if (r < s->window) /* wrap if needed */
+ {
+- e = d - (uInt)(q - s->window); /* bytes from offset to end */
+- r = s->end - e; /* pointer to offset */
+- if (c > e) /* if source crosses, */
++ do {
++ r += s->end - s->window; /* force pointer in window */
++ } while (r < s->window); /* covers invalid distances */
++ e = s->end - r;
++ if (c > e)
+ {
+- c -= e; /* copy to end of window */
++ c -= e; /* wrapped copy */
+ do {
+- *q++ = *r++;
++ *q++ = *r++;
+ } while (--e);
+- r = s->window; /* copy rest from start of window */
++ r = s->window;
++ do {
++ *q++ = *r++;
++ } while (--c);
+ }
++ else /* normal copy */
++ {
++ *q++ = *r++; c--;
++ *q++ = *r++; c--;
++ do {
++ *q++ = *r++;
++ } while (--c);
++ }
++ }
++ else /* normal copy */
++ {
++ *q++ = *r++; c--;
++ *q++ = *r++; c--;
++ do {
++ *q++ = *r++;
++ } while (--c);
+ }
+- do { /* copy all or what's left */
+- *q++ = *r++;
+- } while (--c);
+ break;
+ }
+ else if ((e & 64) == 0)
diff --git a/audio/zinf/files/patch-zlib-zconf.h b/audio/zinf/files/patch-zlib-zconf.h
new file mode 100644
index 000000000000..9f4ca4b60d38
--- /dev/null
+++ b/audio/zinf/files/patch-zlib-zconf.h
@@ -0,0 +1,28 @@
+--- lib/zlib/include/zconf.h.orig Sun Aug 4 20:51:32 2002
++++ lib/zlib/include/zconf.h Sun Aug 4 20:53:27 2002
+@@ -238,15 +238,25 @@
+ #ifdef HAVE_UNISTD_H
+ # include <sys/types.h> /* for off_t */
+ # include <unistd.h> /* for SEEK_* and off_t */
++#ifndef __FreeBSD__
+ # define z_off_t off_t
+ #endif
++#endif
+ #ifndef SEEK_SET
+ # define SEEK_SET 0 /* Seek from beginning of file. */
+ # define SEEK_CUR 1 /* Seek from current position. */
+ # define SEEK_END 2 /* Set file pointer to EOF plus "offset" */
+ #endif
++#ifndef __FreeBSD__
+ #ifndef z_off_t
+ # define z_off_t long
++#endif
++#else
++/*
++ * This is hard-configured for FreeBSD, since zlib doesn't actually support
++ * using the system off_t for offsets unless off_t is no longer than long.
++ */
++#define z_off_t long
+ #endif
+
+ /* MVS linker does not support external names larger than 8 bytes */
diff --git a/audio/zinf/files/sdr2.plugin.S100.audio.rtp.mpa.freeamp b/audio/zinf/files/sdr2.plugin.S100.audio.rtp.mpa.zinf
index 202e4cceee0e..53b178861605 100644
--- a/audio/zinf/files/sdr2.plugin.S100.audio.rtp.mpa.freeamp
+++ b/audio/zinf/files/sdr2.plugin.S100.audio.rtp.mpa.zinf
@@ -1,5 +1,5 @@
media:audio
-tool:freeamp
+tool:zinf
proto:RTP/AVP
protoname:RTP