aboutsummaryrefslogtreecommitdiff
path: root/audio/zita-convolver
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2017-12-27 07:36:05 +0000
committerMark Linimon <linimon@FreeBSD.org>2017-12-27 07:36:05 +0000
commitf02e9b1855dc11dfa3de0a0a24519c758caea34a (patch)
tree5e3dc4da12378e6f79cbb4cdbdaa0c572de9f795 /audio/zita-convolver
parentd9880127362955fca78c4127c39fa0fb7c92f66c (diff)
downloadports-f02e9b1855dc11dfa3de0a0a24519c758caea34a.tar.gz
ports-f02e9b1855dc11dfa3de0a0a24519c758caea34a.zip
Disable the extra flag "-march=native" on arm to fix builds.
Approved by: portmgr (tier-2 blanket) Obtained from: lonesome.com -exp run
Notes
Notes: svn path=/head/; revision=457351
Diffstat (limited to 'audio/zita-convolver')
-rw-r--r--audio/zita-convolver/Makefile6
-rw-r--r--audio/zita-convolver/files/patch-Makefile9
2 files changed, 12 insertions, 3 deletions
diff --git a/audio/zita-convolver/Makefile b/audio/zita-convolver/Makefile
index 16beee125d40..fd1f79361bd6 100644
--- a/audio/zita-convolver/Makefile
+++ b/audio/zita-convolver/Makefile
@@ -16,9 +16,9 @@ LICENSE_FILE= ${WRKSRC}/../COPYING
BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:math/fftw3
LIB_DEPENDS= libfftw3f.so:math/fftw3-float
-BROKEN_aarch64= fails to compile: c++: the clang compiler does not support '-march=native'
-BROKEN_armv6= fails to compile: c++: the clang compiler does not support '-march=native'
-BROKEN_armv7= fails to compile: c++: the clang compiler does not support '-march=native'
+#BROKEN_aarch64= fails to compile: c++: the clang compiler does not support '-march=native'
+#BROKEN_armv6= fails to compile: c++: the clang compiler does not support '-march=native'
+#BROKEN_armv7= fails to compile: c++: the clang compiler does not support '-march=native'
USES= compiler:c++11-lib gmake localbase:ldflags tar:bz2
USE_LDCONFIG= yes
diff --git a/audio/zita-convolver/files/patch-Makefile b/audio/zita-convolver/files/patch-Makefile
index cfab1e421c38..64c50cefb43a 100644
--- a/audio/zita-convolver/files/patch-Makefile
+++ b/audio/zita-convolver/files/patch-Makefile
@@ -11,6 +11,15 @@
MAJVERS = 3
+@@ -33,7 +33,7 @@ VERSION = $(MAJVERS).$(MINVERS)
+ CPPFLAGS += -I. -D_REENTRANT -D_POSIX_PTHREAD_SEMANTICS -DENABLE_VECTOR_MODE
+ CXXFLAGS += -fPIC -Wall
+ CXXFLAGS += -ffast-math -funroll-loops -O3
+-CXXFLAGS += -march=native
++#CXXFLAGS += -march=native
+ LDLFAGS +=
+ LDLIBS +=
+
@@ -45,9 +45,10 @@ ZITA-CONVOLVER_DEP = -lfftw3f -lpthread
ZITA-CONVOLVER_O = zita-convolver.o
ZITA-CONVOLVER_H = zita-convolver.h