aboutsummaryrefslogtreecommitdiff
path: root/audio/zrythm
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-09-15 18:26:42 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-09-15 18:26:42 +0000
commit41eb79d3c93895c786d815ba2f9d52c1aa9fbbef (patch)
tree5cec6ee95167c58d3c2cae187512bd0caa6b2b17 /audio/zrythm
parent5110e246e84b0581a3fc56f2e499ae86082a3dab (diff)
downloadports-41eb79d3c93895c786d815ba2f9d52c1aa9fbbef.tar.gz
ports-41eb79d3c93895c786d815ba2f9d52c1aa9fbbef.zip
audio/zrythm: Fix license; Fix link to fftw3*_threads libraries: they weren't linked to due to a bug in meson.build
Reported by: upstream
Notes
Notes: svn path=/head/; revision=548738
Diffstat (limited to 'audio/zrythm')
-rw-r--r--audio/zrythm/Makefile6
-rw-r--r--audio/zrythm/files/patch-meson.build2
-rw-r--r--audio/zrythm/files/patch-src_main.c13
3 files changed, 7 insertions, 14 deletions
diff --git a/audio/zrythm/Makefile b/audio/zrythm/Makefile
index b44905767670..39984bd768e5 100644
--- a/audio/zrythm/Makefile
+++ b/audio/zrythm/Makefile
@@ -3,15 +3,17 @@
PORTNAME= zrythm
DISTVERSIONPREFIX= v
DISTVERSION= 0.8.911
+PORTREVISION= 1
CATEGORIES= audio
MAINTAINER= yuri@FreeBSD.org
COMMENT= Modern music production system, also known as DAW
-LICENSE= GPLv3
+LICENSE= AGPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= fftw3>0:math/fftw3 \
+ fftw3-float>0:math/fftw3-float \
help2man:misc/help2man \
kf5-breeze-icons>0:x11-themes/kf5-breeze-icons
LIB_DEPENDS= libaudec.so:audio/libaudec \
@@ -48,6 +50,8 @@ USE_XORG= x11
GLIB_SCHEMAS= org.zrythm.Zrythm.gschema.xml
INSTALLS_ICONS= yes
+LDFLAGS+= ${LOCALBASE}/lib/libfftw3_threads.so ${LOCALBASE}/lib/libfftw3f_threads.so # these libs are required but aren't returned by pkg-config for fftw3
+
BINARY_ALIAS= git=false python3=${PYTHON_CMD}
post-patch: # https://git.zrythm.org/zrythm/zrythm/issues/299
diff --git a/audio/zrythm/files/patch-meson.build b/audio/zrythm/files/patch-meson.build
index 73e789e16c85..bfd236ed2a29 100644
--- a/audio/zrythm/files/patch-meson.build
+++ b/audio/zrythm/files/patch-meson.build
@@ -1,3 +1,5 @@
+Workaround for the bug in meson.build: fftw3_threads and fftw3f_threads libraries aren't returned by pkg-config
+
--- meson.build.orig 2020-06-06 18:03:44 UTC
+++ meson.build
@@ -638,8 +638,8 @@ zrythm_deps = [
diff --git a/audio/zrythm/files/patch-src_main.c b/audio/zrythm/files/patch-src_main.c
deleted file mode 100644
index 855058c1a92c..000000000000
--- a/audio/zrythm/files/patch-src_main.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/main.c.orig 2020-05-26 06:54:40 UTC
-+++ src/main.c
-@@ -505,8 +505,8 @@ main (int argc,
-
- /* init fftw */
- g_message ("Making fftw planner thread safe...");
-- fftw_make_planner_thread_safe ();
-- fftwf_make_planner_thread_safe ();
-+ //fftw_make_planner_thread_safe ();
-+ //fftwf_make_planner_thread_safe ();
-
- /* init audio decoder */
- g_message ("Initing audio decoder...");