aboutsummaryrefslogtreecommitdiff
path: root/audio/zrythm
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-02-16 19:36:29 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-02-16 19:36:29 +0000
commit428abb97c331858888b822231b8ca4609fcd4c88 (patch)
tree0dc9455bc8ecb6de8b6320c3486ad276ca4ac8d8 /audio/zrythm
parent597a3ec1e3294aac8eb5432161badf9bc7b71ddc (diff)
downloadports-428abb97c331858888b822231b8ca4609fcd4c88.tar.gz
ports-428abb97c331858888b822231b8ca4609fcd4c88.zip
New port: audio/zrythm: Modern music production system, also known as DAW
Notes
Notes: svn path=/head/; revision=493061
Diffstat (limited to 'audio/zrythm')
-rw-r--r--audio/zrythm/Makefile52
-rw-r--r--audio/zrythm/distinfo3
-rw-r--r--audio/zrythm/pkg-descr6
3 files changed, 61 insertions, 0 deletions
diff --git a/audio/zrythm/Makefile b/audio/zrythm/Makefile
new file mode 100644
index 000000000000..b45c77da89cc
--- /dev/null
+++ b/audio/zrythm/Makefile
@@ -0,0 +1,52 @@
+# $FreeBSD$
+
+PORTNAME= zrythm
+DISTVERSION= g20190216
+CATEGORIES= audio
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Modern music production system, also known as DAW
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= kf5-breeze-icons>0:x11-themes/kf5-breeze-icons
+LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg \
+ libcyaml.so:textproc/libcyaml \
+ libdazzle-1.0.so:x11-toolkits/libdazzle \
+ libjack.so:audio/jack \
+ liblilv-0.so:audio/lilv \
+ libportaudio.so:audio/portaudio \
+ libsamplerate.so:audio/libsamplerate \
+ libserd-0.so:devel/serd \
+ libsmf.so:audio/libsmf \
+ libsndfile.so:audio/libsndfile \
+ libsord-0.so:devel/sord \
+ libasound.so:audio/alsa-lib \
+ libsratom-0.so:audio/sratom \
+ libsuil-0.so:audio/suil \
+ libyaml.so:textproc/libyaml
+RUN_DEPENDS= gsettings-desktop-schemas>=0:devel/gsettings-desktop-schemas \
+ kf5-breeze-icons>0:x11-themes/kf5-breeze-icons
+
+USES= autoreconf gettext-runtime gmake python:3.5+,build gettext-runtime gnome pkgconfig
+USE_GITLAB= yes
+GL_SITE= https://git.zrythm.org
+GL_COMMIT= fd92153c1c2552b54ac9ea2b5981bbb880da04f8
+GNU_CONFIGURE= yes
+USE_GNOME= atk cairo gdkpixbuf2 glib20 gtk30 libxml2 pango
+GLIB_SCHEMAS= org.zrythm.gschema.xml
+ALL_TARGET= ${PORTNAME}
+INSTALLS_ICONS= yes
+
+BINARY_ALIAS= python3=${PYTHON_CMD}
+
+PLIST_FILES= bin/zrythm \
+ share/applications/zrythm.desktop \
+ share/fonts/zrythm/Segment7Standard/OFL.txt \
+ share/icons/hicolor/scalable/apps/z.svg
+
+post-install: # https://git.zrythm.org/zrythm/zrythm/issues/61
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/zrythm
+
+.include <bsd.port.mk>
diff --git a/audio/zrythm/distinfo b/audio/zrythm/distinfo
new file mode 100644
index 000000000000..2e414b483f62
--- /dev/null
+++ b/audio/zrythm/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1550345216
+SHA256 (zrythm-zrythm-fd92153c1c2552b54ac9ea2b5981bbb880da04f8_GL0.tar.gz) = 0769d2d6a007fc91878983173cada9cb305dbf0072ca9ca89b26c6f373e4dcf8
+SIZE (zrythm-zrythm-fd92153c1c2552b54ac9ea2b5981bbb880da04f8_GL0.tar.gz) = 602150
diff --git a/audio/zrythm/pkg-descr b/audio/zrythm/pkg-descr
new file mode 100644
index 000000000000..3f8459eb741e
--- /dev/null
+++ b/audio/zrythm/pkg-descr
@@ -0,0 +1,6 @@
+Zrythm is built using C and the GTK+3 toolkit and borrows ideas, concepts and
+code from other projects such as Ardour and Jalv. It is built with the intention
+to provide GNU/Linux and BSD users a full-featured alternative to proprietary
+DAWs and offers a unique approach to workflow that other GNU/Linux DAWs lack.
+
+WWW: https://www.zrythm.org/