aboutsummaryrefslogtreecommitdiff
path: root/audio/zynaddsubfx
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2017-12-06 17:30:06 +0000
committerKurt Jaeger <pi@FreeBSD.org>2017-12-06 17:30:06 +0000
commit69df8d1cf93dcbbdebf51433c7a16a0deab593a4 (patch)
tree6e9ee5e9e85d9e5e9b44969cdaa63339d14c5b3a /audio/zynaddsubfx
parent5acb2487667700ca037b92df46df531910328ad5 (diff)
downloadports-69df8d1cf93dcbbdebf51433c7a16a0deab593a4.tar.gz
ports-69df8d1cf93dcbbdebf51433c7a16a0deab593a4.zip
audio/zynaddsubfx: fix build on cur, 10.x by force llvm40
PR: 220958 Submitted by: hselasky (maintainer)
Notes
Notes: svn path=/head/; revision=455665
Diffstat (limited to 'audio/zynaddsubfx')
-rw-r--r--audio/zynaddsubfx/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/audio/zynaddsubfx/Makefile b/audio/zynaddsubfx/Makefile
index b1bc04653761..48998111a95f 100644
--- a/audio/zynaddsubfx/Makefile
+++ b/audio/zynaddsubfx/Makefile
@@ -41,8 +41,8 @@ GUI_LIB_DEPENDS= libfltk.so:x11-toolkits/fltk \
libfontconfig.so:x11-fonts/fontconfig
GUI_ON= -DGuiModule:STRING=fltk
GUI_CMAKE_OFF= -DGuiModule:STRING=OFF
-GUI_USE+= XORG=x11,xext,xfixes,xcursor,ice,sm,xpm,xinerama,xft
-GUI_USE+= GL=glu
+GUI_USE+= XORG=x11,xext,xfixes,xcursor,xrender,ice,sm,xpm,xinerama,xft
+GUI_USE+= GL=gl,glu
GUI_USES= jpeg
OSS_CMAKE_ON= -DOssEnable:BOOL=ON
@@ -77,6 +77,13 @@ PORTEXAMPLES= *
CMAKE_ARGS+= -DZYN_DATADIR:STRING=${DATADIR}
CMAKE_ARGS+= -DZYN_EXAMPLESDIR:STRING=${EXAMPLESDIR}
+.include <bsd.port.options.mk>
+
+# Build fix for ZynAddSubFx
+BUILD_DEPENDS+= clang40:devel/llvm40
+CC= clang40
+CXX= clang++40
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "i386" || ${ARCH} == "amd64"