aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorRodrigo Osorio <rodrigo@FreeBSD.org>2019-08-20 12:33:44 +0000
committerRodrigo Osorio <rodrigo@FreeBSD.org>2019-08-20 12:33:44 +0000
commit07c94d76ce893140d55c9bbe9eff061ee34837af (patch)
treec0fc4e1f3e709887c413f84bbd849570563831f0 /audio
parent1b112fb344a8ff95add19e8a6e890bcd58c91d49 (diff)
downloadports-07c94d76ce893140d55c9bbe9eff061ee34837af.tar.gz
ports-07c94d76ce893140d55c9bbe9eff061ee34837af.zip
New port audio/fossmixer: Graphical mixer application for OSS
FOSS Mixer is a graphical mixer application for FreeBSD to control OSS audio backend. Mixer can be use to control audio levels, set recording source, and it includes white noise generator for testing the audio output. It is pretty much what mixer(1) does. FOSS Mixer does not need third party user interface library, it runs on plain X11/OpenGL. PR: 239929 Submitted by: manwe@suomi24.fi
Notes
Notes: svn path=/head/; revision=509424
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/fossmixer/Makefile73
-rw-r--r--audio/fossmixer/distinfo3
-rw-r--r--audio/fossmixer/pkg-descr7
-rw-r--r--audio/fossmixer/pkg-plist26
5 files changed, 110 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index cabe42a8778d..f5bcc2428897 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -192,6 +192,7 @@
SUBDIR += fomp-lv2
SUBDIR += foo-yc20
SUBDIR += forked-daapd
+ SUBDIR += fossmixer
SUBDIR += fpc-a52
SUBDIR += fpc-mad
SUBDIR += fpc-modplug
diff --git a/audio/fossmixer/Makefile b/audio/fossmixer/Makefile
new file mode 100644
index 000000000000..88e49061d2c9
--- /dev/null
+++ b/audio/fossmixer/Makefile
@@ -0,0 +1,73 @@
+# $FreeBSD$
+
+PORTNAME= fossmixer
+PORTVERSION= 0.0.2
+CATEGORIES= audio
+MASTER_SITES= https://downloads.sourceforge.net/project/detroit/
+DISTNAME= detroit-0.2.1
+EXTRACT_SUFX= .tar.xz
+
+MAINTAINER= jani@lasipalatsi.fi
+COMMENT= Graphical mixer application for OSS
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= ${LOCALBASE}/share/fonts/noto/NotoSans-Italic.ttf:x11-fonts/noto-basic \
+ ${LOCALBASE}/share/fonts/noto/NotoSans-Regular.ttf:x11-fonts/noto-basic
+LIB_DEPENDS= libao.so:audio/libao \
+ libportaudio.so:audio/portaudio \
+ libpulse-simple.so:audio/pulseaudio \
+ libiconv.so:converters/libiconv \
+ libltdl.so:devel/libltdl \
+ libfreetype.so:print/freetype2
+
+USES= gettext-runtime gl perl5
+USE_GL= gl
+USE_PERL5= patch build
+USE_XORG= x11 xext xrandr
+
+WRKSRC= ${WRKDIR}/${DISTNAME}
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-bob \
+ --disable-color \
+ --disable-coords \
+ --disable-draw \
+ --disable-image \
+ --disable-math \
+ --disable-menu \
+ --disable-remote \
+ --sysconfdir="${ETCDIR}" \
+ --with-libiconv="${LOCALBASE}" \
+ --with-libintl="${LOCALBASE}" \
+ --with-libltdl="${LOCALBASE}"
+
+ALL_TARGET=
+INSTALL_TARGET= install-strip
+
+post-patch:
+ @(cd ${WRKSRC}/apps && ./build.sh fossmixer)
+
+ @for i in alsa flac samplerate gnutls openssl librsvg-2.0; do \
+ ${REINPLACE_CMD} -e "s|$${i}|$${i}_EXCLUDE|g" ${WRKSRC}/configure ; \
+ done
+
+ @${REINPLACE_CMD} -e "s|^.*bobs.*$$||" ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e "s|@echo Compiling engine/$$< ; ||" ${WRKSRC}/engine/Makefile.in
+
+post-install:
+ @for i in conf res; do \
+ if [ -e "${STAGEDIR}${PREFIX}/etc/fossmixer/fossmixer.$${i}" ]; then \
+ ${MV} -f \
+ ${STAGEDIR}${PREFIX}/etc/fossmixer/fossmixer.$${i} \
+ ${STAGEDIR}${PREFIX}/etc/fossmixer/fossmixer.$${i}.sample ; \
+ fi ; \
+ done
+
+ @for i in NotoSans-Italic NotoSans-Regular; do \
+ ${LN} -sf \
+ "${LOCALBASE}/share/fonts/noto/$${i}.ttf" \
+ "${STAGEDIR}${PREFIX}/share/detroit/fonts/$${i}.ttf" ; \
+ done
+
+.include <bsd.port.mk>
diff --git a/audio/fossmixer/distinfo b/audio/fossmixer/distinfo
new file mode 100644
index 000000000000..9cf13a2aa05f
--- /dev/null
+++ b/audio/fossmixer/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1566072730
+SHA256 (detroit-0.2.1.tar.xz) = 8916027b43806e1bce84e9823b5343f1091dd52f7fd80eb8ff299afc2ab72d8c
+SIZE (detroit-0.2.1.tar.xz) = 22269292
diff --git a/audio/fossmixer/pkg-descr b/audio/fossmixer/pkg-descr
new file mode 100644
index 000000000000..00737034fbf3
--- /dev/null
+++ b/audio/fossmixer/pkg-descr
@@ -0,0 +1,7 @@
+FOSS Mixer is a graphical mixer application for FreeBSD to control OSS
+audio backend. Mixer can be use to control audio levels, set recording
+source, and it includes white noise generator for testing the audio
+output. It is pretty much what mixer(1) does. FOSS Mixer does not need
+third party user interface library, it runs on plain X11/OpenGL.
+
+WWW: http://detroit.sourceforge.net/app_fossmixer.html
diff --git a/audio/fossmixer/pkg-plist b/audio/fossmixer/pkg-plist
new file mode 100644
index 000000000000..a0a56e6aacfb
--- /dev/null
+++ b/audio/fossmixer/pkg-plist
@@ -0,0 +1,26 @@
+@sample %%ETCDIR%%/fossmixer.conf.sample
+@sample %%ETCDIR%%/fossmixer.res.sample
+bin/fossmixer
+share/detroit/fonts/KEEPME
+share/detroit/fonts/NotoSans-Italic.ttf
+share/detroit/fonts/NotoSans-Regular.ttf
+share/detroit/widgets/button_1_1.widget
+share/detroit/widgets/button_2_1.widget
+share/detroit/widgets/button_3_1.widget
+share/detroit/widgets/knob_1_1.widget
+share/detroit/widgets/knob_1_2.widget
+share/detroit/widgets/knob_2_1.widget
+share/detroit/widgets/knob_2_2.widget
+share/detroit/widgets/knob_3_1.widget
+share/detroit/widgets/knob_3_2.widget
+share/detroit/widgets/lamp_1_1.widget
+share/detroit/widgets/led_1_1.widget
+share/detroit/widgets/led_2_1.widget
+share/detroit/widgets/led_3_1.widget
+share/detroit/widgets/slide_1_1.widget
+share/detroit/widgets/slide_1_2.widget
+share/detroit/widgets/slide_2_1.widget
+share/detroit/widgets/slide_2_2.widget
+share/detroit/widgets/slide_3_1.widget
+share/detroit/widgets/slide_3_2.widget
+share/fossmixer/fossmixer_bg.tga