aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2015-10-13 20:07:54 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2015-10-13 20:07:54 +0000
commit0b0cf9fc3e785b8d18c3a57e709c98f486fa8628 (patch)
tree89742fcfff2a2c5ff26a47225d2edeacd44b243e /audio
parent46a3cede8aea563d40a7a6e6273dad15f319c30a (diff)
downloadports-0b0cf9fc3e785b8d18c3a57e709c98f486fa8628.tar.gz
ports-0b0cf9fc3e785b8d18c3a57e709c98f486fa8628.zip
Use the new test framework in my ports, if applicable.
While here, also strip more libraries.
Notes
Notes: svn path=/head/; revision=399214
Diffstat (limited to 'audio')
-rw-r--r--audio/flac/Makefile6
-rw-r--r--audio/libao/Makefile4
-rw-r--r--audio/libogg/Makefile4
-rw-r--r--audio/libvorbis/Makefile4
-rw-r--r--audio/opus/Makefile7
5 files changed, 11 insertions, 14 deletions
diff --git a/audio/flac/Makefile b/audio/flac/Makefile
index b30e0ea9b53f..17d58edfaa39 100644
--- a/audio/flac/Makefile
+++ b/audio/flac/Makefile
@@ -3,6 +3,7 @@
PORTNAME= flac
PORTVERSION= 1.3.1
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://downloads.xiph.org/releases/flac/
@@ -21,6 +22,8 @@ CONFIGURE_ARGS= --enable-static \
--disable-silent-rules \
--disable-thorough-tests \
--disable-xmms-plugin
+INSTALL_TARGET= install-strip
+TEST_TARGET= check
.include <bsd.port.options.mk>
@@ -34,7 +37,4 @@ post-install:
${STAGEDIR}${PREFIX}/man/man1/flac.1
${RM} ${STAGEDIR}${PREFIX}/man/man1/flac.1.bak
-regression-test: build
- @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE_CMD} check
-
.include <bsd.port.mk>
diff --git a/audio/libao/Makefile b/audio/libao/Makefile
index 0e7c92e35c9f..40e9cccd05a1 100644
--- a/audio/libao/Makefile
+++ b/audio/libao/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libao
PORTVERSION= 1.2.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= http://downloads.xiph.org/releases/ao/
@@ -15,6 +15,8 @@ USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-static \
--disable-arts
+INSTALL_TARGET= install-strip
+
# do not install
MAKE_ARGS= ckport_DATA=""
diff --git a/audio/libogg/Makefile b/audio/libogg/Makefile
index ad94d38963f8..827072b73aad 100644
--- a/audio/libogg/Makefile
+++ b/audio/libogg/Makefile
@@ -15,13 +15,11 @@ USES= libtool pathfix tar:xz
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
+TEST_TARGET= check
OPTIONS_DEFINE= DOCS
post-stage:
${LN} -s libogg.so.0 ${STAGEDIR}${PREFIX}/lib/libogg.so.8
-regression-test: build
- @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} check
-
.include <bsd.port.mk>
diff --git a/audio/libvorbis/Makefile b/audio/libvorbis/Makefile
index 712765c08d3e..537e4726b3c8 100644
--- a/audio/libvorbis/Makefile
+++ b/audio/libvorbis/Makefile
@@ -18,6 +18,7 @@ USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-ogg=${LOCALBASE}
INSTALL_TARGET= install-strip
+TEST_TARGET= check
OPTIONS_DEFINE= DOCS
@@ -26,7 +27,4 @@ post-stage:
${LN} -s libvorbis.so.0 ${STAGEDIR}${PREFIX}/lib/libvorbis.so.4
${LN} -s libvorbisfile.so.3 ${STAGEDIR}${PREFIX}/lib/libvorbisfile.so.6
-regression-test: build
- @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} check
-
.include <bsd.port.mk>
diff --git a/audio/opus/Makefile b/audio/opus/Makefile
index 142bfd4d8f6c..0b00c0c4a152 100644
--- a/audio/opus/Makefile
+++ b/audio/opus/Makefile
@@ -2,7 +2,7 @@
PORTNAME= opus
PORTVERSION= 1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= http://downloads.xiph.org/releases/opus/ \
MOZILLA/opus
@@ -21,9 +21,8 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-custom-modes \
--disable-maintainer-mode \
--disable-doc # requires doxygen
-
-regression-test: build
- @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} check
+INSTALL_TARGET= install-strip
+TEST_TARGET= check
.include <bsd.port.options.mk>