aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-10-21 05:35:38 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-10-21 05:35:38 +0000
commit0fb16032bcfafb3df0e8d8fa5bd551a079dd0a1e (patch)
tree10af8fa0636fa04bb4925f65b992993c3d6dbd2f /audio
parent314d9c4573d1b98f69150ed0042136b5107029b9 (diff)
downloadports-0fb16032bcfafb3df0e8d8fa5bd551a079dd0a1e.tar.gz
ports-0fb16032bcfafb3df0e8d8fa5bd551a079dd0a1e.zip
New port: audio/rnnoise-nu: Recurrent neural network for audio noise reduction
Notes
Notes: svn path=/head/; revision=482641
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/rnnoise-nu/Makefile36
-rw-r--r--audio/rnnoise-nu/distinfo3
-rw-r--r--audio/rnnoise-nu/pkg-descr3
4 files changed, 43 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index e060b165d9bf..05a12549f074 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -731,6 +731,7 @@
SUBDIR += ripit
SUBDIR += ripperx
SUBDIR += rkr-lv2
+ SUBDIR += rnnoise-nu
SUBDIR += rosegarden
SUBDIR += rplay
SUBDIR += rsynth
diff --git a/audio/rnnoise-nu/Makefile b/audio/rnnoise-nu/Makefile
new file mode 100644
index 000000000000..26d182b9179b
--- /dev/null
+++ b/audio/rnnoise-nu/Makefile
@@ -0,0 +1,36 @@
+# $FreeBSD$
+
+PORTNAME= rnnoise-nu
+DISTVERSION= g20180916
+CATEGORIES= audio
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Recurrent neural network for audio noise reduction
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= autoreconf gmake libtool
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-static --disable-examples
+USE_GITHUB= yes
+GH_ACCOUNT= GregorR
+GH_TAGNAME= 2626930
+USE_LDCONFIG= yes
+
+OPTIONS_DEFINE= DOCS
+
+DOCS_CONFIGURE_ENABLE= doc
+
+PORTDOCS= * # API documentation feature is broken: https://github.com/xiph/rnnoise/issues/44
+
+PLIST_FILES= include/rnnoise-nu.h \
+ lib/librnnoise-nu.so \
+ lib/librnnoise-nu.so.1 \
+ lib/librnnoise-nu.so.1.0.0 \
+ libdata/pkgconfig/rnnoise-nu.pc
+
+post-install-DOCS-on:
+ @${RM} ${STAGEDIR}${DOCSDIR}/COPYING
+
+.include <bsd.port.mk>
diff --git a/audio/rnnoise-nu/distinfo b/audio/rnnoise-nu/distinfo
new file mode 100644
index 000000000000..e0ec7c688f95
--- /dev/null
+++ b/audio/rnnoise-nu/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1540098308
+SHA256 (GregorR-rnnoise-nu-g20180916-2626930_GH0.tar.gz) = e63558d1a6269cc02ec078909f29f0a698e85d973ba86c16c5bbc50b5fb69f96
+SIZE (GregorR-rnnoise-nu-g20180916-2626930_GH0.tar.gz) = 830784
diff --git a/audio/rnnoise-nu/pkg-descr b/audio/rnnoise-nu/pkg-descr
new file mode 100644
index 000000000000..1f17a133e7c5
--- /dev/null
+++ b/audio/rnnoise-nu/pkg-descr
@@ -0,0 +1,3 @@
+RNNoise is a noise suppression library based on a recurrent neural network.
+
+WWW: https://github.com/xiph/rnnoise