aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-07-04 20:26:16 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-07-04 20:26:42 +0000
commit1cee258236caf1de59bc7c911f7d2c9dc8610dba (patch)
tree54dcda3d49646dec34369d15beb193e3aea6f036 /audio
parentbc02049bf8bbba23d78ca07d75c02d7940b98995 (diff)
downloadports-1cee258236caf1de59bc7c911f7d2c9dc8610dba.tar.gz
ports-1cee258236caf1de59bc7c911f7d2c9dc8610dba.zip
audio/qsampler: Change to cmake.
Diffstat (limited to 'audio')
-rw-r--r--audio/qsampler/Makefile8
1 files changed, 1 insertions, 7 deletions
diff --git a/audio/qsampler/Makefile b/audio/qsampler/Makefile
index 17255116c30d..037a7eb9cd3c 100644
--- a/audio/qsampler/Makefile
+++ b/audio/qsampler/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= libgig.so:audio/libgig \
liblscp.so:audio/liblscp
RUN_DEPENDS= linuxsampler:audio/linuxsampler
-USES= autoreconf desktop-file-utils gl gmake localbase:ldflags pkgconfig \
+USES= cmake compiler:c++17-lang desktop-file-utils gl localbase:ldflags pkgconfig \
shared-mime-info qmake:no_env qt:5 xorg
USE_GL= gl
USE_QT= core gui network widgets x11extras \
@@ -24,12 +24,6 @@ USE_QT= core gui network widgets x11extras \
USE_GITHUB= yes
GH_ACCOUNT= rncbc
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-qt5
-
-CXXFLAGS+= -I${LOCALBASE}/include/qt5 -fPIC # https://github.com/rncbc/qsampler/issues/18
-LDFLAGS+= -llscp
-
post-configure:
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} -o ${PORTNAME}.mak \
${QMAKE_ARGS}