aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorJesper Schmitz Mouridsen <jsm@FreeBSD.org>2018-10-25 15:47:05 +0000
committerJesper Schmitz Mouridsen <jsm@FreeBSD.org>2018-10-25 15:47:05 +0000
commit21f80b607b120f418a54824f2003ad81354f6d76 (patch)
treee4f135e36ac6c9323903420503a32dd0878f7bc8 /audio
parent7ac8312f56a1ff3422737e70b8dbdca61946447d (diff)
downloadports-21f80b607b120f418a54824f2003ad81354f6d76.tar.gz
ports-21f80b607b120f418a54824f2003ad81354f6d76.zip
New port audio/pavucontrol-qt
pavucontrol-qt is the Qt port of volume control pavucontrol of sound server PulseAudio. WWW: https://github.com/lxqt/pavucontrol-qt/ PR: 229310 Approved by: swills (mentor) Differential Revision: https://reviews.freebsd.org/D17700
Notes
Notes: svn path=/head/; revision=482973
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/pavucontrol-qt/Makefile26
-rw-r--r--audio/pavucontrol-qt/distinfo3
-rw-r--r--audio/pavucontrol-qt/pkg-descr4
4 files changed, 34 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 167e2d7fdcf5..697518fe0437 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -640,6 +640,7 @@
SUBDIR += paprefs
SUBDIR += patchage
SUBDIR += pavucontrol
+ SUBDIR += pavucontrol-qt
SUBDIR += pavumeter
SUBDIR += pc-mixer
SUBDIR += pd
diff --git a/audio/pavucontrol-qt/Makefile b/audio/pavucontrol-qt/Makefile
new file mode 100644
index 000000000000..368649c511d2
--- /dev/null
+++ b/audio/pavucontrol-qt/Makefile
@@ -0,0 +1,26 @@
+# Created by: Olivier Duchateau
+# $FreeBSD$
+
+PORTNAME= pavucontrol-qt
+PORTVERSION= 0.4.0
+CATEGORIES= audio
+MASTER_SITES= LXQT/${PORTNAME}
+
+MAINTAINER= jsm@FreeBSD.org
+COMMENT= PulseAudio mixer in Qt
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libpulse.so:audio/pulseaudio
+
+USES= cmake:outsource compiler:c++11-lang gettext-runtime localbase:ldflags qt:5 \
+ lxqt pkgconfig tar:xz gnome
+USE_QT= buildtools_build qmake_build core dbus gui linguisttools \
+ widgets
+USE_LXQT= buildtools
+USE_GNOME= glib20
+
+PLIST_FILES= bin/pavucontrol-qt \
+ share/applications/pavucontrol-qt.desktop
+
+.include <bsd.port.mk>
diff --git a/audio/pavucontrol-qt/distinfo b/audio/pavucontrol-qt/distinfo
new file mode 100644
index 000000000000..22c33c23958e
--- /dev/null
+++ b/audio/pavucontrol-qt/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1529709887
+SHA256 (lxqt/pavucontrol-qt-0.4.0.tar.xz) = e6b2edc4079c067fa8710eee8bd7f11f148128a9f08d5d38e600b4c31f841b5f
+SIZE (lxqt/pavucontrol-qt-0.4.0.tar.xz) = 34916
diff --git a/audio/pavucontrol-qt/pkg-descr b/audio/pavucontrol-qt/pkg-descr
new file mode 100644
index 000000000000..32ab9030b585
--- /dev/null
+++ b/audio/pavucontrol-qt/pkg-descr
@@ -0,0 +1,4 @@
+pavucontrol-qt is the Qt port of volume control pavucontrol of sound
+server PulseAudio.
+
+WWW: https://github.com/lxqt/pavucontrol-qt/