aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-04-07 19:37:02 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-04-07 19:37:36 +0000
commit261a5b4b628add54ee4866d428763a2bfd199c76 (patch)
tree9d35f5562eb144f72f0cb4a9a0301e58c1473beb /audio
parent4ad7ae27f6442600bc01916650d4a74920cc8504 (diff)
downloadports-261a5b4b628add54ee4866d428763a2bfd199c76.tar.gz
ports-261a5b4b628add54ee4866d428763a2bfd199c76.zip
New port: audio/poly-lv2: Collection of LV2 plugins designed for modular/eurorack style use
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/poly-lv2/Makefile42
-rw-r--r--audio/poly-lv2/distinfo3
-rw-r--r--audio/poly-lv2/pkg-descr3
-rw-r--r--audio/poly-lv2/pkg-plist38
5 files changed, 87 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 69ad8e17d70d..46113dcb2b1b 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -608,6 +608,7 @@
SUBDIR += pms
SUBDIR += pms-devel
SUBDIR += pocketsphinx
+ SUBDIR += poly-lv2
SUBDIR += polyphone
SUBDIR += portaudio
SUBDIR += praat
diff --git a/audio/poly-lv2/Makefile b/audio/poly-lv2/Makefile
new file mode 100644
index 000000000000..59e8dac90ec3
--- /dev/null
+++ b/audio/poly-lv2/Makefile
@@ -0,0 +1,42 @@
+PORTNAME= poly
+DISTVERSION= g20201118
+CATEGORIES= audio
+PKGNAMESUFFIX= -lv2
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Collection of LV2 plugins designed for modular/eurorack style use
+
+#LICENSE= not defined in the repository: https://github.com/polyeffects/PolyLV2/issues/2
+
+BUILD_DEPENDS= lv2>0:audio/lv2 \
+ ${LOCALBASE}/include/boost/circular_buffer.hpp:devel/boost-libs
+
+USES= gmake pkgconfig
+
+USE_GITHUB= yes
+GH_ACCOUNT= polyeffects
+GH_PROJECT= PolyLV2
+GH_TAGNAME= 3fd1dd4
+
+do-build:
+ @cd ${WRKSRC} && for d in $$(ls); do \
+ if [ -d $${d} ]; then \
+ echo "==> Building for sub-directory $${d}" && ( \
+ cd $${d} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${ALL_TARGET} \
+ ) \
+ fi \
+ done
+
+do-install:
+ @cd ${WRKSRC} && for d in $$(ls); do \
+ if [ -d $${d} ]; then \
+ echo "==> Staging for sub-directory $${d}" && ( \
+ cd $${d} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${INSTALL_TARGET} \
+ ) \
+ fi \
+ done
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/lv2/basic_modular.lv2/maths.so
+
+.include <bsd.port.mk>
diff --git a/audio/poly-lv2/distinfo b/audio/poly-lv2/distinfo
new file mode 100644
index 000000000000..1b9d45fb4a78
--- /dev/null
+++ b/audio/poly-lv2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1617823013
+SHA256 (polyeffects-PolyLV2-g20201118-3fd1dd4_GH0.tar.gz) = 18d9f90f7664a8c5688de01e362bae0d27c95721614f5043f7125a69cb745769
+SIZE (polyeffects-PolyLV2-g20201118-3fd1dd4_GH0.tar.gz) = 231389
diff --git a/audio/poly-lv2/pkg-descr b/audio/poly-lv2/pkg-descr
new file mode 100644
index 000000000000..a2ce5bb6e715
--- /dev/null
+++ b/audio/poly-lv2/pkg-descr
@@ -0,0 +1,3 @@
+PolyLV2 is a collection of LV2 plugins designed for modular/eurorack style use.
+
+WWW: https://github.com/polyeffects/PolyLV2
diff --git a/audio/poly-lv2/pkg-plist b/audio/poly-lv2/pkg-plist
new file mode 100644
index 000000000000..da5e37bcf7e6
--- /dev/null
+++ b/audio/poly-lv2/pkg-plist
@@ -0,0 +1,38 @@
+lib/lv2/basic_modular.lv2/amp.ttl
+lib/lv2/basic_modular.lv2/basic_modular.so
+lib/lv2/basic_modular.lv2/difference.ttl
+lib/lv2/basic_modular.lv2/manifest.ttl
+lib/lv2/basic_modular.lv2/maths.so
+lib/lv2/basic_quantizer.lv2/basic_quantizer.so
+lib/lv2/basic_quantizer.lv2/basic_quantizer.ttl
+lib/lv2/basic_quantizer.lv2/manifest.ttl
+lib/lv2/chorus.lv2/chorus.so
+lib/lv2/chorus.lv2/chorus.ttl
+lib/lv2/chorus.lv2/manifest.ttl
+lib/lv2/chorus_ext.lv2/chorus_ext.so
+lib/lv2/chorus_ext.lv2/chorus_ext.ttl
+lib/lv2/chorus_ext.lv2/manifest.ttl
+lib/lv2/flanger.lv2/flanger.so
+lib/lv2/flanger.lv2/flanger.ttl
+lib/lv2/flanger.lv2/manifest.ttl
+lib/lv2/flanger_ext.lv2/flanger_ext.so
+lib/lv2/flanger_ext.lv2/flanger_ext.ttl
+lib/lv2/flanger_ext.lv2/manifest.ttl
+lib/lv2/harm_trem.lv2/harm_trem.so
+lib/lv2/harm_trem.lv2/harm_trem.ttl
+lib/lv2/harm_trem.lv2/manifest.ttl
+lib/lv2/harm_trem_ext.lv2/harm_trem_ext.so
+lib/lv2/harm_trem_ext.lv2/harm_trem_ext.ttl
+lib/lv2/harm_trem_ext.lv2/manifest.ttl
+lib/lv2/step_sequencer.lv2/manifest.ttl
+lib/lv2/step_sequencer.lv2/step_sequencer.so
+lib/lv2/step_sequencer.lv2/step_sequencer.ttl
+lib/lv2/step_sequencer_bpm.lv2/manifest.ttl
+lib/lv2/step_sequencer_bpm.lv2/step_sequencer_bpm.so
+lib/lv2/step_sequencer_bpm.lv2/step_sequencer_bpm.ttl
+lib/lv2/vibrato.lv2/manifest.ttl
+lib/lv2/vibrato.lv2/vibrato.so
+lib/lv2/vibrato.lv2/vibrato.ttl
+lib/lv2/vibrato_ext.lv2/manifest.ttl
+lib/lv2/vibrato_ext.lv2/vibrato_ext.so
+lib/lv2/vibrato_ext.lv2/vibrato_ext.ttl