aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2018-03-02 19:10:48 +0000
committerRene Ladan <rene@FreeBSD.org>2018-03-02 19:10:48 +0000
commit2d1cca0907e43e9c18510b17f40eade4d564bca4 (patch)
tree6df9d024d7f94a3241c3a3279e74f29e9e65c80c /audio
parentcc674ab4583d720b5c9c33eb5bfed6a512eb897f (diff)
downloadports-2d1cca0907e43e9c18510b17f40eade4d564bca4.tar.gz
ports-2d1cca0907e43e9c18510b17f40eade4d564bca4.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/amp/Makefile32
-rw-r--r--audio/amp/distinfo3
-rw-r--r--audio/amp/files/patch-audio.c35
-rw-r--r--audio/amp/files/patch-audio.h114
-rw-r--r--audio/amp/files/patch-audioIO__Linux.c41
-rw-r--r--audio/amp/files/patch-dump.c28
-rw-r--r--audio/amp/files/patch-formats.c11
-rw-r--r--audio/amp/files/patch-getbits.c41
-rw-r--r--audio/amp/files/patch-guicontrol.c12
-rw-r--r--audio/amp/files/patch-layer2.c11
-rw-r--r--audio/amp/files/patch-layer3.c22
-rw-r--r--audio/amp/files/patch-position.c20
-rw-r--r--audio/amp/files/patch-rtbuf.c21
-rw-r--r--audio/amp/pkg-descr5
15 files changed, 0 insertions, 397 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 9757089d01ec..dbbe8f2d94a8 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -25,7 +25,6 @@
SUBDIR += alure
SUBDIR += amarok-kde4
SUBDIR += amb-plugins
- SUBDIR += amp
SUBDIR += ample
SUBDIR += amsynth
SUBDIR += aqualung
diff --git a/audio/amp/Makefile b/audio/amp/Makefile
deleted file mode 100644
index 6190e4c6a245..000000000000
--- a/audio/amp/Makefile
+++ /dev/null
@@ -1,32 +0,0 @@
-# Created by: Vanilla I. Shu <vanilla@MinJe.com.TW>
-# $FreeBSD$
-
-PORTNAME= amp
-PORTVERSION= 0.7.6
-PORTEPOCH= 1
-CATEGORIES= audio
-MASTER_SITES= http://www.gufi.org/ports/
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Another mp3 player
-
-DEPRECATED= No more upstream
-EXPIRATION_DATE= 2018-03-01
-
-USES= gmake
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= ac_cv_prog_gcc=no
-
-PLIST_FILES= bin/amp man/man1/amp.1.gz
-
-post-patch:
- @${REINPLACE_CMD} -e \
- '/CC="gcc"/s|^|#| ; \
- /CFLAGS=$$/s|^|#| ; \
- s|-O6|$$CFLAGS|' ${WRKSRC}/configure
-
-do-install:
- (cd ${WRKSRC} && ${INSTALL_PROGRAM} amp ${STAGEDIR}${PREFIX}/bin)
- (cd ${WRKSRC} && ${INSTALL_MAN} amp.1 ${STAGEDIR}${PREFIX}/man/man1)
-
-.include <bsd.port.mk>
diff --git a/audio/amp/distinfo b/audio/amp/distinfo
deleted file mode 100644
index 62b79f240fd3..000000000000
--- a/audio/amp/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1467406118
-SHA256 (amp-0.7.6.tar.gz) = c08e91d512065d7f6866fd83fa60571d76de7a1c4cc377cf9ce7dd9f943c69b8
-SIZE (amp-0.7.6.tar.gz) = 100337
diff --git a/audio/amp/files/patch-audio.c b/audio/amp/files/patch-audio.c
deleted file mode 100644
index 660fc47bcb3c..000000000000
--- a/audio/amp/files/patch-audio.c
+++ /dev/null
@@ -1,35 +0,0 @@
---- audio.c.orig 1997-08-23 11:30:21 UTC
-+++ audio.c
-@@ -56,7 +56,7 @@ void statusDisplay(struct AUDIO_HEADER *
- msg("{ %d } ",frameNo);
- }
- if (A_SHOW_TIME && !(frameNo%10)) {
-- seconds=frameNo*1152/t_sampling_frequency[header->ID][header->sampling_frequency];
-+ seconds=frameNo*(header->ID==0?576:1152)/t_sampling_frequency[header->IDex][header->ID][header->sampling_frequency];
- minutes=seconds/60;
- seconds=seconds % 60;
- msg("[%d:%02d]",minutes,seconds);
-@@ -245,10 +245,6 @@ void report_header_error(int err)
- switch (err) {
- case GETHDR_ERR: die("error reading mpeg bitstream. exiting.\n");
- break;
-- case GETHDR_NS : warn("this is a file in MPEG 2.5 format, which is not defined\n");
-- warn("by ISO/MPEG. It is \"a special Fraunhofer format\".\n");
-- warn("amp does not support this format. sorry.\n");
-- break;
- case GETHDR_FL1: warn("ISO/MPEG layer 1 is not supported by amp (yet).\n");
- break;
- case GETHDR_FF : warn("free format bitstreams are not supported. sorry.\n");
-@@ -268,10 +264,10 @@ int setup_audio(struct AUDIO_HEADER *hea
- {
- if (A_AUDIO_PLAY)
- if (AUDIO_BUFFER_SIZE==0)
-- audioOpen(t_sampling_frequency[header->ID][header->sampling_frequency],
-+ audioOpen(t_sampling_frequency[header->IDex][header->ID][header->sampling_frequency],
- (header->mode!=3 && !A_DOWNMIX),A_SET_VOLUME);
- else
-- audioBufferOpen(t_sampling_frequency[header->ID][header->sampling_frequency],
-+ audioBufferOpen(t_sampling_frequency[header->IDex][header->ID][header->sampling_frequency],
- (header->mode!=3 && !A_DOWNMIX),A_SET_VOLUME);
- return 0;
- }
diff --git a/audio/amp/files/patch-audio.h b/audio/amp/files/patch-audio.h
deleted file mode 100644
index e21d86cdf946..000000000000
--- a/audio/amp/files/patch-audio.h
+++ /dev/null
@@ -1,114 +0,0 @@
---- audio.h.orig 1997-08-21 13:00:18 UTC
-+++ audio.h
-@@ -9,6 +9,7 @@
- #include <stdio.h>
-
- struct AUDIO_HEADER {
-+ int IDex;
- int ID;
- int layer;
- int protection_bit;
-@@ -55,8 +56,8 @@ extern void report_header_error(int err)
-
- extern int scalefac_l[2][2][22];
- extern int scalefac_s[2][2][13][3];
--extern int t_b8_l[2][3][22];
--extern int t_b8_s[2][3][13];
-+extern int t_b8_l[2][2][3][22];
-+extern int t_b8_s[2][2][3][13];
- extern short t_bitrate[2][3][15];
-
- extern int is[2][578];
-@@ -64,7 +65,7 @@ extern float xr[2][32][18];
-
- extern int *t_l,*t_s;
- extern int nch;
--extern int t_sampling_frequency[2][3];
-+extern int t_sampling_frequency[2][2][3];
-
- extern int A_QUIET,A_SHOW_CNT,A_FORMAT_WAVE,A_DUMP_BINARY;
- extern int A_WRITE_TO_AUDIO,A_WRITE_TO_FILE;
-@@ -106,9 +107,14 @@ float xr[2][32][18];
-
- int *t_l,*t_s;
- int nch;
--int t_sampling_frequency[2][3] = {
--{ 22050 , 24000 , 16000},
--{ 44100 , 48000 , 32000}
-+int t_sampling_frequency[2][2][3] = {
-+ { /* MPEG 2.5 samplerates */
-+ { 11025, 12000, 8000},
-+ { 0, }
-+ },{ /* MPEG 2.0/1.0 samplerates */
-+ { 22050 , 24000 , 16000},
-+ { 44100 , 48000 , 32000}
-+ }
- };
-
- /* GUI control stuff */
-@@ -143,28 +149,47 @@ short t_bitrate[2][3][15] = {{
- /* the last sfb is given implicitly on pg.28. of the standard. scalefactors
- * for that one are 0, pretab also
- */
-+/* The new leftmost index is for IDex, so the first six (only three used)
-+ are for MPEG 2.5, and the next six are for MPEG 1.0, 2.0
-+*/
- /* leftmost index denotes ID, so first three tables are for MPEG2 (header->ID==0)
- * and the other three are for MPEG1 (header->ID==1)
- */
- /* 22.05, 24, 16 */
--int t_b8_l[2][3][22]={{ /* table B.8b ISO/IEC 11172-3 */
--{5,11,17,23,29,35,43,53,65,79,95,115,139,167,199,237,283,335,395,463,521,575},
--{5,11,17,23,29,35,43,53,65,79,95,113,135,161,193,231,277,331,393,463,539,575},
--{5,11,17,23,29,35,43,53,65,79,95,115,139,167,199,237,283,335,395,463,521,575}
--},{
--{3,7,11,15,19,23,29,35,43,51,61,73,89,109,133,161,195,237,287,341,417,575},
--{3,7,11,15,19,23,29,35,41,49,59,71,87,105,127,155,189,229,275,329,383,575},
--{3,7,11,15,19,23,29,35,43,53,65,81,101,125,155,193,239,295,363,447,549,575}
--}};
--int t_b8_s[2][3][13]={{ /* table B.8b ISO/IEC 11172-3 */
--{3,7,11,17,23,31,41,55,73,99,131,173,191},
--{3,7,11,17,25,35,47,61,79,103,135,179,191},
--{3,7,11,17,25,35,47,61,79,103,133,173,191}
--},{
--{3,7,11,15,21,29,39,51,65,83,105,135,191},
--{3,7,11,15,21,27,37,49,63,79,99,125,191},
--{3,7,11,15,21,29,41,57,77,103,137,179,191}
--}};
-+int t_b8_l[2][2][3][22]={
-+ {{ /* MPEG 2.5; This table probably isn't correct. */
-+ {5,11,17,23,29,35,43,53,65,79,95,115,139,167,199,237,283,335,395,463,521,575},
-+ {5,11,17,23,29,35,43,53,65,79,95,115,139,167,199,237,283,335,395,463,521,575},
-+ {11,23,35,47,59,71,87,107,131,159,191,231,279,335,399,475,565,567,569,571,573,575}
-+ },{
-+ {0,},
-+ }},{{ /* table B.8b ISO/IEC 11172-3 (MPEG 1.0/2.0) */
-+ {5,11,17,23,29,35,43,53,65,79,95,115,139,167,199,237,283,335,395,463,521,575},
-+ {5,11,17,23,29,35,43,53,65,79,95,113,135,161,193,231,277,331,393,463,539,575},
-+ {5,11,17,23,29,35,43,53,65,79,95,115,139,167,199,237,283,335,395,463,521,575}
-+ },{
-+ {3,7,11,15,19,23,29,35,43,51,61,73,89,109,133,161,195,237,287,341,417,575},
-+ {3,7,11,15,19,23,29,35,41,49,59,71,87,105,127,155,189,229,275,329,383,575},
-+ {3,7,11,15,19,23,29,35,43,53,65,81,101,125,155,193,239,295,363,447,549,575}
-+ }}
-+};
-+int t_b8_s[2][2][3][13]={
-+ {{ /* MPEG 2.5; This table probably isn't correct. */
-+ {3,7,11,17,25,35,47,61,79,103,133,173,191},
-+ {3,7,11,17,25,35,47,61,79,103,133,173,191},
-+ {7,15,23,35,51,71,95,123,159,161,163,165,167}
-+ },{
-+ {0,},
-+ }},{{ /* table B.8b ISO/IEC 11172-3 */
-+ {3,7,11,17,23,31,41,55,73,99,131,173,191},
-+ {3,7,11,17,25,35,47,61,79,103,135,179,191},
-+ {3,7,11,17,25,35,47,61,79,103,133,173,191}
-+ },{
-+ {3,7,11,15,21,29,39,51,65,83,105,135,191},
-+ {3,7,11,15,21,27,37,49,63,79,99,125,191},
-+ {3,7,11,15,21,29,41,57,77,103,137,179,191}
-+ }}
-+};
-
- int args(int argc,char **argv);
- void initialise_decoder(void);
diff --git a/audio/amp/files/patch-audioIO__Linux.c b/audio/amp/files/patch-audioIO__Linux.c
deleted file mode 100644
index a11446effe43..000000000000
--- a/audio/amp/files/patch-audioIO__Linux.c
+++ /dev/null
@@ -1,41 +0,0 @@
---- audioIO_Linux.c.orig 1997-05-31 17:47:58 UTC
-+++ audioIO_Linux.c
-@@ -21,12 +21,14 @@
- #ifdef HAVE_MACHINE_SOUNDCARD_H
- #include <machine/soundcard.h>
- #else
--#include <linux/soundcard.h>
-+#include <sys/soundcard.h>
- #endif
-
- /* optimal fragment size */
-
-+#ifndef OS_BSD
- int AUSIZ = 0;
-+#endif
-
- /* declare these static to effectively isolate the audio device */
-
-@@ -42,6 +44,9 @@ static int volumeIoctl;
- void
- audioOpen(int frequency, int stereo, int volume)
- {
-+#ifdef OS_BSD
-+ int temp;
-+#endif
- int supportedMixers, play_format=AFMT_S16_LE;
-
- if ((audio_fd = open ("/dev/dsp", O_WRONLY, 0)) == -1)
-@@ -78,7 +83,12 @@ audioOpen(int frequency, int stereo, int
- if (volume != -1)
- audioSetVolume(volume);
-
-+#ifdef OS_BSD
-+ temp = AUSIZ;
-+ if (ioctl(audio_fd, SNDCTL_DSP_GETBLKSIZE, &temp) == -1)
-+#else
- if (ioctl(audio_fd, SNDCTL_DSP_GETBLKSIZE, &AUSIZ) == -1)
-+#endif
- die("Unable to get fragment size\n");
- }
-
diff --git a/audio/amp/files/patch-dump.c b/audio/amp/files/patch-dump.c
deleted file mode 100644
index 2cb924ef1944..000000000000
--- a/audio/amp/files/patch-dump.c
+++ /dev/null
@@ -1,28 +0,0 @@
---- dump.c.orig 1997-05-31 20:19:38 UTC
-+++ dump.c
-@@ -46,19 +46,21 @@ int _data,space=0;
- void show_header(struct AUDIO_HEADER *header)
- {
- int bitrate=t_bitrate[header->ID][3-header->layer][header->bitrate_index];
--int fs=t_sampling_frequency[header->ID][header->sampling_frequency];
--int mpg,layer;
-+int fs=t_sampling_frequency[header->IDex][header->ID][header->sampling_frequency];
-+int mpg,mpg_ex,layer;
- char stm[8];
- if (A_QUIET) return;
- layer=4-header->layer;
- if (header->ID==1) mpg=1;
- else mpg=2;
-+ if (header->IDex==1) mpg_ex=0;
-+ else mpg_ex=5;
- if (header->mode==3) strcpy(stm,"mono");
- else strcpy(stm,"stereo");
-
- printf("\n\
- Properties: %s %dHz\n\
--Coding Method: MPEG%1d.0 layer%1d\n\
-+Coding Method: MPEG%1d.%1d layer%1d\n\
- Bitrate: %dkbit/s\n"\
-- ,stm,fs,mpg,layer,bitrate);
-+ ,stm,fs,mpg,mpg_ex,layer,bitrate);
- }
diff --git a/audio/amp/files/patch-formats.c b/audio/amp/files/patch-formats.c
deleted file mode 100644
index 57f6ddb0a4cc..000000000000
--- a/audio/amp/files/patch-formats.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- formats.c.orig 1997-05-31 17:47:58 UTC
-+++ formats.c
-@@ -27,7 +27,7 @@ unsigned char iza[8]={0x64 ,0x61 ,0x74 ,
- int len,fs,i;
-
- len=ftell(out_file)-44;
-- fs=t_sampling_frequency[header->ID][header->sampling_frequency];
-+ fs=t_sampling_frequency[header->IDex][header->ID][header->sampling_frequency];
- rewind(out_file);
- fwrite(ispred,1,20,out_file);
-
diff --git a/audio/amp/files/patch-getbits.c b/audio/amp/files/patch-getbits.c
deleted file mode 100644
index f1e28c2e0853..000000000000
--- a/audio/amp/files/patch-getbits.c
+++ /dev/null
@@ -1,41 +0,0 @@
---- getbits.c.orig 1997-08-20 13:30:21 UTC
-+++ getbits.c
-@@ -91,6 +91,7 @@ unsigned int getbits(int n)
- */
- static inline void parse_header(struct AUDIO_HEADER *header)
- {
-+ header->IDex=_getbits(1);
- header->ID=_getbits(1);
- header->layer=_getbits(2);
- header->protection_bit=_getbits(1);
-@@ -112,11 +113,17 @@ static inline int header_sanity_check(st
- header->bitrate_index==15 ||
- header->sampling_frequency==3) return -1;
-
-+ /* Rule out invalid MPEG 2.5 headers */
-+ if (header->IDex==0 &&
-+ (header->ID==1 || header->layer!=1 ||
-+ header->bitrate_index > 8)) return -1;
-+
- /* an additional check to make shure that stuffing never gets mistaken
- * for a syncword. This rules out some legal layer1 streams, but who
- * cares about layer1 anyway :-). I must get this right sometime.
- */
- if ( header->ID==1 && header->layer==3 && header->protection_bit==1) return -1;
-+
- return 0;
- }
-
-@@ -132,11 +139,7 @@ struct AUDIO_HEADER tmp;
- if ((retval=_fillbfr(4))!=0) return retval;
-
- for(;;) {
-- while ((s=_getbits(12)) != 0xfff) {
-- if (s==0xffe) {
-- parse_header(&tmp);
-- if (header_sanity_check(&tmp)==0) return GETHDR_NS;
-- }
-+ while (_getbits(11) != 0x7ff) {
- if ((retval=readsync())!=0) return retval;
- }
-
diff --git a/audio/amp/files/patch-guicontrol.c b/audio/amp/files/patch-guicontrol.c
deleted file mode 100644
index b32c284fb929..000000000000
--- a/audio/amp/files/patch-guicontrol.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- guicontrol.c.orig 1997-08-23 11:30:51 UTC
-+++ guicontrol.c
-@@ -375,7 +375,8 @@ int decodeMPEG_2(int inFilefd)
- break;
- case GETHDR_SYN: warn("oops, we're out of sync.\n");
- break;
-- default:
-+ default:
-+ break;
- }
- break;
- }
diff --git a/audio/amp/files/patch-layer2.c b/audio/amp/files/patch-layer2.c
deleted file mode 100644
index a127aaf76529..000000000000
--- a/audio/amp/files/patch-layer2.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- layer2.c.orig 1997-06-16 17:53:15 UTC
-+++ layer2.c
-@@ -34,7 +34,7 @@ int hsize,fs,mean_frame_size;
- if (header->protection_bit==0) hsize+=2;
-
- bitrate=t_bitrate[header->ID][3-header->layer][header->bitrate_index];
-- fs=t_sampling_frequency[header->ID][header->sampling_frequency];
-+ fs=t_sampling_frequency[header->IDex][header->ID][header->sampling_frequency];
- if (header->ID) mean_frame_size=144000*bitrate/fs;
- else mean_frame_size=72000*bitrate/fs;
-
diff --git a/audio/amp/files/patch-layer3.c b/audio/amp/files/patch-layer3.c
deleted file mode 100644
index e00700b24df4..000000000000
--- a/audio/amp/files/patch-layer3.c
+++ /dev/null
@@ -1,22 +0,0 @@
---- layer3.c.orig 1997-08-18 12:42:17 UTC
-+++ layer3.c
-@@ -61,7 +61,7 @@ int mean_frame_size,bitrate,fs,hsize,ssi
- /* MPEG2 only has one granule
- */
- bitrate=t_bitrate[header->ID][3-header->layer][header->bitrate_index];
-- fs=t_sampling_frequency[header->ID][header->sampling_frequency];
-+ fs=t_sampling_frequency[header->IDex][header->ID][header->sampling_frequency];
- if (header->ID) mean_frame_size=144000*bitrate/fs;
- else mean_frame_size=72000*bitrate/fs;
-
-@@ -96,8 +96,8 @@ int mean_frame_size,bitrate,fs,hsize,ssi
-
- /* these two should go away
- */
-- t_l=&t_b8_l[header->ID][header->sampling_frequency][0];
-- t_s=&t_b8_s[header->ID][header->sampling_frequency][0];
-+ t_l=&t_b8_l[header->IDex][header->ID][header->sampling_frequency][0];
-+ t_s=&t_b8_s[header->IDex][header->ID][header->sampling_frequency][0];
-
- /* debug/dump stuff
- */
diff --git a/audio/amp/files/patch-position.c b/audio/amp/files/patch-position.c
deleted file mode 100644
index 8c446f7e38ff..000000000000
--- a/audio/amp/files/patch-position.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- position.c.orig 1997-05-31 17:47:58 UTC
-+++ position.c
-@@ -40,7 +40,7 @@ struct AUDIO_HEADER tmp;
- }
-
- bitrate=t_bitrate[tmp.ID][3-tmp.layer][tmp.bitrate_index];
-- fs=t_sampling_frequency[tmp.ID][tmp.sampling_frequency];
-+ fs=t_sampling_frequency[tmp.IDex][tmp.ID][tmp.sampling_frequency];
- if (tmp.ID) mean_frame_size=144000*bitrate/fs;
- else mean_frame_size=72000*bitrate/fs;
- fillbfr(mean_frame_size + tmp.padding_bit - hsize);
-@@ -73,7 +73,7 @@ struct AUDIO_HEADER tmp;
- * so we have to go back one frame + 4 bytes + 1 byte (in case padding was used).
- */
- bitrate=t_bitrate[tmp.ID][3-tmp.layer][tmp.bitrate_index];
-- fs=t_sampling_frequency[tmp.ID][tmp.sampling_frequency];
-+ fs=t_sampling_frequency[tmp.IDex][tmp.ID][tmp.sampling_frequency];
- if (tmp.ID) mean_frame_size=144000*bitrate/fs;
- else mean_frame_size=72000*bitrate/fs;
-
diff --git a/audio/amp/files/patch-rtbuf.c b/audio/amp/files/patch-rtbuf.c
deleted file mode 100644
index 2700b2f62feb..000000000000
--- a/audio/amp/files/patch-rtbuf.c
+++ /dev/null
@@ -1,21 +0,0 @@
---- rtbuf.c.orig 1997-08-23 10:16:40 UTC
-+++ rtbuf.c
-@@ -337,15 +337,15 @@ int apar;
- (mpegheader->mode != 3) ? "stereo" : "mono");
- return -1;
- }
-- apar = t_sampling_frequency[mpegheader->ID][mpegheader->sampling_frequency];
-+ apar = t_sampling_frequency[mpegheader->IDex][mpegheader->ID][mpegheader->sampling_frequency];
- if (ioctl(audio_fd, SNDCTL_DSP_SPEED, &apar) == -1) {
- perror("ioctl: SNDCTL_DSP_SPEED");
- return -1;
- }
-- if (apar != t_sampling_frequency[mpegheader->ID][mpegheader->sampling_frequency]) {
-+ if (apar != t_sampling_frequency[mpegheader->IDex][mpegheader->ID][mpegheader->sampling_frequency]) {
- fprintf(stderr, "Warning: requested sampling rate %d does not "
- "match effective %d\n",
-- t_sampling_frequency[mpegheader->ID][mpegheader->sampling_frequency],
-+ t_sampling_frequency[mpegheader->IDex][mpegheader->ID][mpegheader->sampling_frequency],
- apar);
- }
-
diff --git a/audio/amp/pkg-descr b/audio/amp/pkg-descr
deleted file mode 100644
index 81e0eebbf2fe..000000000000
--- a/audio/amp/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-amp (Audio Mpeg Player) is an MPEG audio decoder which was originally started
-putting together as a side project of the MPEG hardware design project at
-FER/Zagreb - just to confirm my knowledge of the standard. It works with
-both MPEG1 and MPEG2 audio streams, layer3 and for now the multichannel
-extensions defined in MPEG2 too.