aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2011-06-28 19:59:02 +0000
committerJuergen Lock <nox@FreeBSD.org>2011-06-28 19:59:02 +0000
commit3236095b4891417770965f5682404078540e44af (patch)
treedac134606331f2af4153551c481b60aaf8046feb /audio
parent263f887bfbcc3870432d0f2cc39b86ecc049acc2 (diff)
downloadports-3236095b4891417770965f5682404078540e44af.tar.gz
ports-3236095b4891417770965f5682404078540e44af.zip
Fix build with clang.
Notes
Notes: svn path=/head/; revision=276607
Diffstat (limited to 'audio')
-rw-r--r--audio/gramofile/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/audio/gramofile/Makefile b/audio/gramofile/Makefile
index b48ee0a93c00..309db5193221 100644
--- a/audio/gramofile/Makefile
+++ b/audio/gramofile/Makefile
@@ -24,6 +24,9 @@ LIB_DEPENDS= fftw.2:${PORTSDIR}/math/fftw
ALL_TARGET= gramofile
USE_GMAKE= yes
USE_PERL5= yes
+USE_CSTD= gnu89
+MAKE_ARGS+= CC=${CC}
+MAKE_ARGS+= CXX=${CXX}
PERLCOREDIR= ${LOCALBASE}/lib/perl5/${PERL_VERSION}/mach/CORE
MAKE_ARGS+= PERLCOREDIR=${PERLCOREDIR}